SRS light flashing but no fault codes - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 33 (permalink) Old 08-27-2011, 12:37 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
SRS light flashing but no fault codes

Hi I have a bit of a problem my merc is a 2003 e270 cdi w211 i had a problem with the passenger recognition matt but have that resolved now the problem is the computer is coming back with "no fault codes" so everything is good but the dashboard still has the warning message showing and the SRS light is flashing the computer cannot reset the instrument panel, I thought this would automatically reset itself but has not the computer being used is a MB computer and says cannot communicate with instrument panel, can anyone help me with problem thanks, Nigel
nobjob is offline  
Sponsored Links
Advertisement
 
post #2 of 33 (permalink) Old 08-27-2011, 12:56 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 20,105
Mentioned: 22 Post(s)
Quoted: 1148 Post(s)
Lifetime Premium Member
The light flashing is not a cluster problem. It is coming from the SRS module under the ashtray. Run a quick test and make sure all restraint systems have a check mark. If one
has a [!] or F then that is what is causing the problem.
Noodles is offline  
post #3 of 33 (permalink) Old 08-27-2011, 01:14 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,616
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Does the computer connect with the SRS system?

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
 
post #4 of 33 (permalink) Old 08-27-2011, 06:26 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
done that and yes all airbag and restraint system have a check next to them the only one that has an [!] is the instrument cluster, there are no fault codes coming up at all the computer says everything is ok
nobjob is offline  
post #5 of 33 (permalink) Old 08-27-2011, 06:29 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
yes the computer connects to the SRS system and all is fine but for some reason it will not clear from the dash and the computer cannot connect to the instrument cluster to clear it, getting a bit pissed off seeing the srs light keep flashing for no reason,
nobjob is offline  
post #6 of 33 (permalink) Old 08-27-2011, 06:47 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,616
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Just wait a minute here, is the SRS light flashing or the seat belt warning light? Try fastening your seat belt and see if the light stops flashing.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #7 of 33 (permalink) Old 08-27-2011, 07:14 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no no its the srs light is flashing the seat belt light is working fine..and the message say srs restraint system faulty visit workshop.. but when plugged in it comes back "no fault codes present" but cannot clear the fault from the dash
nobjob is offline  
post #8 of 33 (permalink) Old 08-27-2011, 07:23 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,616
Mentioned: 3 Post(s)
Quoted: 312 Post(s)
Quote:
Originally Posted by nobjob View Post
no no its the srs light is flashing the seat belt light is working fine..and the message say srs restraint system faulty visit workshop.. but when plugged in it comes back "no fault codes present" but cannot clear the fault from the dash
Have you run the short test and looked at the fault codes on other systems? Many of these systems are connected and the fault may not actually be shown on the SRS system.

ERIC.

___________________________________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell
eric242340 is offline  
post #9 of 33 (permalink) Old 08-27-2011, 07:48 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2010
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
all fault codes were cleared but fault remained on dash, and i drove the car for a while then it was plugged in again and it says no fault codes present, but the dash is still telling me there is a fault i thought this would clear automatically but it did not so tried going into the instrument cluster to clear it with the computer and the computer returns saying it cannot communicate with the instrument cluster and it is the right MB computer that is being used.so not sure what to try next
nobjob is offline  
post #10 of 33 (permalink) Old 08-27-2011, 07:55 AM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
hey ppl i have diagonosed the problem of OVP replacement or fuse replacement on my 2004 w211 e320cdi through going over different threads.. But i cannot find where it is on the W211.. i could'nt find it.. can somebody help!!

Thanks
harisE320 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
ABS Fault Reading Fault Codes DavidUK1 V-Class 3 09-26-2012 04:27 AM
94 e320... OBD not flashing codes daknuts W124 E,CE,D,TD Class 12 09-02-2010 01:57 PM
1995 RST pin 21 DM flashing light..no codes? JMINSD R129 SL-Class 5 06-17-2010 03:20 PM
fault codes? jmoney6 W124 E,CE,D,TD Class 3 05-14-2007 04:55 PM
Fault Codes aqorps W124 E,CE,D,TD Class 12 08-18-2006 10:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome