Oil leak Help! - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-09-2011, 06:33 PM
BenzWorld Junior Member
 
Date registered: Jul 2004
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Oil leak Help!

My 07 e350 2 wheel drive has started to leak oil. It only has 54k. It is coming from the back of the engine in front of the driver side close to the firewall. It looks like it is coming from below the valve cover gasket but not the oil cover. Any ideas and can it be fixed without taking it to the dealer. I am somewhat mechanical. Thanks
Lotusing is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-09-2011, 10:49 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 14,232
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Lifetime Premium Member
You are going to have to clean up that area and then leak for its source with it cleaned up.
Too hard to diagnose over the net without pics.
Also a small amount of oil can look like a lot more than it is when it spreads out.
Noodles is offline  
#3 (permalink) Old 04-10-2011, 05:35 AM
BenzWorld Junior Member
 
Benzer0matic's Avatar
 
Date registered: Mar 2010
Vehicle: 08' E350 4matic
Location: NY/NJ
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My 08' developed a leak in the same location, it was the valve cover gasket and, I think, some sort of expansion plugs. Fixed under warranty
Benzer0matic is offline  
#4 (permalink) Old 04-10-2011, 10:45 AM
BenzWorld Elite
 
Roadking999's Avatar
 
Date registered: Apr 2008
Vehicle: E350 4M 06
Location: Snow Belt
Posts: 2,039
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
On my 06 E350 4M,I've had the valve cover gasket, expansion plug and camshaft cap (round black 2 inch cover) all leak at different times, they were all repaired/replaced under warranty. If you're out of warranty and you want to DIY then do what Noodles suggested above to find the source, use a mirror to pinpoint the leak.
Roadking999 is offline  
#5 (permalink) Old 04-10-2011, 11:05 AM
BenzWorld Junior Member
 
Date registered: Jul 2004
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the reply. It looks like the expansive plug is leaking. Looking at it closer the valve cover is dry. Is it difficult the change the expansive plug?
Lotusing is offline  
#6 (permalink) Old 04-10-2011, 12:58 PM
BenzWorld Elite
 
konigstiger's Avatar
 
Date registered: Jan 2007
Vehicle: '71 Pinto
Location: North Scottsdale, AZ
Posts: 2,063
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Quote:
Originally Posted by Lotusing View Post
It looks like the expansive plug is leaking.
Check PM
konigstiger is offline  
#7 (permalink) Old 04-10-2011, 04:08 PM
BenzWorld Member
 
Date registered: May 2006
Vehicle: 2005 E320, 87 560SL, 81 240D 4 spd with 300D engine, 2002 Sierra Denali, 97 Volvo 850 T5, 96 Mustang
Location: Kirkland, WA
Posts: 364
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Our 05 started to leak last month and I had it fixed under warranty, eleven hours labor for several different things on the engine (valve covers and something else) and 2 leaks on transmission. Free!!!

Dan

2005 E320 CPO
2011 Escape Limited
1984 300 Turbo Diesel
1984 Mustang 12.9 @ 109
1997 Volvo 850 Turbo
1998 Volvo C70
3 Boats
3 teenage drivers, OMG help me!
DANSMB is offline  
#8 (permalink) Old 04-10-2011, 05:40 PM
BenzWorld Junior Member
 
Date registered: Jul 2004
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Free, how did that happen?
Lotusing is offline  
#9 (permalink) Old 04-11-2011, 12:00 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 14,232
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Lifetime Premium Member
He has the CPO extension on the warranty from MB.
Noodles is offline  
#10 (permalink) Old 04-14-2011, 07:21 PM
BenzWorld Extremist
 
Date registered: Nov 2002
Vehicle: '82 500sec euro, '95 Ford F150
Location: West Palm Beach, Fl
Posts: 942
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
the e320 wagon I bought recently is leaking like sieve from the upper oil pan AND the rear main seal. As most of you know there is no gasket, only sealant (why?)

BTW the car only has 68K.

It also has the usual bad motor and trans mounts- vibrating like a well used Kia.

All these issues are preplexing to me considering the overall excellent condition of the car, and my previous experience with the w126 cars.
roadhouse is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Engine oil leak - front pulley oil leak? southbusiness W210 E-Class 4 04-25-2009 05:41 PM
Head gasket oil leak...stop leak products? lisam W202 C-Class 8 04-11-2009 02:55 PM
Wiring loom - insulation falling off, water leak, oil leak sjc123456789 W124 E,CE,D,TD Class 3 02-10-2006 10:24 AM
oil leak... motor honey?...leak stop? b2d W123 E,CE,D,CD,TD,TE Class 1 04-11-2005 03:07 PM
My car is in the shop...Oil leak, windshield washer leak, and screw came off. chanm W163 M-Class 3 05-23-2003 06:21 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome