IS IT MOTOR MOUNTS OR TRANSMISSION MOUNT? - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-31-2010, 07:57 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Posts: 61
Post IS IT MOTOR MOUNTS OR TRANSMISSION MOUNT?

03' E320 (W211) - i have a slight vibration when i start the car and accelerate. when placed in nuetral smooth no vibration. you will hear the vibration rattling my central air outlet grill which is above the two center a/c vents at acceleration, but goes away. i now hear a slight clicking noise when driving the down the road, but goes away after the engine warms up real good. i believe it could be the mounts, but which? i would like to think just the transmission mount (easy fix). but how do you tell without taking to dealership? is there an answer for this question? thanks in advance for the your opinions.
domingo56 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-31-2010, 12:57 PM   #2 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Posts: 66
hey bud dont worry too much im pretty sure it was the mounts, i had the same problem and once it warms up it stops. Its the two engine mounts and the tranny mount. when changing be sure to use oem dealer parts not replicas mine had been changed with a replica it was horrible quality. The total for all 3 on mine was 475 plus tax so 520.... around 70-80k miles this is normal
__________________
E320 +Sport +Navi +Harmon Kardon +Dual Spoilers +All lights White/Blue + Exhaust Tips -Side markers


mike2291 is offline   Reply With Quote
Old 08-31-2010, 08:50 PM   #3 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1988 Mercedes Benz 300E 144256 Miles. 2003 E500 105.XXX miles. 2005 ML55 AMG 72.XXX Miles
Location: denver
Posts: 204
change both engine and transmission, engine mounts go first fallowed by trans mounts. I bought 2 engine mounts for 117$ with shipping and handling and 1 trans mount for 30$ with shipping and handling. My local mechanic wanted 480$ total to do the job but i decided to save some $$$ and so it my self. Good luck buddy
Bruce24 is offline   Reply With Quote
Old 09-03-2010, 09:25 AM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: 2005 W211 E320
Location: Hong Kong
Posts: 24
oohhh!!! I have the same problem jsut wanted to go back for body checking, if I wanted to DIY, please anyone can share the photo for the replace process?

Thanks.
crysnet is offline   Reply With Quote
Old 09-03-2010, 09:37 AM   #5 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Posts: 61
Post

Quote:
Originally Posted by domingo56 View Post
03' E320 (W211) - i have a slight vibration when i start the car and accelerate. when placed in nuetral smooth no vibration. you will hear the vibration rattling my central air outlet grill which is above the two center a/c vents at acceleration, but goes away. i now hear a slight clicking noise when driving the down the road, but goes away after the engine warms up real good. i believe it could be the mounts, but which? i would like to think just the transmission mount (easy fix). but how do you tell without taking to dealership? is there an answer for this question? thanks in advance for the your opinions.
just found out that my transmission mount is ok and my left motor mount is leaking. now to replace the two motor mounts. is bilstein from parts geek a good product to replace mercedes orignal motor mounts? what does the forum (who has replaced their motor mounts) say on motor mount replacement? thanks in advance.
domingo56 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
1999 230SLK Engine mounts and Automatic Transmission mount zerlin R170 SLK Class 13 10-11-2011 08:29 PM
Motor Mounts/Transmission Mounts akil_parker W220 S-Class 7 09-30-2011 04:56 AM
W210 Motor/Transmission mounts Drahcir For Sale/Wanted/Trade/Giveaway 0 03-28-2010 01:58 PM
how do you replace transmission mount and engine mounts on 2003 s600? 2003 s600 W220 S-Class 1 04-15-2009 11:09 PM
C/E class Motor AND Transmission mounts NOLA911 For Sale/Wanted/Trade/Giveaway 0 08-14-2008 09:12 AM


All times are GMT -7. The time now is 02:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.