E350 check engine light and engine noise issue - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-24-2010, 01:39 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Jun 2010
Location: S. Fla
Posts: 3
E350 check engine light and engine noise issue

Let me first let me let all you know that there is a lot of good information on these forums and thanks for the information.

I have an issue with my 2006 E350. I am the original owner and currently have 47,700 miles. I have had an issue with my car for a couple years now. The engine runs smooth but make a noise like diesel engine. I brought the car in under warranty a couple times for the issue, but they could not hear it or identify it. Of course, after my warranty expried, about 3 months later, the engine light came on with these codes (I have access to mercedes certified techs outside of dealer to run codes):

P0016 Crankshaft Position –Camshaft Position Correlation Bank 1 Sensor A
P0017 Crankshaft Position –Camshaft Position Correlation Bank 1 Sensor B

Both of these sensors were replaced and the engine light went off for about a week, and now presents with the same codes. I have been told the codes and the sound have to do with the balance shaft. Is this the case in your experiences? If so, is it really a $5k service task?

Any other ideas out there?

Should I try to make an issue of it with the dealer, since it has already been documented as an issue a couple when I brought it in for the noise. The only reason I hesitate to do that is because I do not want that to have an impact on me if I decide to get an extended warranty to fix the problem.

Thanks for your input guys!
skalacorp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-24-2010, 01:43 PM   #2 (permalink)
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 13,897
Lifetime Premium Member
This is well known issue and MB should cover it. Talk to the service manager. If he does
not attempt to get good will from MB then have the dealer give you the contact info
for the regional MB manager in charge of your region.
Noodles is offline   Reply With Quote
Old 06-24-2010, 01:59 PM   #3 (permalink)
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 28,806
Definitely hound the dealer particularly since it existed prior to the warranty expiration.

Check out this thread (particularly the pics!) at benz obsession to understand what's going under the engine covers.

Are you OBSESSED about your Benz? |Attn! Owners '06-'07 MB's with M272 or M273 engines
__________________
Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline   Reply With Quote
Old 06-24-2010, 02:03 PM   #4 (permalink)
BenzWorld Elite
 
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Dealer should refer to Dealer Technical Bulletin (DTB) S-B-03.30/08j for information on balance shaft problems.
__________________
Kent Christensen
Albuquerque
'07 GL320CDI
lkchris is offline   Reply With Quote
Old 06-24-2010, 02:14 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2009
Location: SoCal
Posts: 30
Yes, it's about a $5K fix. Mine was done under warranty.
hiker64012 is offline   Reply With Quote
Old 06-25-2010, 08:18 AM   #6 (permalink)
BenzWorld Member
 
Date registered: Nov 2007
Posts: 114
Service shuttle... R350 at local dealer near me had diesel sounding engine.... too i ask is this the Diesel version and he said no
hawk25 is offline   Reply With Quote
Old 06-25-2010, 08:24 AM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Jun 2010
Location: S. Fla
Posts: 3
Thanks for all the great input everyone. I'll you know the outcome.
skalacorp is offline   Reply With Quote
Old 08-24-2010, 10:24 AM   #8 (permalink)
BenzWorld Newbie
 
Date registered: May 2010
Posts: 1
Quote:
Originally Posted by skalacorp View Post
Thanks for all the great input everyone. I'll you know the outcome.
I was wondering what happened?? Did you get it fixed? I have the same issue.... !!!
Yasso is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
06 Mercedes E350 check engine and code issue skalacorp W203 C32 AMG, C55 AMG 0 06-24-2010 01:24 PM
Check Engine Light 2006 E350 gemee W211 E-Class 4 02-28-2010 03:25 AM
Check Engine Light 2006 E350 gemee W212 E-Class 5 02-23-2010 11:13 PM
Check engine light issue Chipsterbenz W208 CLK Class 4 02-19-2010 03:24 PM
2003 E350 4MATIC - Check Engine Light 1099gentry W211 E-Class 8 10-27-2009 07:47 PM


All times are GMT -7. The time now is 04:57 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.