Troubleshooting Alarm - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-31-2010, 11:18 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 06 CDI
Posts: 23
Troubleshooting Alarm

Hello...My alarm stopped working for some reason. I know this because the it doesn't chirp when i unlock/lock the car. I checked the fuses in the trunk and the driver side panel of the dash. nothing blew.

So i am stuck in the next steps of figuring out whats going on. I have no information in the dash indicating any doors or hood pins arent working properly.

Any suggestions?
Thanks.
beafer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-31-2010, 11:32 AM   #2 (permalink)
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 13,906
Lifetime Premium Member
What year is your 211?
Noodles is offline   Reply With Quote
Old 05-31-2010, 11:36 AM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 06 CDI
Posts: 23
sorry i didnt mention that before.

its a 2006 CDI
Thanks.
beafer is offline   Reply With Quote
Old 05-31-2010, 11:53 AM   #4 (permalink)
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 13,906
Lifetime Premium Member
The lack of the chirp does not always mean the alarm is broken. Are you getting
the flashing LED on the dash once you lock the car with the remote?
Noodles is offline   Reply With Quote
Old 05-31-2010, 12:05 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 06 CDI
Posts: 23
the indicators on the dash light up fine as well the outside lights. All the functions of the remote (lock/unlock/trunk) work EXCEPT the panic.
beafer is offline   Reply With Quote
Old 05-31-2010, 12:10 PM   #6 (permalink)
BenzWorld Elite
 
konigstiger's Avatar
 
Date registered: Jan 2007
Posts: 1,988
Quote:
Originally Posted by beafer View Post
the indicators on the dash light up fine as well the outside lights. All the functions of the remote (lock/unlock/trunk) work EXCEPT the panic.
Siren unit may need replacement I can send instructions for visual inspection of connections and/or DIY replacement if out of warranty – PM email address.
konigstiger is offline   Reply With Quote
Old 05-31-2010, 12:15 PM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 06 CDI
Posts: 23
it is out of warranty. Does the alarm atleast blink the lights when its going off, like if i push the panic?

Sending PM now. Thanks.
beafer is offline   Reply With Quote
Old 10-26-2010, 08:01 PM   #8 (permalink)
BenzWorld Newbie
 
Date registered: Feb 2009
Vehicle: 2007 E350 4MATIC
Location: Omaha, NE
Posts: 1
Quote:
Originally Posted by konigstiger View Post
Siren unit may need replacement I can send instructions for visual inspection of connections and/or DIY replacement if out of warranty – PM email address.
Just came across this thread and it's the same situation I'm in - the siren/alarm on my 2006 E350 no longer works. When I press the panic button the lights flash but there is no sound. My toddler son had apparently hit/mashed the panic button and it had been going off in our detached garage for quite some time. Now it no longer makes any noise at all.

Any way you could share the visual inspection or DIY replacement instructions?
jochod is offline   Reply With Quote
Old 08-09-2011, 09:38 AM   #9 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2011
Location: Southampton, England
Posts: 16
Sounds like it is definitely the alarm siren unit which is faulty. I had the same fault in a 30,000 mile UK R/H drive 2007 220 CDI and the alarm is under the R/H wheel arch. The mechanic replaced it and it was covered in road mess and had destroyed itself. A very common fault in Mercedes E Class, apparently. The high tone horn (the one that is at the front of the car) had similarly perished also, and was replaced too.
Organist is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
AC troubleshooting brandon671 W126 S,SE,SEC,SEL,SD,SDL Class 2 09-15-2007 12:26 AM
Can the factory alarm be codes so that it beeps when the alarm is engaged and the light flash HACK THT W163 M-Class 0 03-18-2006 07:10 PM
AC Troubleshooting mark2280 W126 S,SE,SEC,SEL,SD,SDL Class 4 06-21-2005 09:24 PM
AC Troubleshooting mark2280 W126 S,SE,SEC,SEL,SD,SDL Class 0 06-16-2005 11:01 AM
Audio clip of the panic alarm - alarm + Hella air horns... Drew W163 M-Class 0 10-10-2003 06:35 PM


All times are GMT -7. The time now is 06:23 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.