How to reset the trip meter - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-17-2009, 12:10 AM Thread Starter
BenzWorld Extremist
 
BenzE500's Avatar
 
Date registered: Dec 2005
Vehicle: ABCLOSING
Location: California
Posts: 865
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
How to reset the trip meter

Anyone know how to do this I lost my manual
BenzE500 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-17-2009, 07:06 AM
BenzWorld Junior Member
 
Date registered: Aug 2009
Vehicle: 2006 E350 and 2006 C280 4Matic
Location: Northern Virginia
Posts: 24
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
What year is your car? You can view the owners manuals here:
Mercedes-Benz - Home of C, E, S, CLK, CLS, CL, SLK, SL, SLR, R, GLK, M, GL, G Class

This should be able to answer any of your questions.
stingray71 is offline  
post #3 of 6 (permalink) Old 08-18-2009, 01:45 PM
BenzWorld Member
 
Tom4697's Avatar
 
Date registered: Aug 2006
Vehicle: '13 E350
Location: Mass. USA
Posts: 198
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Trip odometer
Make sure you are viewing the trip odometer
display ( page 153).
If it is not displayed, press button è
or ÿ repeatedly until the trip
odometer appears.
Press and hold the reset button1 ( button/knob to the left of your instrument cluster )
( page 150) until the trip odometer is
reset.

Copied from my 2006 E350 owners manual, hope thats what you were looking for.
T.

Today will be tomorrows history, make it count.
Tom4697 is offline  
post #4 of 6 (permalink) Old 02-23-2011, 12:13 AM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 2002 C230 Kompressor
Location: San Antonio, TX
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
This thread was awesomo.

I give this a bump and +1 because as a new user who didnt get a user manual when the dealer sold me the car, this made my life (and my mechanics) so much easier...
The_Kompressor is offline  
post #5 of 6 (permalink) Old 02-23-2011, 06:57 AM
BenzWorld Junior Member
 
Date registered: Aug 2009
Vehicle: 2006 E350 and 2006 C280 4Matic
Location: Northern Virginia
Posts: 24
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
stingray71 is offline  
post #6 of 6 (permalink) Old 09-14-2015, 06:24 AM
BenzWorld Newbie
 
Date registered: Sep 2015
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
2007 C Saloon 320 CDi - trip odometer used to be displayed a few seconds after starting ignition. After a service this function was lost and must now press down arrow on multi function control to display.

Car gone back to dealer twice and they cannot explain why or how to fix - was the loss of automatic display of trip odometer due to software upgrade? Hubby's car (2010 E estate) still display the trip odometer after ignition like mine used to.
Upsetatloss is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    I reset my trip meter and now the odo stopped working! vr6freak W124 E,CE,D,TD Class 4 10-06-2007 10:07 AM
    trip meter finally broke daryn R/C107 SL/SLC Class 2 11-14-2006 07:28 PM
    odometer/trip meter repair in Maryland? ZRGator W140 S-Class 0 09-28-2006 01:48 PM
    trip meter stopped working help me? drebdy W140 S-Class 0 02-09-2006 10:26 AM
    trip meter stopped what could be the cause? drebdy W140 S-Class 0 05-15-2005 09:33 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome