Bluetooth "Puck with Tail" version coding problems - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-15-2008, 02:56 AM   #1 (permalink)
BenzWorld Junior Member
 
jamsong's Avatar
 
Date registered: Aug 2002
Vehicle: 2004 E320S4
Location: Portland, Oregon USA
Posts: 27
Bluetooth "Puck with Tail" version coding problems

I have an 04 E320 and I got the "CP Interface Kit with Bluetooth", part no: B 67 87 5855
I am able to pair with my wife's bluetooth phone (RAZR v3) but (predictably without version coding) I cannot hear on either side of the call and when I press "Phone" on the Comand system, it says, "Phone not installed"

I installed it which was very easy and then I took it to the dealer to be version coded.

I gave my service advisor a copy of the diagram of the Star Diagnosis of the Tele-Aid page with the "Portable cellular telephone" set to "Fitted" and asked them to do the same with my car.

I was not present when they did this so obviously, the phone was not still paired when the dealer did the version coding. Moreover, I was unable to pick up the car until after hours so I couldn't talk to a tech but I picked up the car and the bluetooth kit still does not work. I get the same "Phone not installed" message. Still got charged $56.25 for .5hrs of labor...

This is what my service invoice says:
"Checked and changed version coding within VTEL control module as per client request and found that vehicle not equipped with bluetooth control module."

So my question, am I missing anything? It seems like others just installed the device and then got their dealership service to change one setting in the Tele-aid.
Do I need to have the phone paired while it's being version coded?
Are there other settings that need to be changed on the Star Diagnosis?

I won't be able to talk to a service advisor or tech until Monday.
jamsong is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-15-2008, 06:43 PM   #2 (permalink)
BenzWorld Elite
 
Yacht Master's Avatar
 
Date registered: Nov 2006
Vehicle: E-ZGO 53 HP., 99 E 430 sport, 04 E55 AMG, 2008 Tahoe LTZ Sold Porsche to Brother
Location: Caribbean/Florida/Colorado
Posts: 1,578
The tech needs yet one more shot at it.
Call the SA and ask him for a purchase order to reimburse you for training their tech.
It really is so simple a caveman could do it. In less than 5 min.
Yacht Master is offline   Reply With Quote
Old 03-15-2008, 11:05 PM   #3 (permalink)
BenzWorld Junior Member
 
jamsong's Avatar
 
Date registered: Aug 2002
Vehicle: 2004 E320S4
Location: Portland, Oregon USA
Posts: 27
Quote:
Originally Posted by Yacht Master View Post
The tech needs yet one more shot at it.
Call the SA and ask him for a purchase order to reimburse you for training their tech.
It really is so simple a caveman could do it. In less than 5 min.
Do you suppose that the tech just screwed up or put the settings back to default?
I'm thinking the tech didn't follow my instructions and just programmed the "Bluetooth System" to "Fitted" and left the "Portable Cellular Telephone" to "Not Fitted" on the Star Tele-aid page.
Hopefully, I'll get this answer on Monday.

Also, are you saying, definitively, that there is nothing more to do than what I described?

Thanks for the reply.
jamsong is offline   Reply With Quote
Old 03-16-2008, 12:20 AM   #4 (permalink)
BenzWorld Veteran
 
Date registered: Mar 2007
Vehicle: ML350
Location: chicago,IL
Posts: 686
Quote:
Originally Posted by jamsong View Post
Do you suppose that the tech just screwed up or put the settings back to default?
I'm thinking the tech didn't follow my instructions and just programmed the "Bluetooth System" to "Fitted" and left the "Portable Cellular Telephone" to "Not Fitted" on the Star Tele-aid page.
Hopefully, I'll get this answer on Monday.

Also, are you saying, definitively, that there is nothing more to do than what I described?

Thanks for the reply.
that is most likely the issue... remember that the puck with tail module is a newer and not very common so there may be one guy in service who has familiarity with it.. its not their fault, there is simply too much for any one guy to learn.. Thats why forums like this are great. You can get the exact procedure information and pass that on to the tech doing the work...
rob13572468 is offline   Reply With Quote
Old 03-16-2008, 12:37 AM   #5 (permalink)
BenzWorld Extremist
 
Mr. Pie's Avatar
 
Date registered: Nov 2004
Vehicle: CLK320
Location: Kirkland, WA
Posts: 945
Send a message via MSN to Mr. Pie
I or I should say the tech had some problems with my wife's car recently, but it turned out to be a short in the communications system. The good news it was caught and repaired under warranty, the bad news, my wife was without her car for a week.

This issue had everyone stumped that even a master tech from Cali couldn't figure it out. The guy here ended up tracing the wires to the trunk and found that one of the harnesses was getting an intermitent connection. All the work done would have cost close to $2,000.00 in repairs but was covered as I said.

End result is that it is working now and while her car was in the shop she got to drive around in a 2008 C300.

Anyway, maybe there is a short somewhere as well. Just a thought.
__________________
2001 W208 Black Opal Metallic
K2a, K3, K4 + COMAND, HID halo projector headlights, flat hood emblem, chrome cluster rings, Bluetooth phone adapter, MB illuminated door sills, AMG steering wheel, AMG pedals, chrome AMG II dual spoke wheels, Nitto NT 555 Extreme Performance, 235/35/19 front, 265/30/19 rear
Mr. Pie is offline   Reply With Quote
Old 03-16-2008, 12:38 AM   #6 (permalink)
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 221.122 & 212.025 & 204.089 & 906.633
Location: Europe
Posts: 10,110
Quote:
Originally Posted by jamsong View Post
I'm thinking the tech didn't follow my instructions and just programmed the "Bluetooth System" to "Fitted" and left the "Portable Cellular Telephone" to "Not Fitted" on the Star Tele-aid page.
What did you exactly ask the tech to do? We do not have this option in Europe but I thought you would have to code the IC (phone present from optional equipment) and the Tele-Aid CTEL( MHI) fitted?
Diesel Benz is offline   Reply With Quote
Old 03-16-2008, 06:50 AM   #7 (permalink)
BenzWorld Elite
 
Yacht Master's Avatar
 
Date registered: Nov 2006
Vehicle: E-ZGO 53 HP., 99 E 430 sport, 04 E55 AMG, 2008 Tahoe LTZ Sold Porsche to Brother
Location: Caribbean/Florida/Colorado
Posts: 1,578
Quote:
Originally Posted by jamsong View Post
Do you suppose that the tech just screwed up or put the settings back to default?
I'm thinking the tech didn't follow my instructions and just programmed the "Bluetooth System" to "Fitted" and left the "Portable Cellular Telephone" to "Not Fitted" on the Star Tele-aid page.
Hopefully, I'll get this answer on Monday.

Also, are you saying, definitively, that there is nothing more to do than what I described?

Thanks for the reply.
Yes, from your description the setting for "Phone present" was not made.
My understanding is that the puck with tail takes the place of the phone and there should be no reference to Bluetooth in the SDS Star programing.
It is just that simple "phone present" is all that need be changed.
They will "get it", and you will love it. Once it is working make a call before you leave the dealership to a friend so that you can asses the sound quality, call someone with a good ear.
Once that is done if the audio out quality (your microphone) is poor they have updated a module to improve the sound of your out going signal.
I will try to find the posts.
Here is the DTB P-B-82.70/3386 and the part number # A 211 82 0 3185
Yacht Master is offline   Reply With Quote
Old 03-16-2008, 08:45 AM   #8 (permalink)
BenzWorld Junior Member
 
jamsong's Avatar
 
Date registered: Aug 2002
Vehicle: 2004 E320S4
Location: Portland, Oregon USA
Posts: 27
Quote:
Originally Posted by Diesel Benz View Post
What did you exactly ask the tech to do? We do not have this option in Europe but I thought you would have to code the IC (phone present from optional equipment) and the Tele-Aid CTEL( MHI) fitted?
What is "code the IC (phone present from optional equipment)"?
Is that in th Star Diagnosis?

I gave the service advisor a printout of the attached file.
Attached Thumbnails
Bluetooth "Puck with Tail" version coding problems-e320-cell-phone-coding.jpg  
jamsong is offline   Reply With Quote
Old 03-16-2008, 09:05 AM   #9 (permalink)
BenzWorld Junior Member
 
jamsong's Avatar
 
Date registered: Aug 2002
Vehicle: 2004 E320S4
Location: Portland, Oregon USA
Posts: 27
Quote:
Originally Posted by Yacht Master View Post
Yes, from your description the setting for "Phone present" was not made.
My understanding is that the puck with tail takes the place of the phone and there should be no reference to Bluetooth in the SDS Star programing.
It is just that simple "phone present" is all that need be changed.
They will "get it", and you will love it. Once it is working make a call before you leave the dealership to a friend so that you can asses the sound quality, call someone with a good ear.
Once that is done if the audio out quality (your microphone) is poor they have updated a module to improve the sound of your out going signal.
I will try to find the posts.
Here is the DTB P-B-82.70/3386 and the part number # A 211 82 0 3185
Great advice about calling someone - I actually did mention DTB 82.70/3386 and they ordered the part and will replace the microphone later. The post that alerted me to this was:
Bluetooth - Microphone quality - MBWorld.org Forums
On a side note, I got my SBC "dampened" along with the Puck version coding. The difference on the SBC is amazing, the sound and vibration are gone (and I'm sensitive to those things).

I'll let you all know my final outcome of my "Puck with Tail" challenge.
jamsong is offline   Reply With Quote
Old 03-18-2008, 10:16 PM   #10 (permalink)
BenzWorld Junior Member
 
jamsong's Avatar
 
Date registered: Aug 2002
Vehicle: 2004 E320S4
Location: Portland, Oregon USA
Posts: 27
Yacht Master, you were absolutely correct. Thanks for the definitive answer to go back to the dealer and make them do the coding correct.ly They didn't charge me for the recoding and, yes maybe they should have payed me for training their technicians on properly coding the Puck with Tail.

I reiterated to the SA what I wanted and this time around, they did exactly what I asked. I was again not present when they did the coding. I dropped the car off in the morning and picked it up in the afternoon. I got into my car, and the Comand screen immediately said "Activating Phone." Phone now works on the Comand, steering wheel controls work, and voice quality is great. After a minute, my phonebook downloaded (I have a Samsung Blackjack with WM6) and I later paired my wife's Motorola RAZR v3 and it also downloaded her address book. Wife wasn't convinced that this was worth ~$500 for the part & coding but hey, sure beats $2k, and it's worth it to me. It's such a clean install and the interface integration with the car is slick.
jamsong is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
LED tail light "Lamp out" warning display peter_02AMG W210 E50 AMG, E55 AMG 5 11-28-2010 08:32 PM
2004 E55 IPhone bluetooth puck with tail works! Yacht Master W211 E55 AMG, E63 AMG 18 08-26-2010 04:51 AM
Version 1 "Quick" Reply Button Doesn't do anything. Digmenow Benzworld Site issues forum 5 11-11-2007 03:33 PM
SLK 200 "Final Version" for sale: €48.000 Max R170 SLK Class 0 09-12-2003 07:46 AM


All times are GMT -7. The time now is 09:12 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.