HELP 2001 Mercedes E320 limp mode! - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2012, 02:00 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2012
Posts: 1
Arrow HELP 2001 Mercedes E320 limp mode!

Hey I have a 2001 Mercedes E320 that was driving fine until one day it stopped accelerating. I came an office and after I started it, pushing the gas would have no response. The check engine light went on and ESP malfunction. In P and N it revs up just a tiny bit but in D it just drives about 11mph and that's it. It does shift between first gear and second gear. I had no time to fix it so it stood without use for couple months, and the battery died. I bought a new battery and started the car, and turned off the esp button right away. Gave it a circle around my neighborhood and it was accelerating just fine. So I thought that was the fix... When I started the car again the problem came back. I changed the throttle position sensor and that didn't change anything. I called a friend and he brought his computer and it gave out the code p0120. He erased he code but it came right back up. My friend thinks the computer needs to get re flashed or relearned... Anyone who knows what this can be please help out, before I but anymore unneeded parts. Thanks in advance...
tyslyuk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-18-2012, 03:48 PM   #2 (permalink)
BenzWorld Junior Member
 
Date registered: Nov 2008
Vehicle: 1985 500 SEL 175k mi - 1999 E320 Wagon 4matic 160K
Location: Ludington, Michigan
Posts: 45
Hey read this Trans FAQ here...
http://www.benzworld.org/forums/w210...ssion-faq.html
85500sel is offline   Reply With Quote
Old 01-18-2012, 05:41 PM   #3 (permalink)
~BANNED~
 
Date registered: Oct 2010
Vehicle: 1999 E300 TD
Posts: 2,045
P0120 is the throttle position sensor code, however and although your friend went to the library, he did not find a book.

What your friend did not do was check the varying voltage of TPS against the varying voltage change from the manifold pressure sensor and the voltage change from the engine control unit--------have a different friend do that and then he will be able to tell you what component to really buy.
Plutoe is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
E320 CDI - Limp Mode P2015? jslimjeff W211 E-Class 20 03-05-2014 11:08 PM
97 E320 in Limp Mode chels97 W210 E-Class 22 06-03-2011 06:13 PM
96 e320 in limp mode? kikaz69 W210 E-Class 10 03-13-2011 03:34 AM
01 e320 in Limp Mode please help mpalic W210 E50 AMG, E55 AMG 3 10-25-2008 09:52 AM
E320 Check Engine light-Limp Mode? jchumba General Mercedes-Benz 1 10-25-2008 08:30 AM


All times are GMT -7. The time now is 03:47 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.