E240 2000 gearbox thumps into gear gets stuck. Please help - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-24-2011, 11:17 PM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
E240 2000 gearbox thumps into gear gets stuck. Please help

Hi Everyone, I am new to this site and would really appreciate any help with my problem
My 2000 E240 W210 with 5 speed tip shift gearbox and only 32,000km has a problem. I had it detailed a couple of weeks ago and since then I have had a few problems with the gearbox. When I select drive the gearbox thumps into gear and really wants to pull on the brakes. Sometimes it wont let me select reverse after this happens and I have to switch the car off in order to select park. I can then start the car again and select reverse but it thumps/bangs into that gear too. When I drive it when it's playing up it is in limp mode and stays in 2nd.
Sometimes I hop in the car and it works fine?? When I first picked it up from the detailer it was stuck in P and we had to stick a screwdriver in the emergency release slot to disengage it.
Anyway last week I took it to Mercedes and they scanned it on their star diagnostic laptop. It came up with heaps of fault codes which are listed below. They cleared them and said it was all ok now so I picked it up and it drove home perfectly. I didn't use it for a week and went to use it and the same problem occured again. To further confuse things I tried it again today and it is fine again. AARRGGHH!! I have two of these cars and was going to swap the gear selector modules today but as the dodgy on is working I wouldn't know if the other one had infact fixed it if they were swapped.
I think it's either the gearbox control module in the engine bay or the actual gear selector module as part of the shifter. Most likely the latter.
Does anyone know how to deal with this? Can anyone decipher the codes which the car presented?
Thanks in advance for any help.

Codes
130 Can Mommunication with control unit N15/5 (electronic selector lever control unit) is sporadically disturbed
132 Can comm with engine system is sporadically disturbed
134 Can comm with traction system is sporadically disturbed
135 can comm with engine is sporadically disturbed
136 occasional interferance to can comm with control module A1 (instrument cluster) or N73 (EIS, EZS control unit)

P1856-005 Selector lever position detection has failed

P2067 Fault is stored in component N15/3 (ETC, EGS control unit)

C1024 Fault in Can Comm with control unit N15/3 (ETC, EGS control unit)

C1020-018 Can bus fault in comm

C1022 Fault in can comm with control unit N3/10 (ME-SFI ME)

There are a few more but I'm over typing now and sporadically disturbed with this car!!
Radelaide is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-25-2011, 05:16 AM
~BANNED~
 
Date registered: Oct 2010
Vehicle: 1999 E300 TD
Posts: 2,045
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well you sure do have a conundrum.

The one thing you, or MB did not indicate was, where all of the faults were stored.

In any event, if you look a the big picture, it appears that most of the faults are communication issues. Either the cables are damaged or the module or modules(many) themselves are faulty.

The bad news is that to do the diagnosis, you need similar diagnostic software as MB. As you start unplugging modules, how will you be able to determine what is still not communicating? That's the problem!

My solution is find a friend who has a copy of the chicom knock off MB diagnostic software and work with him! Good luck
Plutoe is offline  
#3 (permalink) Old 08-25-2011, 06:32 AM
BenzWorld Veteran
 
gurunutkins's Avatar
 
Date registered: May 2007
Vehicle: 2001 E320 wagon
Location: Issaquah WA (E of Raymond - S of oh lord)
Posts: 638
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the idiots detailing it got liquid in the shifter and have messed up the circuit board that sits unprotected below the shifter console?
cheers
Barri

2001 e320 wagon, 1973 350sl euro, 1974 450sl, 1976 450sl, 1978 450 slc euro
gurunutkins is offline  
#4 (permalink) Old 08-25-2011, 08:03 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 104,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Agreeing with Barri. Try opening the shifter assembly and spray the circuit board with a good electronics cleaner. Or as you suggested, swap the guts of the bad shifter with the good one.

But if we are correct, the question remains: why would the car would behave well some of the time and sometimes not?

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 08-25-2011 at 08:05 AM.
Musikmann is offline  
#5 (permalink) Old 08-25-2011, 06:36 PM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
UPDATE.

As the car shifted into gear perfectly yesterday just before I was about to swap the gear lever with the wifes car, I decided to drive it and see what happens?? Well nothing happened and it worked perfectly. I have started it and moved it five times since then with no problem.
Anyway I thought I would get Mercedes to rescan the car and it came up with far fewer faults since last time it was scanned. YAY! There were just way too many faults for me to process last time.
This time it showed
130 Can comm with control unit N15/5 (electronic selector lever module control unit) is sporadically disturbed (STORED)
P1856-005 Selector lever position detection has failed (STORED)
P2067 Fault is stored in component N15/3 (ETC {EGS}control unit) (P0705)

From this I am convinced that the problem lies with the gear selector module and that it must have got wet when detailed.

Does anyone know if this can be opened and cleaned/repaired?

I can get a new one from a friend that sells parts for $800au which is just over $1000 cheaper than from MBAU!! Should I just bite the bullet and get a new one??

Thanks for all of your responses!!!
Radelaide is offline  
#6 (permalink) Old 08-25-2011, 06:46 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 104,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Not time for a new one just yet. Check the stickies and there are instructions about removing the board and how to clean it. This is a very common problem and a design flaw. When any liquid gets into the shifter apparatus there are problems like you described.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
#7 (permalink) Old 08-25-2011, 07:01 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,327
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 19 Post(s)
Quote:
Originally Posted by Musikmann View Post
Not time for a new one just yet. Check the stickies and there are instructions about removing the board and how to clean it. This is a very common problem and a design flaw. When any liquid gets into the shifter apparatus there are problems like you described.
+1

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#8 (permalink) Old 08-25-2011, 07:38 PM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
OK, I have just had a play and agree with your sentiments about not changing it just yet.
On the top of the gear selector unit is the W&S switch. I removed that which is extremely easy. Underneath that is a circuit board which could very easily get wet through the gaps in the W&S switch. It looked to be in OK condition but not absolutely perfect like a new one so I have sprayed it with INOX and blown it out with my air gun. There may have been some corrosion or similar as a result of getting it detailed. I hope this has fixed it as it is an extremely easy fix.
Radelaide is offline  
#9 (permalink) Old 08-25-2011, 07:40 PM
BenzWorld Junior Member
 
Date registered: Aug 2011
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Where do I find the "stickies" that you mention. I'm new at this!! Cheers
Radelaide is offline  
#10 (permalink) Old 08-25-2011, 09:13 PM
BenzWorld Senior Member
 
KMani1's Avatar
 
Date registered: Jun 2009
Vehicle: 2001 C320 W203 Black on Black. 1997 E320 W210 Silver (RIP). 1995 E320 W124 Pearl Black.
Location: 92555
Posts: 595
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
One reason I never get my car details, just do it myself when ever I had time. How much those guys know about car beside spray some liquid and wipe it off, beside they might think of the term "NMC" Not My Car.

RIP.
KMani1
KMani1 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
W210 E240 gear slippage N-GEN W210 E-Class 2 10-30-2010 02:37 PM
W211 E240 Automatic Gearbox bencejb W211 E-Class 1 10-18-2010 08:00 AM
Key Stuck In Ignition - Gear Stuck In Park hank4422 W210 E-Class 6 12-18-2009 06:43 PM
Gear select display/ stuck in 1st gear raybenz W163 M-Class 1 03-18-2007 06:35 PM
Gearbox Problems E240 1998 mobye General Mercedes-Benz 0 01-19-2006 04:10 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome