My first MB E320 (Wipers, signals, power doors and windows) - Many issues need help - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-23-2011, 06:47 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 1996 E320
Location: Milwaukee, WI
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post My first MB E320 (Wipers, signals, power doors and windows) - Many issues need help

Hello MB Geeks

Recently I bought a 1996 E320 Mercedes from a guy in Chicago and he said that there is an issue with the power windows and it might be a fuses!! Well I knew it could be more than that but the price was fairly good even if it was the worst.
However, while driving it to Milwaukee, WI I found out that this car was beaten up and many electrical things don't work.
First of all after two days of googling I was able to get my WIS installed and running fine but still learning how to use it
Second, it looks like that my VIN is European and no decoder is recognizing it.

VIN: WDBJF55F3TJ006353

Issues:
1- Turn signals don't work.
2- Wiper don't work (water is working)
3- Power seats don't work.
4- Power Windows don't work.
5- Sun roof doesn't work.
6- Radio doesn't work.
7- Door locks are jammed.
8- Parking light stays on and drains the battery.
9- Defogger doesn't work.
10- Right turn signal is stuck blinking (I have removed fuse #5 to stop it also if I turn the head light all the way on it will stop)
11- "Light is defective" message.
12- "Take the key" message with two squares sign.

First thing I did of course is checking the fuses. took them off one by one, clean it and put it back in the three fuses locations; near the battery, by the driver door and under the hood.
Then I disassembled the center console and checked the power windows switch board and it looked fine to me. and cleaned it also by brushing it with alcohol and drying it with air pressure.
Today I opened the PSE pump and looked at it from inside thinking that there might be a water damage but it was like new.
Tomorrow I am going to check for the relays, I found where they are located but don't know how to test them.

My first question is do all of those issue indicate for one cause?
2nd Other than the relays next to the fuses under the hood, is there any other box?

Thanks much in advance for the help.
khaledq is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-23-2011, 07:13 PM
BenzWorld Member
 
Date registered: Oct 2007
Vehicle: 1999 E430 Sport
Location: Crystal Lake, IL
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
So many things are not working, I wonder if there is a bad ground somewhere or if there is no power present at some of the fuses. Initially I would use a meter and check if there is power available at the fuses themselves.

Has this car been in a flood?

The locks, windows, defogger, seats and many other items all work via the CAN bus. There could be one faulty unit that is preventing the bus from working.
n42w88 is offline  
#3 (permalink) Old 02-23-2011, 07:37 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 1996 E320
Location: Milwaukee, WI
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes there is a power on the fuses.
I don't know about the flood I wish someone can get the history for me.
Any idea how to diagnose the canbus signal?

Thank you
khaledq is offline  
#4 (permalink) Old 02-23-2011, 08:32 PM
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 1990 190E 2.6 W201 Euro Spec / 2003 C240 wagon
Location: Victoria, BC Canada
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi khaledg,

Sounds like a faulty wiring harness. I've heard rumours of insulation cracking and signals getting shorted together. Isn't this the dreaded $3k fire-wall wiring loom replacement issue?

JJoynt
Victoria, BC
1990 190E
1995 C280
2003 C240 wagon
JJoynt is offline  
#5 (permalink) Old 02-23-2011, 08:34 PM
BenzWorld Extremist
 
Date registered: Jan 2008
Vehicle: W210 1996 E320 Smoke Silver. [W124 1990 300CE Artic White - Sold].
Location: DFW
Posts: 814
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by khaledq View Post
Hello MB Geeks

Recently I bought a 1996 E320 Mercedes from a guy in Chicago and he said that there is an issue with the power windows and it might be a fuses!! Well I knew it could be more than that but the price was fairly good even if it was the worst.
...
May I ask how good the price was? Since I have the same 1996 E320 with no issues I can set my price accordingly.

W210 1996 E320 Exterior Smoke Silver, Interior Mushroom, 159,999 miles as of 09/09/09, 170K as of 02/01/2011.
texholdem is offline  
#6 (permalink) Old 02-23-2011, 09:43 PM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 1996 E320
Location: Milwaukee, WI
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by JJoynt View Post
Hi khaledg,

Sounds like a faulty wiring harness. I've heard rumours of insulation cracking and signals getting shorted together. Isn't this the dreaded $3k fire-wall wiring loom replacement issue?
What issue is this? What part of the harness that could be?
khaledq is offline  
#7 (permalink) Old 02-23-2011, 10:18 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 104,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Lifetime Premium Member
Quote:
Originally Posted by khaledq View Post
$1850 How much did you buy yours?
No offense intended but one of the mantras here is: there is no car more expensive than a cheap Mercedes. You have your work cut out for you man and I sympathise with you.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
#8 (permalink) Old 02-23-2011, 10:44 PM
BenzWorld Extremist
 
Date registered: Jan 2008
Vehicle: W210 1996 E320 Smoke Silver. [W124 1990 300CE Artic White - Sold].
Location: DFW
Posts: 814
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by khaledq View Post
$1850 How much did you buy yours?
I bought mine in Jan 2008 for $6,900 with 130K miles. It is now worth under $3K. Trade-in about $2,300-$2,500.- for new car purchase

W210 1996 E320 Exterior Smoke Silver, Interior Mushroom, 159,999 miles as of 09/09/09, 170K as of 02/01/2011.
texholdem is offline  
#9 (permalink) Old 02-24-2011, 04:26 AM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 1996 E320
Location: Milwaukee, WI
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
No offense intended but one of the mantras here is: there is no car more expensive than a cheap Mercedes. You have your work cut out for you man and I sympathise with you.
It's not expensive for me at all even if I am going to put in it. However, any idea or suggestion on the issues?
khaledq is offline  
#10 (permalink) Old 02-24-2011, 04:30 AM
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: 1996 E320
Location: Milwaukee, WI
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by texholdem View Post
I bought mine in Jan 2008 for $6,900 with 130K miles. It is now worth under $3K. Trade-in about $2,300-$2,500.- for new car purchase
Would you sell it to me?
khaledq is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2000 E320 4matic - horn, turn signals, wipers inoperative thomasfox W210 E-Class 15 07-24-2013 06:01 AM
windows, wipers, mirrors and signals stop working, then start again meddling kid W202 C-Class 4 10-12-2010 03:01 PM
No Power Windows or wipers jrequena W124 E,CE,D,TD Class 0 03-05-2010 11:48 AM
Help: 99 E430 turn signals, wipers, seats, windows ALL NOT working wheeljo2 W210 E-Class 9 01-13-2008 04:24 PM
Swapping doors...I have power windows, I want MANUAL??? panamacolin W123 E,CE,D,CD,TD,TE Class 18 07-12-2006 02:08 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome