EL. Power Control EPC (warning light) - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-24-2010, 10:22 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Jun 2008
Vehicle: (W210) Mercedes E320 CDI YEAR 2000 X reg (MANUAL AIR CON)
Location: UK
Posts: 89
EL. Power Control EPC (warning light)

Hey there. Got a problem with my car. If i bury the accelerator down and press the button on the floor (where the accelerator pedal hits the floor) this warning comes up EL. (which I’m guessing stands for electrical) Power control EPC. Just wondering if anybody knows what the problem is or if there is a common problem or a sensor needs changing.

Thanks in advance
__________________
Most problems are usually solved with simple solutions.
Killer2000 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-24-2010, 11:24 AM   #2 (permalink)
BenzWorld Senior Member
 
Date registered: Mar 2010
Vehicle: 1999 E300 Turbodiesel
Location: Florida
Posts: 463
Quote:
Originally Posted by Killer2000 View Post
Hey there. Got a problem with my car. If i bury the accelerator down and press the button on the floor (where the accelerator pedal hits the floor) this warning comes up EL. (which I’m guessing stands for electrical) Power control EPC. Just wondering if anybody knows what the problem is or if there is a common problem or a sensor needs changing.

Thanks in advance
I think that I am corect when I say USA cars inst cluster is not fitted with the dreded European EPC light------We have the dreded Check engine light and when that section of the inst cluster is lit---our blood pressure goes up and we all run to the bank, because its going to cost us money(USD) we don't consider anything else as money.

In any event run to the bank then grab a pint then----see a good mechanic and have him read the code!! Good luck!!!
jhby@qis.net is offline   Reply With Quote
Old 07-24-2010, 12:14 PM   #3 (permalink)
BenzWorld Elite
 
renault12ts's Avatar
 
Date registered: Feb 2009
Vehicle: 2000 S210 E320CDI Avantgarde
Location: UK
Posts: 2,779
Send a message via ICQ to renault12ts Send a message via AIM to renault12ts Send a message via MSN to renault12ts Send a message via Yahoo to renault12ts
Quote:
Originally Posted by Killer2000 View Post
Hey there. Got a problem with my car. If i bury the accelerator down and press the button on the floor (where the accelerator pedal hits the floor) this warning comes up EL. (which I’m guessing stands for electrical) Power control EPC. Just wondering if anybody knows what the problem is or if there is a common problem or a sensor needs changing.

Thanks in advance
Get the codes read. Not necessarily expensive. Does kick-down actually work or are you just getting the EPC message? I got this message when an ABS ring broke, repaired for £100.
__________________
For the avoidance of doubt, when answering posts I am referring to the W210 Mercedes...not the Renault12ts.
renault12ts is offline   Reply With Quote
Old 07-24-2010, 03:34 PM   #4 (permalink)
BenzWorld Member
 
Date registered: Jun 2008
Vehicle: (W210) Mercedes E320 CDI YEAR 2000 X reg (MANUAL AIR CON)
Location: UK
Posts: 89
Yeah kick down works there’s no drop in performance. Personally i just think it’s a bad sensor. I will check the codes as it an electrical problem.

Thanks for your responses.
Killer2000 is offline   Reply With Quote
Old 07-27-2010, 01:57 PM   #5 (permalink)
BenzWorld Junior Member
 
Zafferg's Avatar
 
Date registered: Jul 2010
Vehicle: 2001 E320 CDI (I6) Avantgarde Designo
Location: UK - Cumbria
Posts: 41
Hi there I'm experiencing almost identical problem!

2000 x reg 320 cdi avantgarde - only bought a couple of weeks ago from a dealer so have the 3 months warranty although have done some research into the company the dealer has used and it sounds like it wont be worth the money its written on!

I get the el. error only on kickdown but don't get the resultant boost in performance instead the revs drop. So I've been driving it right to the limit (which it handles fine) but not using the kickdown. Would be very interested in more info!

There seems to be plenty of threads concerning the error while at high revs but few that experience it on kickdown only.
Zafferg is offline   Reply With Quote
Old 08-02-2010, 12:53 PM   #6 (permalink)
BenzWorld Junior Member
 
Zafferg's Avatar
 
Date registered: Jul 2010
Vehicle: 2001 E320 CDI (I6) Avantgarde Designo
Location: UK - Cumbria
Posts: 41
Well took mine to the local merc garage today (sytner in carlisle)
Turned out mine is a faulty kickdown sensor - warranty company are going to cover the parts (~£120) but are going to seriously stiff me on the labour (they recon it should take no longer than 24mins at a max £37.5 per hr) But the loverly lady on the service desk cut me a decent deal.

V happy so far overall - am really looking forward to some kickdown action! Going to ask them to keep me the old part so I can inspect it properly - will post some pics if any interest.

Sorry for the thread hi-jack but guess it's pretty related!
Zafferg is offline   Reply With Quote
Old 09-05-2012, 07:26 AM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2012
Vehicle: 1993 Mercedes 500 SE W126; 2000 Mercedes C280 W202; 1995 Mercedes SL500 R129
Location: South Africa
Posts: 4
Quote:
Originally Posted by Zafferg View Post
Hi there I'm experiencing almost identical problem!

2000 x reg 320 cdi avantgarde - only bought a couple of weeks ago from a dealer so have the 3 months warranty although have done some research into the company the dealer has used and it sounds like it wont be worth the money its written on!

I get the el. error only on kickdown but don't get the resultant boost in performance instead the revs drop. So I've been driving it right to the limit (which it handles fine) but not using the kickdown. Would be very interested in more info!

There seems to be plenty of threads concerning the error while at high revs but few that experience it on kickdown only.
Did you come right with this problem. I am currently having the same issue.
jca2689 is offline   Reply With Quote
Old 09-05-2012, 11:27 AM   #8 (permalink)
BenzWorld Elite
 
renault12ts's Avatar
 
Date registered: Feb 2009
Vehicle: 2000 S210 E320CDI Avantgarde
Location: UK
Posts: 2,779
Send a message via ICQ to renault12ts Send a message via AIM to renault12ts Send a message via MSN to renault12ts Send a message via Yahoo to renault12ts
Quote:
Originally Posted by jca2689 View Post
Did you come right with this problem. I am currently having the same issue.
This is an old thread, and the member you are asking a question of hasn't been here since last August.
renault12ts is offline   Reply With Quote
Old 09-05-2012, 11:35 AM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2012
Vehicle: 1993 Mercedes 500 SE W126; 2000 Mercedes C280 W202; 1995 Mercedes SL500 R129
Location: South Africa
Posts: 4
Quote:
Originally Posted by renault12ts View Post
This is an old thread, and the member you are asking a question of hasn't been here since last August.
Yeah I only realised that just now.
Could you help me out. I keep having the EPC error come up when i depress the pedal to the kick down switch. The only error i get on star is Throttle sensor 1 signal voltage too high. I replaced the pedal assembly with a known working one and the same thing continues to happen. The car doesnt get any faults provided the kick down isnt pressed...

Thank you
jca2689 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
EL power control. EPC visit workshop fault any ideas??? paulhandley W210 E-Class 1 04-10-2009 10:12 AM
EL. POWER CONTROL VISIT WORKSHOP! EPC HELP!!?!?! Decay W203 C-Class 1 02-10-2009 05:31 AM
EPC warning light johnnype220cdi W210 E-Class 0 01-29-2009 08:35 AM
EPC - Electronic Power Control Andrew G General Mercedes-Benz 2 04-23-2008 01:19 AM
EL. Power Control EPC paciffic_breeze W210 E-Class 0 11-26-2006 10:17 AM


All times are GMT -7. The time now is 03:11 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.