Reprogramming the E320 computer for check engine light illuminating - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-14-2010, 02:48 PM   #1 (permalink)
BenzWorld Junior Member
 
ziggie's Avatar
 
Date registered: Nov 2008
Posts: 19
Reprogramming the E320 computer for check engine light illuminating

Hay,

My 2002 E320 Station Wagon has illuminated check engine light.

I changed all 4 Oxygen Sensors, two Catalytic Converters, and then reset the check engine light with diagnostic tool. But , the check engine light gets illuminated just after 25 miles of driving. I was the codes of 403 and 402 which says the Catalytic Converters below threshold.

I was reading that before and I still read that after installing to new Cats.

What seems to be the problem I can not figure it out. And it is not the Gas Cap either.

Do I need to reprogram the engine computer to fix this problem? Please help

Last edited by ziggie; 01-14-2010 at 03:32 PM.
ziggie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-14-2010, 03:21 PM   #2 (permalink)
BenzWorld Senior Member
 
Big"D"inTheMB's Avatar
 
Date registered: Jun 2007
Vehicle: 2005 C240
Location: Bay Area, CA
Posts: 584
What codes are you getting before you clear them?

That would be a huge help in getting your question answered.
__________________
Mercedes Benz, enough said.


2011 MB GL-450 Weekend SUV.
2005 MB C240 - daily commuter
Big"D"inTheMB is offline   Reply With Quote
Old 01-14-2010, 03:27 PM   #3 (permalink)
BenzWorld Junior Member
 
ziggie's Avatar
 
Date registered: Nov 2008
Posts: 19
ng the e320 computer for check engine light illuminating

the codes are 403 and 402 which says the Catalytic Converters below threshold.

I was reading that before and I still read that after installing to new Cats.
ziggie is offline   Reply With Quote
Old 01-14-2010, 03:33 PM   #4 (permalink)
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 101,000+
Location: West Virginia, USA
Posts: 17,191
Lifetime Premium Member
Maybe if you disconnect the battery, wait a few minutes, then reconnect. That will reset the ECU.
__________________
Mercedes Benz - Das beste oder nichts!
Musikmann is offline   Reply With Quote
Old 01-14-2010, 03:36 PM   #5 (permalink)
BenzWorld Junior Member
 
ziggie's Avatar
 
Date registered: Nov 2008
Posts: 19
I actually replaced the battery for this car about two months ago so I don't think that would be the solution.
ziggie is offline   Reply With Quote
Old 01-14-2010, 03:43 PM   #6 (permalink)
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 101,000+
Location: West Virginia, USA
Posts: 17,191
Lifetime Premium Member
It might not be but did you replace the battery before or after you replaced the cats? You asked about reprogramming the "engine computer" and I told you how to reset/reboot the engine control unit. Or are we talking about 2 different things?

Another possibility: Are you sure the new cats are compatible with your car and are installed properly?
Musikmann is offline   Reply With Quote
Old 01-14-2010, 03:49 PM   #7 (permalink)
BenzWorld Junior Member
 
ziggie's Avatar
 
Date registered: Nov 2008
Posts: 19
Yes the new cats are M/B and installed okay
ziggie is offline   Reply With Quote
Old 01-16-2010, 05:10 AM   #8 (permalink)
BenzWorld Elite
 
iluvjesus's Avatar
 
Date registered: Jan 2009
Vehicle: 210.065
Posts: 2,947
Any symptoms when driving it? Are the O2 sensors genuine too? Don't worry ziggie, it usually reprograms itself. Drive for a few more days and the CEL may disappear.
__________________
iluvJESUS
"I am the Alpha and the Omega," says the Lord God,
"who is, and who was, and who is to come, the Almighty." Revelation 1:8
iluvjesus is offline   Reply With Quote
Old 01-16-2010, 05:38 AM   #9 (permalink)
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: w210 E320 2001, BMW E34 1991, w124 E300
Location: saudi Arabia
Posts: 72
this happened to me, i have reset the CEL 3 days ago, it gets illuminated again after 2 km.
today when i turn the engine, the light was off.
So as iluvjesus said,maybe it reprograms itself.
samijusuf is offline   Reply With Quote
Old 01-16-2010, 01:02 PM   #10 (permalink)
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(171K Miles), 2002 E320 Special Edition(149K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
This is an interesting one. The cats doesn't have any sensors and analysis of the cat operation depends on readings from the two o2 sensors before and after the first cat. Since you had installed MB cats, I think we can assume that they are operating correctly.
Now what may have happened if you had driven for a long time with bad cats and/or O2 sensors, is that the adaptive values for fuel trim, etc., may have tried to compensate for the bad parts and totally screwed up the mixture. Now that you have working parts in, the mixture may be totally wrong! If that is the case, some more driving cycles may bring the values into the correct range. Or you can also have all adaptations reset to the default values using STAR or Carsoft.
Of course you may also have a MAF going bad screwing up the fuel mixture, but that should normally throw codes as well. Are you sure you have the correct MAF fitted for the car?
__________________


Only two thing are infinite, the universe and human stupidity, and I'm not so sure about the former.
Albert Einstein

Honest politicians are like UFOs. Most people believe that there must be some out there somewhere, but nobody has yet been able to prove their existence.
Kobus is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Check engine light e320 cc238 W210 E-Class 16 06-26-2009 05:47 AM
How to check code for check engine light 94 E320 W124 Synd W124 E,CE,D,TD Class 1 05-24-2007 02:37 PM
94 E320 Check Engine Light Jolinie General Mercedes-Benz 2 01-19-2006 03:09 PM
E320 "CHECK ENGINE" light klym22 General Mercedes-Benz 2 10-28-2004 03:44 PM
'95 E320 Check Engine Light Guest (MBNZ) W124 E,CE,D,TD Class 5 01-15-2002 10:56 AM


All times are GMT -7. The time now is 03:11 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.