Wheezing sound - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-16-2009, 08:18 PM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Wheezing sound

Hi all,

I recently did my regular do-it-yourself service on my 1997 E320 which included new air filter and a throttle body clean. Well, after an 800 mile round trip, I begin hearing a wheezing sound from the engine when accelerating. I do not think that this is "normal" so it got my attention. Has anyone ever had this to deal with? Is this something to worry about? What do you folks think?
__________________
97 Mercedes Benz E320
98 Volvo XC 70
87 Volvo 240 DL

Orlando, FL.
NIGHTCAP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-16-2009, 08:57 PM   #2 (permalink)
BenzWorld Elite
 
iluvjesus's Avatar
 
Date registered: Jan 2009
Vehicle: 210.065
Posts: 2,947
Mileage of your car?

Do you have the wheezing when you just rev the engine (i.e. car stationary)? If you do, check V-belt first and belt tensioner.
__________________
iluvJESUS
"I am the Alpha and the Omega," says the Lord God,
"who is, and who was, and who is to come, the Almighty." Revelation 1:8

Last edited by iluvjesus; 08-16-2009 at 08:59 PM.
iluvjesus is offline   Reply With Quote
Old 08-16-2009, 09:08 PM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Wheezing

Milage is 220,000+ and wheezing sound noticed when car is in motion primarily when accelerating.
NIGHTCAP is offline   Reply With Quote
Old 08-16-2009, 09:08 PM   #4 (permalink)
BenzWorld Elite
 
loubapache's Avatar
 
Date registered: Feb 2007
Vehicle: 03 E320 4M Wagon & 97 E320
Location: Western Michigan
Posts: 3,909
In addition to what IJL suggested, also make sure the duct to the throttle body is completely seated and the airbox fully closed as well.
loubapache is offline   Reply With Quote
Old 08-16-2009, 09:10 PM   #5 (permalink)
BenzWorld Junior Member
 
benzotech2003's Avatar
 
Date registered: Jun 2009
Vehicle: 1996 C280
Location: Chicago
Posts: 34
NIghtcap,
Check your power steering fluid, while the car is running there should be little or no turbulence in the reservoir. another thing I can think of is maybe after your throttle cleaning service maybe a vacuum line fell off, but if it was a big enough one it would run rough. Hope this helps.
__________________
1996 C280
1997 S500
1994 S320 (Crashed and sitting, cant let her go)
benzotech2003 is offline   Reply With Quote
Old 08-16-2009, 09:15 PM   #6 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Wheezing

Thanks guys, I will try your suggestions in the morning.
NIGHTCAP is offline   Reply With Quote
Old 08-17-2009, 07:55 PM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Wheezing

I checked out everything as you guys suggested. I discovered that the wheezing (whistling) soung is coming from the throttle itself. There are no leaks that I have observed. I reved it up a few times and sure enough it is there. My indy did change the drive belt for me so I will take it to him to see if that has anything to do with it. Btw at idle I hear a rattle coming from the water pump area which leads me to believe that the belt might have something to do with it.
NIGHTCAP is offline   Reply With Quote
Old 08-17-2009, 09:06 PM   #8 (permalink)
BenzWorld Elite
 
iluvjesus's Avatar
 
Date registered: Jan 2009
Vehicle: 210.065
Posts: 2,947
Quote:
Originally Posted by NIGHTCAP View Post
I checked out everything as you guys suggested. I discovered that the wheezing (whistling) soung is coming from the throttle itself. There are no leaks that I have observed. I reved it up a few times and sure enough it is there. My indy did change the drive belt for me so I will take it to him to see if that has anything to do with it. Btw at idle I hear a rattle coming from the water pump area which leads me to believe that the belt might have something to do with it.
Then you need to check the water pump, bear in mind that problem with the belt tensioner could cause that too. So I would check that also. You may ask your mechanic to clean your throttle body for you or you DIY with a carb cleaner.
iluvjesus is offline   Reply With Quote
Old 08-18-2009, 06:25 PM   #9 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Thanks, I will my indy check out everything.
NIGHTCAP is offline   Reply With Quote
Old 08-23-2009, 08:19 PM   #10 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2007
Posts: 19
Checked everything out and all seems OK except for that whistling sound. My indy mechanic seems to believe that it is because it is breathing better. Still confused.
NIGHTCAP is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Popping sound subwoofer in HK sound syste, Hsheikh W211 E-Class 5 04-30-2010 11:52 AM
No Sound on radio, No Sound on TV, No CDC changer and NO PHONE! st_tropez72 Audio & Telematics Forum 4 09-01-2008 09:59 PM
Funny 'wheezing' engine noise - 300 TD stevebower W210 E-Class 5 11-19-2007 03:53 AM
Sound system ... working on better sound viper1619 W203 C-Class 3 05-16-2004 07:07 AM
High pitch sound sensor sound ~ E320 wagon luvmywagon W124 E,CE,D,TD Class 1 10-04-2003 10:40 AM


All times are GMT -7. The time now is 02:45 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.