1997 E320 Engine Swap (No Start) - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-28-2008, 12:13 PM   #1 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
1997 E320 Engine Swap (No Start)

I just finished the engine swap on my 1997 E-320. The new engine came with all the accessories and wiring harness. I put a new battery in today for the first firing and all I get it the engine turning over.

1) Seems to have fuel.
2) Won't fire on starting fluid. (I hate the stuff)


How do I check for spark?
CIG3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-28-2008, 02:27 PM   #2 (permalink)
BenzWorld Elite
 
ohlord's Avatar
 
Date registered: May 2007
Vehicle: 1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Location: North of Raymond
Posts: 6,019
Get

a spark plug checker,it hooks up in line to the plug.You do not want to use starter fluid on a maf equipped car,unless you spray it in after the maf,which is hard to do on the m104.
Check fuel to the fuel rail
at least you have the hard work done,the sorting out will take time,just don't get frustrated and check all you connections.Cam sensor hook up ,cps hook up,maf harness,ecu,fuses,relays,vac hoses.Sleep on it
__________________

00-02 drivers side self dimming heated mirror
17mm special spark boot tool
O2 plug and play sensors
16mm spring loaded swivel spark socket
trans dipstick and magnet


Mercedes Benz Lyrics
Artist(Band):Janis Joplin
"Oh Lord, won't you buy me
a Mercedes Benz"
ohlord
"Follow Peace,center Life"
ohlord is offline   Reply With Quote
Old 10-28-2008, 05:30 PM   #3 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
Thanks for the input. We are working at my friends shop.

He has a MIDAS diagnostic computer that we tried to connect.
It read the transmission computer for codes. (Nothing)
Would not read the ECU for some reason.

We have fuel.

we checked for spark (Nothing)

Changed the CPS to one from the old engine that ran. (Still nothing)

Checked fuses and all harness connections.

Would there be any issue with the computer. The car sat for over a year. (Dead Battery)
CIG3 is offline   Reply With Quote
Old 10-29-2008, 06:56 AM   #4 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
I've read in another thread about radio codes. My radio is locked. Would this cause the car not to start. The key fob locks and unlocks the doors. I also turned of the alarm that went off this morning when I tried to open the door. Can I rule out the key?

Thanks
CIG3 is offline   Reply With Quote
Old 10-29-2008, 07:47 AM   #5 (permalink)
BenzWorld Elite
 
Date registered: Nov 2005
Vehicle: 1996 210.020
Location: Adrift on a continent...
Posts: 3,972
Did you use the computer from the donor car? If so, that's a problem.
Matt L is offline   Reply With Quote
Old 10-29-2008, 08:18 AM   #6 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
No, the computer is from the original car.

One things I'd like to know is how to reset the DAS. When I first put power to the car I used a battery charger right at the battery. Cannot remember if the key was in the ignition or not.
CIG3 is offline   Reply With Quote
Old 10-29-2008, 12:31 PM   #7 (permalink)
BenzWorld Elite
 
ohlord's Avatar
 
Date registered: May 2007
Vehicle: 1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Location: North of Raymond
Posts: 6,019
The engine

is not married to the tcu,the ecu and the das .So when doing a swap you don't need to take the ecu or even the harness from the donor car.The engine is an Idiot.It does not care as long as it is in the same model.
Now if you were swapping in an E55 motor you would need everything,ecu tcu das ignition everything.
jumping to the battery with a jumper box and key in can erase the codes in the das.The only way to tell that is sds and the only way to reset is the special order one time use key to reprogram.Keep trouble shooting,push comes to shove you may need some time on an sds to see if you toasted the codes.
ohlord is offline   Reply With Quote
Old 10-29-2008, 12:57 PM   #8 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
Thanks for input. I'll keep pushing. One of the tech's at my bubbies shop is going to call his friend at the Dealer to see if he has any ideas and maybe we can get him to plug in his compute on a saturday.

Keep the ideas coming.
CIG3 is offline   Reply With Quote
Old 10-30-2008, 05:52 AM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Oct 2008
Vehicle: 1996 MB E320 W210
Location: Ohio
Posts: 4
Ground strap? This has kept many an engine swap from feeling successful!
leftysquid is offline   Reply With Quote
Old 10-30-2008, 10:24 AM   #10 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Vehicle: 1997 E320
Location: Grand River, Ohio
Posts: 52
I am going to go over the grounds tonight.

The ones I know of are:
Under washer bottle
In front of Main Harness box
Trans to chassic.
Am I missing anything?
CIG3 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
1997 E320 won't start NELSON76 W210 E-Class 2 09-09-2008 06:56 PM
New Problem - 1997 E320 - Check Engine Light gradyjohnson W210 E-Class 5 08-12-2007 04:14 PM
1997 E320 Check Engine Light - Misfire gradyjohnson W210 E-Class 8 04-10-2007 12:38 PM
E320 (1997) Not Start After Replacing Cluster rinopla W210 E50 AMG, E55 AMG 0 04-03-2006 12:21 PM
E320 (1997) Not Start After Replacing Cluster rinopla General Mercedes-Benz 1 04-03-2006 10:05 AM


All times are GMT -7. The time now is 06:36 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.