E200K, 2001, W210, ECU cooling fan - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-29-2008, 03:09 PM
MFK
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: E200 Kompressor 2001
Location: Dublin, Ireland
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
E200K, 2001, W210, ECU cooling fan

Had a problem that ESP, BAS,ABS lights came on and car was stuck in one gear. When I stopped I put into PARK but then I could not engage gear except using the pencil to manually do it. Turned engine off and it would not start again - would not even turn engine over. Was told by a Merc specialist that a fuse would be blown in the ECU box which would need replacing - he was spot on. I am told there is a small fan under the ECU box that needs to be replaced - any idea what is involved in doing this job?



Thanks

MFK
MFK is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-29-2008, 04:03 PM
BenzWorld Elite
 
Date registered: Nov 2005
Vehicle: 1996 210.020
Location: Adrift on a continent...
Posts: 3,972
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The gas models do have a fan to ventilate the module box under the hood. I assume that your module box is on the left, whereas they are on the right in the US. Hopefully the procedure is the same, and someone can come up with it for you.

I've never heard of one going bad, but any fan can break. I assume that you need it or it wouldn't be there. The fan is not present on the IFI diesels.
Matt L is offline  
#3 (permalink) Old 08-30-2008, 02:19 AM
MFK
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: E200 Kompressor 2001
Location: Dublin, Ireland
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes it is petrol and ecu box is on left hand side. I had to remove a small two wire connector going to the fuse box within the ECU module box and then replace the blown fuse and then it started perfect. Merc Specialist said the wires run to a fan that would need to be replaced. By leaving it disconnected and replacing the fuse was enough to get car started and me home.

Any help on doing job would be appreciated.

Thanks

MFK
MFK is offline  
#4 (permalink) Old 08-30-2008, 05:17 AM
MFK
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: E200 Kompressor 2001
Location: Dublin, Ireland
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Stripped out the fan this morning - you have to release all wires to the ecu's and then unbolt the mobule box (4 bolts). Then there are another four bolts to be taken out of a housing attached to bulkhead and you can then get access to small fan which is mounted on side of this housing. A bit fiddly but ok - now all I need is a fan

Cheers

MFK
MFK is offline  
#5 (permalink) Old 08-30-2008, 06:08 PM
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(178K Miles), 2002 E320 Special Edition(156K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This is one to remember. It would seem as if there is some protection build in to prevent the ECU from overheating when the fan stops working. I would assume that the variety of problems you encountered were due to the ECU starting to overheat and the electronics not operating properly. I've experienced similar problems when the fan died out on my PC and the CPU overheated.

I've checked the fuse list and could not find any description for the fuse that you had to replace, Can you remember which one it is? Also how was the problem diagnosed? Any codes? Most people would have assume the gearbox or CPS gone bad.

I can imagine the end result if one had to take the car to a dealer. Probably a bill of several hundred dollars, if not in the thousands, and a full ECU replacement.

Any further information on this would be appreciated, as well as any pictures.

PS. I hope you bought the Merc expert a few pints.



Only two thing are infinite, the universe and human stupidity, and I'm not so sure about the former.
Albert Einstein

Honest politicians are like UFOs. Most people believe that there must be some out there somewhere, but nobody has yet been able to prove their existence.
Kobus is offline  
#6 (permalink) Old 08-31-2008, 12:27 AM
BenzWorld Elite
 
ohlord's Avatar
 
Date registered: May 2007
Vehicle: 1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Location: North of Raymond
Posts: 6,019
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Was it the

K40 relay?
Control Module
that blew?and have you tried to power the fan and see if it is actually dead or did just the relay die?
ohlord


00-02 drivers side self dimming heated mirror
17mm special spark boot tool
O2 plug and play sensors
16mm spring loaded swivel spark socket
trans dipstick and magnet


Mercedes Benz Lyrics
Artist(Band):Janis Joplin
"Oh Lord, won't you buy me
a Mercedes Benz"
ohlord
"Follow Peace,center Life"
ohlord is offline  
#7 (permalink) Old 08-31-2008, 08:37 AM
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(178K Miles), 2002 E320 Special Edition(156K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ah, the infamous K40 module. On the R170 (SLK) forum, is was virtually standard practice at one stage to remove it and re-solder some connections. Probably more vibrations on the SLK combined with a bad batch of K40 modules caused frequent problems with solder cracking.



Only two thing are infinite, the universe and human stupidity, and I'm not so sure about the former.
Albert Einstein

Honest politicians are like UFOs. Most people believe that there must be some out there somewhere, but nobody has yet been able to prove their existence.
Kobus is offline  
#8 (permalink) Old 09-01-2008, 09:15 AM
MFK
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: E200 Kompressor 2001
Location: Dublin, Ireland
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
No it was a standard 10Amp fuse that blew in the fuse box within the ECU module box. The small fan has 2 wires (red and brown) going to it and it is plugged in to the end of the fuse box holder -the fuse kept blowing until this fan wire was removed. I now have it running without the fan and a 5 amp fuse in it until I get a fan.

See 5 amp fuse I have put in on Right hand side of photo. The fan wire plugs into this same block but further down to the right of picture - not shown in this photo.

It was a brilliant diagnosis (over the phone I must add) by the specialist. He mailed it in seconds once i described teh sequence of symptons etc.
Attached Thumbnails
Click image for larger version

Name:	Image016..jpg
Views:	1890
Size:	55.1 KB
ID:	193274  
MFK is offline  
#9 (permalink) Old 09-03-2008, 04:33 AM
MFK
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: E200 Kompressor 2001
Location: Dublin, Ireland
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
This is the fan that has failed. Any idea where I can get one - Main Dealer wants €180 . No luck at scrap yards so far. It just screws onto side of the ECU box at the bottom.
Part No. 2105450595

PA66-GF20-GB10 is written on the casing of it.

It also says TYP RV40-18/12GU-013 13.2V

Any help much appreciated
Thanks
MFK
Attached Images
 
MFK is offline  
#10 (permalink) Old 09-03-2008, 03:11 PM
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(178K Miles), 2002 E320 Special Edition(156K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This is probably going to be a dealer or scrap-yard only item. Voltage is wrong for PC spares. You can maybe also check if VW or BMW are using the same part. Sometimes they share the same parts, but at a more reasonable cost.



Only two thing are infinite, the universe and human stupidity, and I'm not so sure about the former.
Albert Einstein

Honest politicians are like UFOs. Most people believe that there must be some out there somewhere, but nobody has yet been able to prove their existence.
Kobus is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
E200K (W210) w/ MB Audio 10CC Guest (MBNZ) Audio & Telematics Forum 1 01-05-2010 12:57 PM
ABS & BAS lights on - E200k W210 2001 MFK W210 E-Class 7 03-21-2008 09:38 AM
Rear Fog Lights E200K W210 2001 MFK W210 E-Class 3 02-23-2008 06:30 PM
cooling fan 2001 s55 amg brianmp W220 S-Class 3 11-12-2007 12:14 PM
PCD and off set of W210 E200K MoNd3sTo7 W210 E-Class 7 01-12-2006 02:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome