Inside rear mirror 'Red and Green' lights blinking - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-21-2008, 03:32 PM
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: 96 E320(traded), 99 S500, 02 CLK430 Cabriolet, 07 200T(traded), 11 200T
Location: Toronto, Ontario
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Inside rear mirror 'Red and Green' lights blinking

I noticedd that the 'red and green' lights underneath the inside rear mirror will blink for about 15 sec after the car is started before turning itself off. When I locked the door, these lights are also blinking until the fog and daytime lights are off.

Is this normal? I do not recall the 'red and green' light stay on for that long after starting the vehicle. They both blink at the same time!

Vehicle is 96 E320

Philip

Last edited by 000-668; 01-21-2008 at 03:36 PM.
000-668 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-21-2008, 03:42 PM
BenzWorld Elite
 
Date registered: Dec 2006
Vehicle: 1997 E320, 1997 S320
Location: midwest
Posts: 2,946
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
i don't think it's normal. mine blink about 3 times (on-off), which is 3-4 seconds. they never have blinked until the fog lights turn off at night. when you turn off the car at night, before opening-closing the door, turn the key to position 2 (don't start the car again) and then off, this way you will trick the car not to turn the fog lights + parking lights on when closing the door, and see if they still blink that long. also this way you will lengthen the bulbs lifespan.
do they just blink that long only at the inside mirror, or at the driver's door handle and trunk handle also? i would call the mb dealer and see what they say.
tirona is offline  
#3 (permalink) Old 01-21-2008, 03:55 PM
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: 96 E320(traded), 99 S500, 02 CLK430 Cabriolet, 07 200T(traded), 11 200T
Location: Toronto, Ontario
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thats what I thought was the case, it should stay on for just a few seconds. Now they are on for about 15 sec. The vehicle run fine, just those lights are trying to tell me something.

btw Blinking only at the inside mirror. 96 does not have door or trunk lights. Will check with the dealer tomorrow.

Thanks.

Philip
000-668 is offline  
#4 (permalink) Old 01-22-2008, 04:56 AM
BenzWorld Extremist
 
xlimodriver's Avatar
 
Date registered: Sep 2006
Vehicle: '84 SEC EuroCoupe, '85 200T EuroWagon, '05 Mazda 6 SportWagon
Location: Campbellford, Ontario Canada
Posts: 1,166
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Weak battery in the key triggers the flashing. I think
xlimodriver is offline  
#5 (permalink) Old 01-22-2008, 05:45 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Sichuan province China
Posts: 48,458
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 37 Post(s)
When you lock the car the red light should flash a few times and when you unlock the car the green light should flash. When both red and green flash together its a warning that the system is faulty. Change the battery in the key first, as this normally fixes the problem. If that does not fix it then you will need a fault code readout As you say everything is working normally and the car locks/unlocks ok so change the key battery.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.

Last edited by eric242340; 01-22-2008 at 05:47 AM.
eric242340 is offline  
#6 (permalink) Old 01-22-2008, 08:07 AM
BenzWorld Newbie
 
Date registered: Jun 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Change the remote battery.
19E96M90 is offline  
#7 (permalink) Old 01-22-2008, 08:26 AM
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: 96 E320(traded), 99 S500, 02 CLK430 Cabriolet, 07 200T(traded), 11 200T
Location: Toronto, Ontario
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks. I should have thought about that. Will change the battery and see if the problem goes away. btw this problem is not happening this morning.

Philip
000-668 is offline  
#8 (permalink) Old 01-22-2008, 08:44 AM
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: 1996 E300D
Location: Durham, NC
Posts: 133
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by 000-668 View Post
Thanks. I should have thought about that. Will change the battery and see if the problem goes away. btw this problem is not happening this morning.

Philip
I have had the same problem in my 96 E300. Here's a new kicker to the situation. Sometime my dash needles don't work when that happens. Would that have anything to do with the red/green flashers coming on for 15sec??

Take today for instance. I cranked it this morning and the flashers were on 15sec and the needles on the gauges did not work. Everything else works perfectly. But I will leave work after 8 hours and they will be working fine.

Kind of annoying, I figured it has something to do with the security system. I haven't owned long enough to figure out the kinks. Any advice?
CBFintheODD is offline  
#9 (permalink) Old 01-22-2008, 09:52 AM
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: 96 E320(traded), 99 S500, 02 CLK430 Cabriolet, 07 200T(traded), 11 200T
Location: Toronto, Ontario
Posts: 280
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I don't have any problem with the dash needle. Just the lights are blinking for longer than expected. I have to change the battery first to see if the problem goes away.

Philip
000-668 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Red & Green Mirror Lights Flashing aristotled W140 S-Class 2 04-22-2007 03:30 PM
help green/red mirror lights flashing car no start stevekynaston AMG W210 E50 , AMG E55 6 10-30-2006 10:38 PM
red and green lights flashing rear view mirror bob richards W210 E-Class 2 05-15-2006 06:39 AM
This $300 device changes red traffic lights to green. Benza W163 M-Class 5 11-02-2003 10:17 PM
Flashing green and red mirror lights Guest (MBNZ) W202 C-Class 2 01-03-2002 10:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome