Hard to find Code definition P0600 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-16-2007, 07:44 PM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: 1997 E300d
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hard to find Code definition P0600

I purchased a OBD II reader and received a P0600 Communicationl Link error. I searched this forum and the internet and could not find out what the error actually meant. I called the OBD II instrument company and they emailed a electrical diagram. Basically it has to do with an error on the CAN Data Bus, the IFI control module (in fuel line injector module) or the RCL module (door lock??). The code was able to be cleared and did not come back (yet). Kind of a strange error code. PS-I could not clear the $%#@ SRS idiot light with the OBD II, after replacing the blinker (combination) switch and having t disconnect the air bag.
NCJETSKIER is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-16-2007, 10:15 PM
Moderator
 
raymond-'s Avatar
 
Date registered: Jan 2004
Vehicle: 99 E320
Location: seattle, wa (so of ohlord, w of guru)
Posts: 3,784
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Lifetime Premium Member
dunno if this info helps any more than what you have....
Attached Files
File Type: pdf P0600.pdf (314.1 KB, 4400 views)

raymond-
47º34'N 122º18'W
raymond- is offline  
#3 (permalink) Old 08-17-2007, 06:53 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: 1997 E300d
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks, I did not have that diagram. Now all I have to do is figure out where all this stuff is?????? Chris.
NCJETSKIER is offline  
#4 (permalink) Old 02-20-2009, 11:34 AM
BenzWorld Newbie
 
Date registered: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
did u ever get that po600 code fixed? mine is on and i cant find anyone that knows what to do.. Please help if u can!
c230komp80 is offline  
#5 (permalink) Old 02-20-2009, 12:29 PM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: 1997 E300d
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes, replaced the relay, and changed the battery, now if I can only get the car to stop leaking diesel!!!!!!!!
NCJETSKIER is offline  
#6 (permalink) Old 02-21-2009, 04:01 AM
BenzWorld Member
 
Date registered: Aug 2006
Vehicle: 1997 E300d
Posts: 74
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
c230, It was the K-40 relay located in a black plastic box near the firewall on the passenger side of the car (understand this is for a 1997 E300D). If you search this forum under the P0600, you will see all my previous posts and the help I received from this forum (the help was great!). You will see exactly what was happening with my car (speedometer would quit working, car would go into limp mode, all idiots lights would come on). I also replaced the battery. Between doing both, it corrected the problem. Hope this helps.
NCJETSKIER is offline  
#7 (permalink) Old 02-21-2009, 10:35 AM
BenzWorld Elite
 
ohlord's Avatar
 
Date registered: May 2007
Vehicle: 1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Location: North of Raymond
Posts: 6,019
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
C230

do a battery reset of the cars systems.See if that re-establishes data communication between the modules.So many things can be out of the link and throw a P0600.Even failure of the climate control to send data to the dash cluster.So if the battery reset does not solve the problem,don't throw parts at it,get it on an SDS and it will show a big F in the faulty circuit.
Have you an obd2 scanner? If you do,erase the code and see if it comes back on before doing the battery reset as sometimes comm errors are just temorary errors.


00-02 drivers side self dimming heated mirror
17mm special spark boot tool
O2 plug and play sensors
16mm spring loaded swivel spark socket
trans dipstick and magnet


Mercedes Benz Lyrics
Artist(Band):Janis Joplin
"Oh Lord, won't you buy me
a Mercedes Benz"
ohlord
"Follow Peace,center Life"
ohlord is offline  
#8 (permalink) Old 02-25-2009, 01:01 PM
BenzWorld Newbie
 
Date registered: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had it checked at the auto parts store. It had 14 trouble codes. All of them were involving cylinder misfires on all cyclinders, low fuel pressure, lean exhaust emissions. But its running rich cause there is a lot of black around the tailpipe.. I had the code cleared by the auto parts store and we cranked it up and ran fine for a minute. When I got back in started it up and got to the end of the parking lot is was back on. It runs like crap at idle.. in neutral it will idle up to like 1500 rpm and then back down and will start spuddering to the point the car bounces.. then in gear in will spudder also. If i give a little bit of gas with my foot on the brake like at a traffic light the spuddering stops and it runs smooth and stays running smooth while driving.. no loss of power or anything.. just horrible at idle..

How should i reset the battery? Just un hook it for a while?
c230komp80 is offline  
#9 (permalink) Old 02-25-2009, 01:10 PM
BenzWorld Newbie
 
Date registered: Oct 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I just spoke with my local dealer and that K-40 relay is gone on my car and is replaced by a Signal Acquisition Monitor that cost $450!!! So i dont want to go that route unless absolutely sure it is that.
c230komp80 is offline  
#10 (permalink) Old 02-27-2009, 09:45 PM
BenzWorld Elite
 
Kobus's Avatar
 
Date registered: Apr 2007
Vehicle: 2001 SLK 320(178K Miles), 2002 E320 Special Edition(156K Miles)
Location: South Bay Area,L.A., CA
Posts: 3,326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by c230komp80 View Post
I just spoke with my local dealer and that K-40 relay is gone on my car and is replaced by a Signal Acquisition Monitor ...
O.K., now I think you know exactly what your problem is. MB electronics does not take kindly to some parts of the electronic system being replaced with non-oem parts.



Only two thing are infinite, the universe and human stupidity, and I'm not so sure about the former.
Albert Einstein

Honest politicians are like UFOs. Most people believe that there must be some out there somewhere, but nobody has yet been able to prove their existence.
Kobus is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Error Code p0600??? NCJETSKIER W210 E-Class 0 06-11-2007 06:16 PM
Hard to find wepowe W126 S,SE,SEC,SEL,SD,SDL Class 8 01-01-2007 02:07 PM
Damage Code Definition please.... 2000S430 W220 S-Class 5 10-13-2006 03:36 PM
PLEASE HELP P0600 CODE 95 S320 CHAKIB W140 S-Class 8 10-14-2005 10:22 AM
hard to find parts? WhiteSEC560 W126 S,SE,SEC,SEL,SD,SDL Class 3 05-09-2004 09:08 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome