where is horn fuse in W210 1997? :confused: - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-07-2006, 09:02 AM
BenzWorld Junior Member
 
.::Ğї::.'s Avatar
 
Date registered: May 2006
Vehicle: Mercedes Benz E320
Location: Tbilisi, Georgia
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to .::Ğї::. Send a message via Yahoo to .::Ğї::. Send a message via Skype™ to .::Ğї::.
(Thread Starter)
Exclamation where is horn fuse in W210 1997? :confused:

hello people! my hotn fused burned and i dont know where it is to change it does anyone have map of fuse box on w210 1997 or any king on manual???
thanks a lot!
.::Ğї::. is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-07-2006, 11:44 AM
BenzWorld Elite
 
Date registered: Nov 2005
Vehicle: 1996 210.020
Location: Adrift on a continent...
Posts: 3,972
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
On my '96, the horn fuse is on the K40 relay module. That is the frontmost part inside the module box, near the cabin air intake.
Matt L is offline  
#3 (permalink) Old 01-04-2007, 01:37 PM
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hello, my 97 e420 horn just went out too. I search everywhere but coun't find fuse K40 or K41. Did you find the fuse? If not how did you fix yours.

Thanks
jadi is offline  
#4 (permalink) Old 01-04-2007, 07:57 PM
BenzWorld Elite
 
Date registered: Nov 2005
Vehicle: 1996 210.020
Location: Adrift on a continent...
Posts: 3,972
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I don't know of any K41. K40 is inside the module box. That's under the hood at the right rear (just ahead of the climate-control air intake).
Matt L is offline  
#5 (permalink) Old 01-06-2007, 10:20 AM
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You mean the fuse box next to master cylinder under the hood on driver side. The number only went up to 26. I check every fuse, they all good.
jadi is offline  
#6 (permalink) Old 01-06-2007, 01:34 PM
BenzWorld Elite
 
Date registered: Nov 2005
Vehicle: 1996 210.020
Location: Adrift on a continent...
Posts: 3,972
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Right rear. That's the passenger side for those of us in the US. It's a rather large box, with four phillips-head screws holding the cover down.

The fuse isn't number 40. It's on the K40 relay module, along with a few others. Sorry, I don't remember which one protects the horn circuit.
Matt L is offline  
#7 (permalink) Old 01-06-2007, 10:55 PM
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ok, just got home from work. Will check tomorrow. I did open that box while looking for the fuse. I will now look for the K40 module. I remember there is computer for the car inside among a lot of other connectors and a few (6+/-) 15A fuse and a 40A fuse. Thanks for the info. Will keep you posted.
jadi is offline  
#8 (permalink) Old 01-06-2007, 11:36 PM
BenzWorld Junior Member
 
Date registered: Nov 2006
Vehicle: 99 e320 smoked silver
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
the horn fuse is in the module control box near the cabin intake it the fuse standing in front of the grill looking twoards the rear of the car its the fuse all the way to the left there should only be four in there


hope that helps
mbj898 is offline  
#9 (permalink) Old 01-08-2007, 09:51 AM
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
All the fuse in there are fine. Replace one of the horn in the front with a new one I got from Pepboys still not working. Pull it out, hook it up on the other(low). ...Nothing. Any ideas?
jadi is offline  
#10 (permalink) Old 05-18-2007, 10:04 PM
BenzWorld Newbie
 
Date registered: May 2007
Vehicle: Mercedes E320
Location: Auckland , New Zealand
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Had a horn fuse blown on my E320 , thanks to this forum after a bit of confusion managed to replace it. Attached image of module with horn fuse(extreme left).They are all 15 amp.Name:  Horn_fuse.jpg
Views: 4277
Size:  239.7 KB

Last edited by Mzeedz; 05-18-2007 at 11:42 PM.
Mzeedz is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W210 E-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Where is the Horn Fuse? jeff338 W210 E-Class 22 05-26-2014 10:00 PM
Fuse #21 Blows When Car Is Started - 1997 S320 blacksclass W140 S-Class 4 11-05-2013 08:13 PM
W210 mirror removal?!! very confused LCN W210 E-Class 12 12-14-2006 09:11 PM
Replaced Fuse -- Need Radio Code C230 (1997) raleighbob Audio & Telematics Forum 0 10-29-2006 10:36 AM
E420 (W210 chassis) 1997 jiggie General Mercedes-Benz 1 01-29-2006 10:50 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome