CLK Limp Home Mode!!! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-24-2007, 09:44 AM
BenzWorld Junior Member
 
Date registered: Jun 2007
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation CLK Limp Home Mode!!!

Hi,

I recently had a problem with the Limp mode... after checking my MAF i found nothing to be wrong (after checking the tranny fluid) ... but still ... then i went to another shop where i discovered that the first only wanted MORE MONEY .. & guess what .. the fluid was half a litre ONLY!!!!
so .. we emptied the old one & put this time 3 litres only .. but i'm still suffering from the limp mode .. & this time it is NOT changing from the FIRST ... before changing the fluid it was changing to 1st & snd only ... now it's only 1st !!!!

Guys .. i've tried everyworkshop here & they know NOTHING ...

i think it's something to do with the fluid level (there are NO leaks) .. but maybe 3L aint enough?!!!

Anyone can advice on the right ammount of the tranny fluid?

My car is a CLK 240 / 2003 elegance

thanks in advance
Median is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-24-2007, 12:58 PM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
what kind of shop sare you going to? should have took it to the dealer in the first place.

Anyway low tranny fluid level in a .6 tranny can cause all sorts of issues. 3 liters is not enough. now first off get a tranny dipstick from MB, then when the tranny is hot, check the level and get it to the correct level. then cycle the key and go drive. if it still acts up, you need to go to MB and have them read the fault codes and diagnosis the issue.

now no shop is going to diagnosis your car for free. every shop is going to want up front money for diagnosis. thats how shops work.
Streetglower is offline  
#3 (permalink) Old 06-25-2007, 06:26 AM
BenzWorld Junior Member
 
Date registered: Jun 2007
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I DID ALREADY :(

Well thank you for the reply ...

When i brought the car to the STEALER .. he wanted to change the GEAR BOX!!!!!

only for a LIMP MODE!!!!

so i brought it to some workshops that claim they are MB EXPERTS ... ya right!!!

Then they told me the tranny fluid is OK ... BUT HOW DID THEY VERIFY THAT WITHOUT A DIP STICK!!!!!
where the same shop claimed it's a problem with the transmission!!!!
& i found out it's only 0.5L left in the tranny at another shop!!!!!!!

by the way .. i'm living in the GCC region .. & WE LACK GERMAN CARS EXPERTS HERE .. & the only ones who knows (SOME) stuff they wanna RIP your pocket off...

SO i'm not asking for a FREE service .. i'm asking for the RIGHT service ..
& apparently it's not available here .. where i prefer to sell the car in parts than sending it back to GERMANY to be fixed in the right way ...

Du to posts from different users here i learned the process .. & i'm sure it's the tranny fluid ..

Hope this clarifies my issue with my local stealers & ripshops !!!

I just wanna know how much fluid shall i fill it!!!
if 3 arent enough then how many .. 4 .. 5 .. 12 ???
so i can free it out again & refill the right ammount
ThanX for your help guys ...
Median is offline  
#4 (permalink) Old 06-25-2007, 06:19 PM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,342
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
its usually 3 1/2 quarts to 4 quarts. thats just to fill up.
Streetglower is offline  
#5 (permalink) Old 10-18-2007, 04:46 PM
BenzWorld Newbie
 
Date registered: Oct 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hi, ive just had the same problem as u and need a little advice. Mb softwre didnt read any problems but my 1999 A190-automatic is stuck in limp mode with BAS/ESP light on. My mechanic has drained just 2 litres/2000ml of transmission fluid and there is no dipstick. what is the right amount of trans fluid and will the fluid sort the prblem....how do i get out of limp home mode??? please help
belfasttony is offline  
#6 (permalink) Old 10-19-2007, 04:20 AM
BenzWorld Elite
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 9,251
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 103 Post(s)
This is not a simple exercise like engine oil or coolant top- ups. Also the final level is temperature dependant.
If you have a 722.6 transmission the total ATF content is between 7 to 9 litres.

For information on a service read this:

MercedesShopWiki: 722.6 Transmission Fluid and Filter Change
keyhole is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W209 CLK Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Limp Home Mode revisited gordm W124 E,CE,D,TD Class 4 08-29-2012 10:47 PM
s600 limp home mode getonit W140 S-Class 13 10-06-2010 02:57 PM
Safe Mode/ Limp Home bendont V-Class 10 04-27-2007 08:16 AM
Limp home mode billreddrop W210 E-Class 0 11-23-2006 10:17 AM
My Friend's "Limp Home Mode" bmwm750 W210 E-Class 1 09-14-2005 04:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome