Radiator Fan wont turn off!! Help! - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-07-2010, 03:21 PM   #1 (permalink)
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Send a message via MSN to wf.1990
Angry Radiator Fan wont turn off!! Help!

hello guys! i started my car today after a tranny ATF change, when the Radiator fan in my clk320 turned on and wouldnt turn off.

So whilst still at the shop, he pulled some codes using STAR..it turns out the fan itself was defective, so he changed it with a replacement spare he had..

Still the radiator fan spinned like crazy sounding like jet engine, he also replaced the driver side SAM and a little rectangular metallic box on the driver side front bumper (sorry i dont know wat its called)..and nothin helped!!

no fault codes on the ecu (current or stored)..and the fan would turn of as i turn the engine off..thanks in advance guys..
wf.1990 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-08-2010, 03:21 AM   #2 (permalink)
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Send a message via MSN to wf.1990
anyone?!:S please ive been at 4 mechanics so far and no one could solve it!!

its extremely annoying to have your car sounding like a jet engine all the time!:@ so please, i know you guys are one of the most experienced people in the world when it comes to mercedes, can anyone just help diagnose this problem? thanks guys..
wf.1990 is offline   Reply With Quote
Old 06-08-2010, 06:53 PM   #3 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,108
If he has changed the SAM and fan module then there is only the wiring left to check, get a good electrician to look at the wiring.
__________________
ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline   Reply With Quote
Old 06-08-2010, 08:57 PM   #4 (permalink)
~BANNED~
 
Date registered: Nov 2006
Vehicle: 04 SL500 / 06 ML 500 / JZX VVTI 1JZE
Location: Indyjeho Wa.
Posts: 1,968
Mercedes Sam Module | Circuit and Wiring Diagram
The problem is likely the electrical thermo fan (temperature) switch. Power is sent to it which turns Fans on/off with the pre set factory temp.
Un plug the temp switch. Use an ohmmeter on it with the key off engine cold. Turn on the key. It should read 1.00 (an open circuit) key off, key on Cold 1.00 or its stuck closed or screwed and time to replace it. The only other possibility is a stuck relay in between the switch (Low amperage)and the fuse box/ Sam module (High amperage)which you can trace by using the multimeter also. Proir Temp switch test should help. This shouldn't be hard to diagnose and fix.
Hary Gahtoe is offline   Reply With Quote
Old 06-08-2010, 09:06 PM   #5 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,108
^Good info, this should help
eric242340 is offline   Reply With Quote
Old 06-09-2010, 05:30 AM   #6 (permalink)
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Send a message via MSN to wf.1990
Thanks alot guys!! Well 2 more questions, where exactly is the electrical thermo fan (temperature) switch located? and is the posted link also applicable to a 1999 clk? Thank You again guys
wf.1990 is offline   Reply With Quote
Old 06-09-2010, 07:36 AM   #7 (permalink)
~BANNED~
 
Date registered: Nov 2006
Vehicle: 04 SL500 / 06 ML 500 / JZX VVTI 1JZE
Location: Indyjeho Wa.
Posts: 1,968
I don't have a 6, on a 430 the thermo switch is on the the coolant thermostat housing along with the temp gauge sender unit.
Do a google search W208 Sam module. That one (^)was a 1999-2002 W211

Last edited by Hary Gahtoe; 06-09-2010 at 09:23 AM. Reason: Not enough caffeine
Hary Gahtoe is offline   Reply With Quote
Old 06-09-2010, 10:41 AM   #8 (permalink)
BenzWorld Elite
 
keyhole's Avatar
 
Date registered: Sep 2006
Vehicle: 2004 CLK 240 Coupe
Location: Norfolk. UK
Posts: 8,710
You might take a look at the right front fuse & relay box for signs of corrosion from rainwater ingress. (MB claim that it is only splash-proof, not water proof.)

See this thread: http://www.benzworld.org/forums/gene...ying-s430.html
keyhole is online now   Reply With Quote
Old 10-15-2012, 01:52 PM   #9 (permalink)
BenzWorld Junior Member
 
Date registered: Jan 2006
Vehicle: 2000 CLK320, 2004 E320
Location: Washington DC
Posts: 47
Quote:
Originally Posted by wf.1990 View Post
hello guys! i started my car today after a tranny ATF change, when the Radiator fan in my clk320 turned on and wouldnt turn off.

So whilst still at the shop, he pulled some codes using STAR..it turns out the fan itself was defective, so he changed it with a replacement spare he had..

Still the radiator fan spinned like crazy sounding like jet engine, he also replaced the driver side SAM and a little rectangular metallic box on the driver side front bumper (sorry i dont know wat its called)..and nothin helped!!

no fault codes on the ecu (current or stored)..and the fan would turn of as i turn the engine off..thanks in advance guys..
Hi, did you ever find a solution to your fan problem? My 2000 CLK320 is having the same problem now. Thanks
ooisper is offline   Reply With Quote
Old 10-16-2012, 04:29 AM   #10 (permalink)
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: Clk320 1999 Sport
Location: Beirut, Lebanon
Posts: 56
Send a message via MSN to wf.1990
Well it turned out my airmass flow meter was defective..so maybe you should get it checked..hope that helped
wf.1990 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
doors / boot wont lock - key wont turn alberto28 W202 C-Class 0 05-16-2010 12:33 PM
MERCEDES BENZ CLK 320 Coupe 1999 Need Radiator Fan Shroud+Fan Blade kri7ek General Mercedes-Benz 2 12-07-2009 04:01 PM
Head gasket leveled, New Radiator, new Thermostat, New fan clutch, both Auxiliary fan Workersvillage W124 E,CE,D,TD Class 11 08-10-2008 10:32 PM
engine fan or radiator fan fuse and relays ?? DnBtekhnic W203 C-Class 0 04-21-2008 08:40 AM
heater fan wont turn off....... adrose R170 SLK Class 2 10-18-2002 08:42 PM


All times are GMT -7. The time now is 09:06 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.