How to test ac blower regulator - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-23-2009, 11:41 PM
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
How to test ac blower regulator

Does anyone know how to test an ac/heater blower regulator? My girlfriend have a 99 CLK 320 and the fan is not working. I think it's the regulator but would like to test it before spending $169 on it.

thanks
yatwing is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-24-2009, 10:04 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 358
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There really is no easy way to test the regulator. But it has been my experience that if the regulator goes bad it is because of the blower motor. I would pull the blower motor and regulator out since they are in the same unit and easy to remove and see if maybe it looks like you have had water in the case or anything like that. Really all you can test for at the regulator is power and ground because I think the signal wire from the a/c control unit is PWM(pulse width modulated) and you would need an oscilloscope to test it.
kyle21nluvnit is offline  
#3 (permalink) Old 04-24-2009, 11:40 PM
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks, I'll pull the blower tomorrow to check it out.
yatwing is offline  
#4 (permalink) Old 04-27-2009, 11:53 AM
BenzWorld Junior Member
 
Date registered: May 2008
Vehicle: 99 SLK 230 Sport
Location: Sacramento
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Well, It turns out the contacts where rusted. Disconnected it and reconnected it and it started to work again. A quick fixed but I think next weekend I'm going to take the fan assembly off and clean it up better.
yatwing is offline  
#5 (permalink) Old 07-17-2009, 06:34 PM
BenzWorld Junior Member
 
Date registered: Aug 2004
Vehicle: 1998 SL500, 2002 CLK430
Location: Upper Marlboro, MD
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to queenpumpkin
My ac motor is not working in my 02 CLK 430. Can you tell me where to find it how to remove it? Female working on her own car...any help appreciated.
queenpumpkin is offline  
#6 (permalink) Old 12-07-2009, 03:52 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1999 CLK 430
Location: West Babylon, NY
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to johnsmohr111
Thumbs up Cleaned the contacts on ac/heat blower motor

Quote:
Originally Posted by yatwing View Post
Well, It turns out the contacts where rusted. Disconnected it and reconnected it and it started to work again. A quick fixed but I think next weekend I'm going to take the fan assembly off and clean it up better.
Just had same issue with my 99 clk 430 found how to take out on another thread on here and cleaned up contacts. Wallah works like a charm Thanks for the advice this site is awesome.
johnsmohr111 is offline  
#7 (permalink) Old 12-07-2009, 07:41 PM
BenzWorld Elite
 
Date registered: May 2005
Vehicle: 99CLK320
Location: Lincoln, NE 68516-6548
Posts: 1,480
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
John, would you please post a link to that fix. Good one to keep on file. TIA!
dlbehrns is offline  
#8 (permalink) Old 12-07-2009, 07:55 PM
BenzWorld Junior Member
 
Date registered: Mar 2009
Vehicle: 1999 CLK 430
Location: West Babylon, NY
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to johnsmohr111
Quote:
Originally Posted by dlbehrns View Post
John, would you please post a link to that fix. Good one to keep on file. TIA!
I used the diagram from this tread to locate and take out, not same model but in same location and pretty much the same as my unit. Hope it helps everyone.

http://www.benzworld.org/forums/w208...regulator.html

BTW it took me about 1/2 hour to take out clean and put back. Very simple.
johnsmohr111 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1998 W210 E300DT Bad Blower Regulator or Blower Motor?? How to tell DieselNuts W210 E-Class 12 08-16-2012 09:32 AM
1994 S500V W140 BLOWER AND BLOWER REGULATOR dbs600 W140 S-Class 8 02-13-2012 01:01 PM
blower regulator mmir110 W126 S,SE,SEC,SEL,SD,SDL Class 1 02-27-2008 12:24 PM
Need a Blower regulator ????? Big"D"inTheMB W210 E-Class 0 07-19-2007 11:43 AM
Blower Regulator pollyperkins13 W140 S-Class 3 11-28-2005 07:57 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome