Electric seat not working... - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-14-2009, 02:35 AM
BenzWorld Member
 
Sunray's Avatar
 
Date registered: Dec 2008
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Electric seat not working...

HI,

My CLK 320 electric seat on the driver side is not functioning, the forward and backward movement is not working but the back rest and the head rest works perfectly. Can someone advice how i can shift my seat backward to the position i preferred for driving?

Anyone had similar experince or know what is wrong?

Rgds
Ray
Sunray is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-14-2009, 10:53 AM
BenzWorld Junior Member
 
bruceinla's Avatar
 
Date registered: Dec 2008
Vehicle: none
Location: Oak Park, CA.
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
search the archives for seat motor, the motor itself goes bad from what I have read before

Bruce
bruceinla is offline  
#3 (permalink) Old 02-14-2009, 10:56 AM
BenzWorld Member
 
arashsheikhpoor15's Avatar
 
Date registered: Oct 2008
Vehicle: 2002 CLK 55 AMG
Location: woodland hills, Ca
Posts: 244
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to arashsheikhpoor15
yes, do a search...or look at some of my posts, i posted the same question, and received lots of good answers.
arashsheikhpoor15 is offline  
#4 (permalink) Old 02-14-2009, 06:11 PM
BenzWorld Senior Member
 
Date registered: Feb 2003
Vehicle: 2002 CLK55///04BMWxi///2010GLK350
Location: North of Boston
Posts: 438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
I assume that you have already checked the fuses in the trunk (most common fix/problem). If those are all good, then it's time for a motor replacement...$100 from dealer...remove seat...easy install.

2002 Obsidian Black CLK55
2010 GLK350 4matic
tomtomtomtom is offline  
#5 (permalink) Old 02-14-2009, 07:07 PM
BenzWorld Member
 
Sunray's Avatar
 
Date registered: Dec 2008
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by tomtomtomtom View Post
I assume that you have already checked the fuses in the trunk (most common fix/problem). If those are all good, then it's time for a motor replacement...$100 from dealer...remove seat...easy install.
Hi Mr Tom,

Do you have a guide on how i can check the fuse? And which fuse is for the seat? Please help..!

Rgds
Sunray is offline  
#6 (permalink) Old 02-15-2009, 06:26 AM
BenzWorld Senior Member
 
Date registered: Feb 2003
Vehicle: 2002 CLK55///04BMWxi///2010GLK350
Location: North of Boston
Posts: 438
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
open the trunk..lift off cover...right rear, you will see black box...If I remember correctly, it is the first or second fuse...there is a diagram on inside of cover.

2002 Obsidian Black CLK55
2010 GLK350 4matic
tomtomtomtom is offline  
#7 (permalink) Old 02-15-2009, 08:28 PM
BenzWorld Member
 
Sunray's Avatar
 
Date registered: Dec 2008
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
HiTomtomtom,

Hmhm.. thats a good piece of advice. But how would i know whether the fuse is ok or not? Sorry, i know i might be asking silly question. But this is my 1st car so i am a bit lost.

Rgds
Sunray is offline  
#8 (permalink) Old 02-16-2009, 04:12 PM
BenzWorld Junior Member
 
ludbg's Avatar
 
Date registered: Feb 2009
Vehicle: 1998 CLK320
Location: Chicago, IL
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Sunray View Post
HiTomtomtom,

Hmhm.. thats a good piece of advice. But how would i know whether the fuse is ok or not? Sorry, i know i might be asking silly question. But this is my 1st car so i am a bit lost.

Rgds
take out all the fuses 1 by 1, look at it closely and there is like a little wire inside .... see if its broken. if the wire is fine, the fuse is fine.
hope that helps
ludbg is offline  
#9 (permalink) Old 02-16-2009, 07:16 PM
BenzWorld Member
 
Sunray's Avatar
 
Date registered: Dec 2008
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Many thanks.

But I have checked, all my controls are working except for the forward and backward. I presume that only one fuse are for the full seat adjustment, therefore it shouldnt be the fuse problem i think.
Sunray is offline  
#10 (permalink) Old 02-16-2009, 07:45 PM
BenzWorld Junior Member
 
ludbg's Avatar
 
Date registered: Feb 2009
Vehicle: 1998 CLK320
Location: Chicago, IL
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Sunray View Post
Many thanks.

But I have checked, all my controls are working except for the forward and backward. I presume that only one fuse are for the full seat adjustment, therefore it shouldnt be the fuse problem i think.
yep my passenger seat has the same problem. i can still hear a clicking sound when i press the backward and forward button though.... like its stuck...

does anyone if there is a separate motor for up and down and backward and forward?
ludbg is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Electric seat belt not working on 94 Coupe fifalex W124 E,CE,D,TD Class 20 10-19-2010 10:08 AM
Electric Seat not working - CLK 320...!!! Sunray General Mercedes-Benz 6 02-23-2009 02:22 PM
drivers electric seat stopped working 100% palmer3914 W210 E-Class 15 02-19-2009 03:26 PM
Electric Seat not working Guest (MBNZ) W210 E-Class 10 12-03-2008 11:40 PM
Passenger electric seat not working Cori W163 M-Class 1 01-26-2002 11:00 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome