Check engine light, but the car feels great!? - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-15-2008, 11:45 PM   #1 (permalink)
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
Check engine light, but the car feels great!?

I've only owned this car for about 1k miles and was serviced by MB before i bought it. So ya this light popped up on me tonight.

Car doesn't feel any different. No lag in accel, no rough idle. Checked fluids.
I hope its just bad gas.
Is it worth buying a code checker? I can do alota basic service myself.

I hope my baby is okay
__________________

CLK55 - 2002 / E320 - 2003
Vogtland Springs / Koni Sp / VIPclk320 R Strut
OZ Ultraleggera lightweight (18.3 lb)
Green Filters + Race Cats / SprintBooster
Pioneer AVIC-X910BT / Basslink
Cailbre K40 Hidden Radar Jammer
Ceramic 20% Gloss Tint
gizzo is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-16-2008, 06:53 AM   #2 (permalink)
BenzWorld Member
 
nmilsaps's Avatar
 
Date registered: Mar 2007
Vehicle: 2001 CLK 430
Location: Houston, TX
Posts: 159
Congrats and welcome.
Autozone has a code reader that they have used on my car for free. I'd try that first, if they have them in CA.
nmilsaps is offline   Reply With Quote
Old 06-16-2008, 10:54 AM   #3 (permalink)
BenzWorld Junior Member
 
Cinellipro's Avatar
 
Date registered: May 2008
Vehicle: CLK320 1999 Black/Black/Black
Location: South Florida
Posts: 9
A code checker is definitely worth it if you're a "do it yourself er." However, my check engine light was turning on intermittently. I was told by my mechanic that it has to do with the Ethanol being added to fuel that is not mixing well and is causing the sensors to get false readings.
He said stick to Chevron as they have not added the ethanol mix yet. I cannot say how much of this is reality, but when I started pumping Chevron the check engine light went off, and has stayed off.
Cinellipro is offline   Reply With Quote
Old 06-16-2008, 11:47 AM   #4 (permalink)
BenzWorld Member
 
Date registered: Jul 2007
Vehicle: 2002 CLK 430
Location: Chicago, IL
Posts: 297
I had the exact same issue and it was because of the pressure in the fuel system... only going to feel something like that in pretty extreme driving circumstances. Then I got rear-ended and the other fixes fixed the problem.

Would also recommend the auto-zone free read. If you're gonna buy one then you have to decide if you want the standard readable (pretty cheap) or the one with all the extended MB codes (not as cheap, needs a computer connection)
skiflyer is offline   Reply With Quote
Old 06-16-2008, 02:01 PM   #5 (permalink)
BenzWorld Senior Member
 
sfclk's Avatar
 
Date registered: Mar 2008
Vehicle: 1999 CLK320
Location: San Francisco
Posts: 446
Send a message via AIM to sfclk
My CEL also comes on and off. It turns off usually after 3 drives of 20 mins each.

Next time the CEL comes on I'll take it to Autozone.

Then maybe then, I'll try filling with Chevron instead of Shell.
sfclk is offline   Reply With Quote
Old 06-17-2008, 07:21 AM   #6 (permalink)
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 344
Cool

Check code
Reset code
Fill up with good gas
install gas cap (ensure its tight and the seal is good)

DrIVe ...

If no more light, no more problem
If light come back, check code again. At least that will start loggin you some troubleshooting history.
__________________

--John
2006 CLS500
unlukky is offline   Reply With Quote
Old 06-18-2008, 10:04 PM   #7 (permalink)
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
So the check engine light disapeared wasn't able to check what it was.

But now when i start the car, the 2 red lights at the top of the instrument cluster light up. Then make sounds like a radar detector with the beeps and stuff then go to green light, after the red lights flicker.
Is this the SOS system, i did push the info button a few days ago.

Don't see any referance to it in the manual


Last edited by gizzo; 06-18-2008 at 10:47 PM.
gizzo is offline   Reply With Quote
Old 06-21-2008, 12:46 AM   #8 (permalink)
BenzWorld Member
 
gizzo's Avatar
 
Date registered: Apr 2004
Vehicle: 89' 190e 2.6 / 02' CLK55 AMG
Location: Playa del Rey, CA
Posts: 138
any ideas?
gizzo is offline   Reply With Quote
Old 06-24-2008, 05:22 AM   #9 (permalink)
BenzWorld Member
 
unlukky's Avatar
 
Date registered: May 2007
Vehicle: 2006 CLS500
Location: Fort Worth, TX
Posts: 344
Post

I believe that even if u dont currently have the CEL light, you can still check fault history. Not sure though. Might have even been the gas cap. I have no idea what those lights are. I have an '01. They should be the same. I'll check the next time I get in...
unlukky is offline   Reply With Quote
Old 06-24-2008, 09:24 AM   #10 (permalink)
BenzWorld Member
 
Date registered: May 2005
Vehicle: 2000 CLK 430
Location: NC
Posts: 99
My car had a flat tire, I jacked it up to replaced with the spare tire. After that I replaced the air filters. The next day CEL came on. Without doing anything I drove for 2 days and it was gone. A day later it came on again and has stayed on. I don't feel like losing any power, idle is great. It's still on the spare tire. anybody know if changing the filters or jacking the car up, or running on the spare tire could cause the CEL to come on? Is there any way to reset it?
benzo4me is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > W208 CLK Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Check Engine Light / Car Stalls @ Stop Light jasonryan11 R171 SLK Class 2 08-03-2007 06:56 AM
Bottom of car got scraped, then check engine light came on JJB236 W124 E,CE,D,TD Class 5 02-01-2007 05:00 PM
Check Engine Light is ON and car rumbles... EUROSOE W203 C-Class 9 01-14-2007 10:42 AM
So my check engine light came on. I took car to the Carlo$ R129 SL Class 1 04-30-2004 10:23 AM
Check engine light back on - feels like home again. ScubaDriver W163 M-Class 0 10-14-2003 08:30 PM


All times are GMT -7. The time now is 02:33 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.