Subwoofer + Amp Install *with pics - Page 3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#21 (permalink) Old 09-18-2008, 12:43 PM
BenzWorld Junior Member
 
Date registered: Sep 2008
Vehicle: 07 G500 Blck, 09 C300 4-Matic Palladium Silver
Location: N. VA
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by delirium View Post
is your amp actually screwed down in the spare tire well or is it just sitting there?
Did they have to run the power all the way to the front of the car where the battery is or can you tap in somewhere?
Think about it this way, if you did not bolt the amp down, every time you hit a bump or something, it would be knocked around and probably eventually break. As for the wiring, if you don't run it to the battery through the fire-wall, well, it could have bad consequences. Say you tap into some wire. That wire is set up to send a particular amount of current to a certain component and that wire has a fuse to it to prevent too much current from going through it (the fuses are in the trunk, right side). If you suck up some of that current, you can overload that circuit and blow the fuse, or prevent whatever component the power is supposed to go to from operating properly, or make the car give you some sort of warning light if it's monitoring the voltage/current on the line you tapped into. Always better to go to the battery.
JulesH is offline  
Sponsored Links
Advertisement
 
#22 (permalink) Old 09-29-2008, 10:11 AM
BenzWorld Member
 
Murray Woo's Avatar
 
Date registered: Jun 2008
Posts: 61
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oh, I am coming from a 1997 Mustang to a C350 (sweet upgrade) and I did the whole system on the Mustang myself so I am not a newbie. But I did everything with the Crutchfield mastersheet and there isn't one available for C350 yet. I just want to install a pair of tweeters for more highs and a sub and an amp for more lows. I want to do the tweeters first though. I am not looking for supre high volume - just more clarity and more bass. Can I just swap out the factory tweeters and mount aftermarket ones on without new crossovers? Or do I need to install new crossovers too? My car is leased so I want to mess with it as little as possible... Thanks!
Murray Woo is offline  
#23 (permalink) Old 02-25-2009, 08:19 PM
BenzWorld Newbie
 
Date registered: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
C300

Hey I have a Mercedes C300 Sport 2008 model, and I wanted to install a sub and amp. I was wondering where the factory amp is? Or how I can install this? Any help/ideas??? Thanks
anish08 is offline  
#24 (permalink) Old 03-16-2009, 04:52 PM
BenzWorld Newbie
 
Date registered: Mar 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
yeah i like the way its hidden thats sick.
KEVINwitdaBENZ is offline  
#25 (permalink) Old 07-15-2009, 10:24 AM
BenzWorld Newbie
 
Date registered: Jul 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
im triing to hook up my system myself but ran to a problem.does the c300 have a factory amp and if it does where is it located?

when i installed a memphis 1000 watt amp to my subwoofer it was running great when i installed the door speaker with a 4 channel 550 amp something burned out now there is no sounds.so im thinking i burned out the factory amp that is why there is no sounds anyone know?
anthonyhuynh1984 is offline  
#26 (permalink) Old 07-18-2009, 12:04 AM
BenzWorld Newbie
 
Date registered: Jul 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
remote power wire for the amp

Has anyone figured out a good place to tap into for the remote power wire for the amp off of the built in amp in the back of the car? I have a 2009 C300 with the Harman Kardon Logic 7 system. I've got all my wires run and my LOC spliced off the center speaker (sub) in the back. I managed to tap into a fuse on the right side of the car in the trunk that only turns on when the ignition turns on, but I'm concerned about that. I would think there would be a line coming from the HK amp built in on the left side of the car, but that's a lot of wires to be trying to test without a diagram!

Anyone got any ideas on the remote power wire for the amp? I'd like to get that wired up properly. I'm kinda shocked that all the amazing engineering gone into this car that they didn't hook you up with a RCA out of the amp in the back. Hopefully this will become true in future cars. This car came apart like nothing I've ever seen. I was amazed at the thought put into the wiring and how it was run. Mercedes rocks!

Thanks folks! I'm gonna take another whack in the morning.
drumfreak is offline  
#27 (permalink) Old 07-21-2009, 12:54 AM
HARJOT900
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
How much is was the install on this car??? I want to get that done to my benz I have the speakers,wires,AMP,RCA converter. I have the MM package. How do you install it???
#28 (permalink) Old 06-24-2010, 09:47 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Vehicle: 1999 Mercedes-Benz E320 4MATIC
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Very nice install!
BenzÅ∂∂ict is offline  
#29 (permalink) Old 07-26-2010, 03:55 PM
BenzWorld Member
 
Date registered: Jul 2007
Location: OC, Ca.
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hazemonster, nice setup. I too have the MM package with HK but want some bass.

Do you know if i can simply tap into the high level output of the rear speakers, it looks like your installer used high level inputs? Also, do you know where the switched remote wire on the amp is connected to?
delirium is offline  
#30 (permalink) Old 07-26-2010, 03:59 PM
BenzWorld Member
 
Date registered: Jul 2007
Location: OC, Ca.
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by drumfreak View Post
Has anyone figured out a good place to tap into for the remote power wire for the amp off of the built in amp in the back of the car? I have a 2009 C300 with the Harman Kardon Logic 7 system. I've got all my wires run and my LOC spliced off the center speaker (sub) in the back. I managed to tap into a fuse on the right side of the car in the trunk that only turns on when the ignition turns on, but I'm concerned about that. I would think there would be a line coming from the HK amp built in on the left side of the car, but that's a lot of wires to be trying to test without a diagram!

Anyone got any ideas on the remote power wire for the amp? I'd like to get that wired up properly. I'm kinda shocked that all the amazing engineering gone into this car that they didn't hook you up with a RCA out of the amp in the back. Hopefully this will become true in future cars. This car came apart like nothing I've ever seen. I was amazed at the thought put into the wiring and how it was run. Mercedes rocks!

Thanks folks! I'm gonna take another whack in the morning.
Hey drumfreak, I think the remote out on to a fuse should be ok.
as for your LOC, why didnt you use high level inputs instead of a LOC? Also how did you find the rear speaker wires? they look pretty well concealed to me...
delirium is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W204 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Infinity Subwoofer/amp install traumadoc G-Class 11 09-24-2007 03:09 PM
Subwoofer/Amp Install and Wiring da_guitarist W208 CLK Class 7 08-27-2007 07:44 AM
2002 ML500 subwoofer/amp install captain morgan Audio & Telematics Forum 18 08-23-2005 08:12 AM
2002 ML500 subwoofer/amp install captain morgan W163 M-Class 5 08-06-2005 11:01 AM
planning to install subwoofer and amp dt77 W163 M-Class 1 02-11-2003 10:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome