c32 secondary air injection malfunction - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-23-2010, 08:07 PM   #1 (permalink)
BenzWorld Member
 
Date registered: Apr 2008
Posts: 52
c32 secondary air injection malfunction

hey, hooked up my car to the computer and got this code malfucntion. c32 79k on it. whats the best way to check if is the entire bulb or just a fuse or valve? I have noticed some lost of accerlation. the check engine light went on, while i was doing like 70 mph on the highway. I had the kid who used the machine clear the code.
Mitchell_NY is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-24-2010, 07:50 PM   #2 (permalink)
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
The air pump is known to fail, and it's in no way a cheap part ($650+). There's also the possibility of the fuse or relay (maybe one unit - relay) blowing, but this is normally caused by the pump starting to go. Best way to diagnose is through STAR diagnostics.
__________________

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline   Reply With Quote
Old 04-24-2010, 02:12 PM   #3 (permalink)
BenzWorld Newbie
 
Date registered: Apr 2010
Posts: 1
Post Air Injection Pump

I own an 02 C32 AMG and recently the check engine light has come on and the problem is the air injection pump. Also since the light has come on I have began to feel a hard shift between 1st and 2nd gear. It is even worst at low speeds. The MB dealership says that the pump is causing it all and a new pump will fix the problem. I don't understand how a pump that feeds air into the exhaust can cause the car to shift so bad. Has anyone else had this problem?????
oasp88 is offline   Reply With Quote
Old 04-24-2010, 11:21 PM   #4 (permalink)
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
It wouldn't... The bad shifting might be due to glycol contamination of the transmission. The original Valeo radiator is known to leak coolant into the transmission. Dealership can perform a glycol contamination test, or you can take your own sample, and send it off to black stone labs.
2002c230 is offline   Reply With Quote
Old 02-27-2011, 11:44 AM   #5 (permalink)
BenzWorld Member
 
Date registered: May 2006
Vehicle: 2002 C32 AMG Black and 2003 ML55 AMG Black
Location: LA
Posts: 51
Possible dumb question, however.... how does the radiator leak into the transmission?
C32JET is offline   Reply With Quote
Old 02-28-2011, 07:44 AM   #6 (permalink)
BenzWorld Member
 
Date registered: May 2006
Vehicle: 2002 C32 AMG Black and 2003 ML55 AMG Black
Location: LA
Posts: 51
Anyone have the part number for the secondary air pump and also the relay fuse?

My CEL light is on and throwing this code. Just moved to CA and smog test got me. Automatic fail is what I am told when CEL is on with this code. Before heading into to stealer wanted to get my info in order.
C32JET is offline   Reply With Quote
Old 03-01-2011, 10:51 PM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Oct 2008
Posts: 5
hey guys i have a c32 amg its '03. I'm having the same problem with my car. I checked with the dealer they said its the Secondary Air Injection System... ive been reading these posts some people are saying that their cel stop appearing after they replace the relay. Can some one point out where the relay is located so i can take a look at it.
Sonu is offline   Reply With Quote
Old 03-01-2011, 11:20 PM   #8 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,249
Quote:
Originally Posted by C32JET View Post
Possible dumb question, however.... how does the radiator leak into the transmission?
The transmission oil cooler is an integral part of the radiator and a leak between the two is therefore possible and has happened quite often.
__________________
ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline   Reply With Quote
Old 03-01-2011, 11:29 PM   #9 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,249
Quote:
Originally Posted by C32JET View Post
Anyone have the part number for the secondary air pump and also the relay fuse?

My CEL light is on and throwing this code. Just moved to CA and smog test got me. Automatic fail is what I am told when CEL is on with this code. Before heading into to stealer wanted to get my info in order.
Engine compartment left, click to enlarge. (N10/1)
Attached Thumbnails
c32 secondary air injection malfunction-snap9.jpg   c32 secondary air injection malfunction-snap10.jpg  
eric242340 is offline   Reply With Quote
Old 03-01-2011, 11:41 PM   #10 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,249
Sorry I forgot to say the relay box pic is for the W203 C32 AMG Kompressor.
eric242340 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
P0410 Secondary Air INjection System Malfunction Serdar W163 M-Class 95 06-25-2013 05:10 AM
MORE HELP. SLK 320 p0410 secondary air injection system malfunction socalslk320 R170 SLK Class 10 08-24-2012 10:57 AM
Po410 secondary air injection malfunction Solidjake W163 M-Class 4 09-14-2008 03:47 PM
P0410 Secondary Air Injection System Malfunction olliecampbell W215 CL Class 0 09-10-2008 12:02 PM
P0410: Secondary Air Injection Malfunction Cklasse303 R170 SLK Class 5 05-04-2005 01:08 PM


All times are GMT -7. The time now is 01:26 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.