Digital display is faded on my C230 (can't read hardly anything on it) - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-31-2008, 12:51 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2007
Vehicle: 2002 Mercedez Benz C230K Coupe
Location: Los Angeles
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Digital display is faded on my C230 (can't read hardly anything on it)

Hey Guys! I am new to this site so I haven't been able to find anything on the problem I am having with my 02 C230 Coupe. I bought it a year ago and after a few days I noticed that the electronic display that shows the time, mileage, radio station, odometer etc... was faded. When the car is parked in the sunlight. the display is so faded that you can only read what is in the complete middle of the display. Oddly when it is not in heat or sunlight the display is crisp and clean. I don't understand if the display is bad than it display would always be faded. I am stumped as far as what I need to change? Is it the display or some other component? I anyone has any idea I would be most grateful. Thanks
Ninjad is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-31-2008, 10:02 PM
BenzWorld Member
 
Date registered: Jul 2006
Vehicle: 05 C55, no nav, silver/black, Mahdi 19" wheels, tint
Location: Irvine
Posts: 77
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My display did the same thing during some abnormally hot days (high 90s) when my car was parked in the sun for a while. It was so dim I couldn't read it. But it was fine on other days and hasn't done it again. I asked the dealer to check it, since this hadn't happened in the 2 years I've had the car (C55). They said it checked out ok, so I guess it was just a high temperature condition. Suggest you use a sunshade in your windshield to keep temp around instrument cluster lower, and try to avoid too much hot sun exposure. Good luck with it.
keninirvine is offline  
post #3 of 8 (permalink) Old 09-05-2008, 08:58 PM
BenzWorld Member
 
AMGlover4life's Avatar
 
Date registered: Aug 2008
Vehicle: 2006 c230 sport, 2006 BMW 330
Location: Aventura, Fl
Posts: 279
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
adjust the density with the little twist knob to the left.
AMGlover4life is offline  
post #4 of 8 (permalink) Old 02-19-2009, 12:44 AM
BenzWorld Newbie
 
Date registered: Aug 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Did you solve the problem? My display does this too when the weather is warm. It's almost useless. Dimmer is not the issue. It acts like the heat has ruined the orange display.
msubulldogtx is offline  
post #5 of 8 (permalink) Old 02-19-2009, 11:51 AM Thread Starter
BenzWorld Newbie
 
Date registered: May 2007
Vehicle: 2002 Mercedez Benz C230K Coupe
Location: Los Angeles
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Unfortunately I haven't had any success in resolving the problem. I will check the density gage tonight and see if that does anything! I'll post what happens.
Fingers are crossed!
Ninjad is offline  
post #6 of 8 (permalink) Old 06-07-2010, 02:48 PM
BenzWorld Junior Member
 
Date registered: Apr 2010
Vehicle: 2004 C230 Kompressor Coupe (Manual)
Location: Santa Cruz, CA
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Any success on this? I've never noticed a density guage before, just the panel light adjustment/reset knob.
ibdjtrip is offline  
post #7 of 8 (permalink) Old 06-11-2010, 01:13 PM
BenzWorld Junior Member
 
Date registered: Jun 2010
Vehicle: c200k coupe panoramic evo amg
Location: East Yorkshire
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My display doesn't like the hot sun either, the top line all but disapears, but things return to normal once tempertures drop. I live in the UK so this is not a huge problem for me....
pistol pete is offline  
post #8 of 8 (permalink) Old 06-17-2010, 05:17 PM
BenzWorld Junior Member
 
Wardsweb's Avatar
 
Date registered: Jun 2010
Vehicle: SL550, C240, ML350
Location: San Antonio, TX
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Wardsweb is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W203 C32 AMG, C55 AMG

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    How to Fix Dim Digital Odometer Display SAFRYNFJ W140 S-Class 29 10-30-2015 02:27 AM
    Digital dash display Benz Bling V-Class 0 03-19-2007 05:29 AM
    Digital Temperature display Smifster V-Class 0 08-13-2006 04:02 PM
    Cluster Gauge Digital Display Kouzaymos560SEL W126 S,SE,SEC,SEL,SD,SDL Class 10 04-13-2006 09:37 AM
    Digital Speedo Display jst like the W209 benzonlorinzo C208/A208 CLK-Class 1 07-26-2004 04:11 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome