C320 2003 Key does not work Help! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-20-2010, 11:47 AM
BenzWorld Newbie
 
Date registered: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
C320 2003 Key does not work Help!

My keyless key will not start my car, the buttons work to unlock the doors ect...
but it will not turn in the ignition.

Every dealer I talk to has a different story, is there a way I can reprogram this myself.

Any help is appreciated

Thanks
pjoseph is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-20-2010, 12:55 PM
BenzWorld Junior Member
 
Date registered: May 2009
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
There could be a couple of things, but it could also be something very simple. this has happened to me, my car was park at a decline with the tires turned all the way left.

when you put in your key, does it make that grinding noise that it normally does ???

if not, it is just as if your steering wheel is locked... what i did was insert the key, unload my parking brake, and since my car was standard i let the car slide a little. turned the steering wheel a little bit and the grinding noise came meaning that the key has been recognized.

let me know if that works.
atiqraza is offline  
#3 (permalink) Old 05-20-2010, 03:59 PM
BenzWorld Newbie
 
Date registered: Jan 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thanks for the reply

I decided to change the batteries and now the car starts. they should have some kind of key start as a backup. For some reason now the car does not open when you hit the unlock button but all others work, I am happy the car starts at this point.

thanks
pjoseph is offline  
#4 (permalink) Old 05-20-2010, 06:26 PM
BenzWorld Elite
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2007 CLK550 Cabriolet, 2002 C240 FORMER: 2001 ML320
Location: Birmingham, AL
Posts: 9,213
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
The battery in the Smartkey has nothing to do with the key's ability to start the engine. There is an indutive coil inside the ignition switch that powers the key for starting. The battery is only for the remote control functions. Something else was wrong here. Like Agra's asked, did you here the usual mechanical "grinding" noise when inserting the key in the ignition switch? If so, that means that the Drive Authorization System validated the key. From there, the inability to rotate the ignition switch is purely a mechanical problem. If there was no noise, then DAS did not recognize the key and again, that's not an issue with the battery in the fob.

--

- RODNEY
rudeney is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2003 c320 4matic conradf W203 C-Class 4 08-22-2010 08:08 PM
C320 Key/Ignition Problem Turbo6 W203 C-Class 12 01-22-2009 06:14 AM
2001 c320 doesn't recognize smart key scorpnaz7 W203 C-Class 12 11-14-2007 05:54 PM
"B" Service for 2003 C320 N1ML W203 C-Class 1 02-11-2006 07:57 AM
questions about 2003 C320...please help pz420 W203 C-Class 3 07-29-2005 10:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome