Wipers, indicators and fuel gauge don't work after battery change - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-27-2010, 01:01 PM
BenzWorld Newbie
 
Date registered: Mar 2010
Vehicle: Mercedes C220 CDI (2001)
Location: UK
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Wipers, indicators and fuel gauge don't work after battery change

Tried to start the car the other day but the battery was dead. Bought a new battery and fitted it - starts fine with one small problem - the windscreen wipers, indicators and fuel gauge don't appear to work - with the error on the display console saying take it to the dealer.

Anybody have any ideas as to what could be wrong? I checked the fuses and they all seem fine.
randomcup is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-27-2010, 02:06 PM
BenzWorld Elite
 
Buellwinkle's Avatar
 
Date registered: Aug 2002
Vehicle: C230K Sport Sedan
Location: The O.C.
Posts: 5,368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Probably took out a SAM when you connected/disconnected the battery charger. Some early year C's were very sensitive to this. Figure a couple of hundred bucks at a dealer to replace. Not cheap like a new battery would have been, but not terribly expensive.

Please share your model and year and location in your profile, that way we may be able to provide a more specific answer.

2004.5 C230K - Pewter/Charcoal - www.Buellwinkle.com



http://www.mylavista.com
Buellwinkle is offline  
#3 (permalink) Old 04-27-2010, 02:44 PM
BenzWorld Newbie
 
Date registered: Mar 2010
Vehicle: Mercedes C220 CDI (2001)
Location: UK
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Buellwinkle View Post
Probably took out a SAM when you connected/disconnected the battery charger. Some early year C's were very sensitive to this. Figure a couple of hundred bucks at a dealer to replace. Not cheap like a new battery would have been, but not terribly expensive.

Please share your model and year and location in your profile, that way we may be able to provide a more specific answer.
Thanks for the reply Buellwinkle. Updated my profile. Looks like you might be right as the car was quite an early C. Would hooking a battery up have caused this? Sounds like a trip to the dealer job anyway.
randomcup is offline  
#4 (permalink) Old 04-27-2010, 11:36 PM
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think if your SAM module still good, you may activate the unwork component by reprogramming again. This call "CODING" using STAR DIAG to program.
Actually when we need to swap the battery, we must copy the SAM data to the STAR before disconnect the battery and load the data back to SAM module when new battery connected.

However if SAM module is bad, you need new SAM module and reCODING it again that should be done at Mercedes shop.

W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline  
#5 (permalink) Old 04-28-2010, 06:55 PM
BenzWorld Member
 
Date registered: Mar 2010
Posts: 90
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
u blew out the rear sam. needs to be replaced. its in the trunk on the left side and needs to be coded to work
mbtech101 is offline  
#6 (permalink) Old 04-29-2010, 11:37 AM
BenzWorld Elite
 
Buellwinkle's Avatar
 
Date registered: Aug 2002
Vehicle: C230K Sport Sedan
Location: The O.C.
Posts: 5,368
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I hate to say but a dealer is your best bet.

2004.5 C230K - Pewter/Charcoal - www.Buellwinkle.com



http://www.mylavista.com
Buellwinkle is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help with flashing indicators after battery change f4rrs W210 E-Class 2 11-27-2007 11:09 AM
Indicators don't work in humid weather, also gas gauge Makarov1 W202 C-Class 3 05-08-2005 10:48 PM
how fuel gauge sending unit work?? madrassa W124 E,CE,D,TD Class 0 08-08-2004 05:43 PM
Fuel Gauge Doesn't Work Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 2 08-12-2002 09:29 PM
fuel gauge does'nt work properly Guest (MBNZ) W202 C-Class 4 09-27-2001 06:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome