Smart Key Problem - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-24-2010, 10:00 AM
BenzWorld Newbie
 
Date registered: May 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Smart Key Problem

Hi Everyone,

I got a problem with using my smart keys and while I have found a great many posts that talk about smart key issues, I have yet to see one that discusses the specific issues I am having. Here is what I know:

Info: 2003 C32 4-Door Sedan

Symptoms: After the car sits for a while 1+ hours the smart key fails to unlock/lock the car. After manually unlocking the car and placing the key in the ignition, regardless of whether I started the car or not, the key will work once again.

Diagnosis:
1. At first I thought it was the batteries in the key so I checked them. I also tried my spare key....the problem persisted with both keys, which points to the problem being in the car.

2. I thought I had an issue with the battery in the car. I had the charging system tested and it seems to be working fine.

3. I thought there could be a draw or short on the battery, so last night I record the battery voltage when I parked the car 12.87V, this morning I went out and checked the voltage to see how much it had been drained but it showed 12.47V.

4. Since the smart key works part of the time, I doubt it's the IR or RF antenna.

My theory:
There is something wrong with the EIS or the receiver in the the car? Has anyone else experienced something like this?
asicman is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-25-2010, 07:48 AM
BenzWorld Elite
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2007 CLK550 Cabriolet, 2002 C240 FORMER: 2001 ML320
Location: Birmingham, AL
Posts: 9,303
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Try the resync procedure for the key - turn the key to position 2 (don't start the engine), then back to position 0 and remove it. Hold the "lock" button on the fob and then press the "unlock" button on the fob five times within ten seconds. If that doesn't work, try removing and re-inserting fuse #8.

--

- RODNEY
rudeney is offline  
#3 (permalink) Old 04-25-2010, 04:47 PM
BenzWorld Newbie
 
Date registered: May 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the reply but it didn't work.
asicman is offline  
#4 (permalink) Old 04-26-2010, 06:37 PM
BenzWorld Elite
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2007 CLK550 Cabriolet, 2002 C240 FORMER: 2001 ML320
Location: Birmingham, AL
Posts: 9,303
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Remote unlocking uses a rolling code security system. This is exactly what happens when the rolling code gets out of sync (which is why I suggested the resync procedure). You say you checked the batteries in the keys - did you actually replace them? The ignition switch does have a coil in it that can inductively power the key so that even if the battery is dead, it can still be validated. It's possible the batteries are dead and the ignition switch is giving them just enough power to work for an hour.

I guess it's also possible that the car's system is failing. You might try disconnecting the car's battery for about 10 minutes to "reboot" its electronics. Nothing "bad" will happen, but you will have to resync steering angle sensor (turn the steering wheel lock to lock) and resync the power windows and sunroof (open then close each one and hold the switch closed for 10 seconds).

--

- RODNEY
rudeney is offline  
#5 (permalink) Old 04-26-2010, 07:51 PM
BenzWorld Newbie
 
Date registered: May 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hi rudeney,

First off, thanks for all the replies. Regarding the battery keys, yes I checked and REPLACED them.

I think you might be onto something with the car and keys getting out of sync, the car is now at the dealership so we'll see how it goes. I will keep you guys up to date.
asicman is offline  
#6 (permalink) Old 03-28-2011, 08:15 AM
BenzWorld Newbie
 
Date registered: Mar 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by asicman View Post
Hi rudeney,

First off, thanks for all the replies. Regarding the battery keys, yes I checked and REPLACED them.

I think you might be onto something with the car and keys getting out of sync, the car is now at the dealership so we'll see how it goes. I will keep you guys up to date.
What did the dealer come up with?
Jpalmer1174 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Smart Key door unlocking problem cavallino47 W215 CL Class 1 07-14-2010 10:45 AM
Smart Key Problem asicman W203 C32 AMG, C55 AMG 0 04-24-2010 09:59 AM
smart key problem dacollector W211 E-Class 9 07-21-2006 12:43 AM
Smart Key Problem. justinwrock W211 E-Class 0 07-06-2006 04:03 PM
Problem with smart key ops nizar W202 C-Class 1 06-29-2005 09:43 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome