ESP Faulty- Electronics, visit Workshop - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-25-2010, 11:58 PM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 5
ESP Faulty- Electronics, visit Workshop

My C240 Auto, cuts out in heavy traffic and the display shows ESP Faulty, something about electronics - visit workshop. I then stop, switch-off the vehicle and the start, starts immediately and works fine unless I still drive bumper to bumper and then does the same. Switching the ESP off in such traffic does not help as the error re-appears and vehicle loses all its power .

Reading the site and all the ESP problems that do occur, I would like some comments before taking the vehicle to a local agent in South Africa - all comments and suggestions welcome
Tisch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-26-2010, 01:41 AM   #2 (permalink)
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: C200 Kompressor M111 2.0L Avantgarde Year 2002
Location: Thailand
Posts: 283
May be your car need to reset the steering system.

How to...I can't remember, please other member for instructions.

Please check your battery too, and it's connection. I think bad battery may cause this to happen.
__________________
W203 C200K M111 2002
Denso Iridium IK20
Ground wires SARD
DangTH is offline   Reply With Quote
Old 02-26-2010, 03:14 AM   #3 (permalink)
BenzWorld Member
 
HKirov's Avatar
 
Date registered: Apr 2008
Vehicle: 2002 C230 Kompressor Coupe
Location: Markham, Canada
Posts: 178
Quote:
Originally Posted by DangTH View Post
May be your car need to reset the steering system.

How to...I can't remember, please other member for instructions.

Please check your battery too, and it's connection. I think bad battery may cause this to happen.

To reset it you start the car do full left then full right, do it twice or three times , turn of the car then start. This is how to reset but if it shows you need alignment for sure. And the cut of I have no idea are you shur you aren't tuching the car infront , if not it has nothing to do with your ESP.
__________________
MBWorld

For Sale : OEM Sport Suspention prod 06/2009 less than 2000 mi on it with Teen Springs, Merceeds Auto Radio CD Changer Control, and more.
HKirov is offline   Reply With Quote
Old 02-26-2010, 09:20 PM   #4 (permalink)
BenzWorld Member
 
Date registered: May 2009
Posts: 134
FYI, I'm having a nearly identical problem with my 05 SL500. ESP error followed by limp mode; resets when I turn the car on/off. In my case, it appears when I stomp the throttle hard. I read somewhere (can't recall where) that a faulty throttle position sensor may be to blame. Does your problem occur when you're accelerating (hard) in stop and go?
diablo2112 is offline   Reply With Quote
Old 02-28-2010, 10:23 PM   #5 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 5
Hi diablo2112, Yes this problem does occur when I accelerate during stop - go but not even hard acceleraion.

Thanks for all the comments and welcomes in the newby thread. ?

Planning to take the vehicle to the agent and will give feedback as to the problem and fixes - hopefully it will not run into mega $$$ to get it sorted
Tisch is offline   Reply With Quote
Old 02-28-2010, 11:37 PM   #6 (permalink)
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Shouldn't get too expensive unless oil has made it's way to the TCU unit... Many different things can cause ESP malfunction. Mine was related to bad alignment as HKirov mentioned, but did not have problems with vehicle going into Limp mode. Wheel speed sensor is a common cause as the sensor is easy to damage while messing with the wheels.
__________________

2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline   Reply With Quote
Old 03-03-2010, 08:23 AM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 5
Replaced Air Mass Sensor - seems to have fixed the problem

Thanks for all the comments
Tisch is offline   Reply With Quote
Old 03-03-2010, 09:19 PM   #8 (permalink)
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
First I've heard of MAS causing ESP malfunction... Very strange.
2002c230 is offline   Reply With Quote
Old 03-03-2010, 11:28 PM   #9 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 5
Running fine this morning in heavy traffic - no sudden loss of power or ESP warning

Will let you know if problem re-occurs
Tisch is offline   Reply With Quote
Old 02-04-2012, 09:05 AM   #10 (permalink)
BenzWorld Newbie
 
Date registered: Oct 2011
Posts: 1
Elec stable prog esp

read threads on this problem just to let u all know disconect battery 1st and then reconnect to see if this works worked for me just make sure you connect terminals tightly again saves a lot and easy to try
kd27 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
display faulty visit workshop????? czekitomi W211 E-Class 18 12-01-2012 05:50 AM
ESP visit workshop! doctor J W203 C-Class 10 06-05-2009 08:58 AM
esp visit workshop bas visit workshop icwater W220 S-Class 2 05-18-2009 02:19 PM
ESP Visit workshop garvard W203 C-Class 2 11-12-2007 04:22 PM
ESP - Visit Workshop Nosmo King General Mercedes-Benz 2 11-23-2006 10:51 PM


All times are GMT -7. The time now is 01:31 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.