Fuel gauge not working - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-21-2009, 08:44 AM
BenzWorld Newbie
 
Date registered: May 2009
Vehicle: 2005 C230 Kompressor
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Fuel gauge not working

I have a 2005 C230 Kompressor, this morning I put gas in my car, the guage went up to halfway, then about 10 minutes later as I was driving on the freeway the needle went all the way down only the light indicator did not come on? When I stopped and restarted the car the needle would start to go up and then drop down again.

I know someone else had this problem and theirs starting working again however I would like to know if it is a fuse or something else and what it may cost for me to get it fixed.
crode22 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-21-2009, 12:51 PM
BenzWorld Elite
 
Date registered: May 2007
Vehicle: 2004 C230 Kompressor Sport Coupe
Location: Olympia, WA
Posts: 1,903
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A bouncing needle is probably the sensor. It's just a wiper inside the tank and can go bad. The part shouldn't be expensive but I believe you need a special tool (spanner) to get to it.
zeet is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome