Windshield wiper stuck - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-18-2009, 03:37 PM   #1 (permalink)
BenzWorld Junior Member
 
lon801's Avatar
 
Date registered: Jan 2009
Vehicle: 2003 c230 komp.
Location: clearfield utah
Posts: 7
Exclamation Windshield wiper stuck

hey everyone....i got another problem with the c230. I was just curious if you guys could help me out with ANY info about the windshield wipers being stuck half way. I called the dealer and they said its probably the motor and could cost about 600-800 to fix it and i cant afford that .. Thanks.
lon801 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-18-2009, 04:51 PM   #2 (permalink)
BenzWorld Elite
 
Buellwinkle's Avatar
 
Date registered: Aug 2002
Vehicle: C230K Sport Sedan
Location: The O.C.
Posts: 5,368
It's not cheap to own an MB, the wiper motor runs $276 and wiper transmission is $94, heck, the wiper arms are a fortune at $180 for the pair and that's list price, most dealers jack that up 25% or more. You can go on parts.com and save about 25-30% if you do the work yourself. Can't tell you what's wrong from your post, you have to take it apart and see what's broken. You can check voltages at the motor to see if it's getting juice.You can see if the motor is trying to spin but the transmission is jambed. I would say that mechanical parts are more likely to fail than electrical parts, so I would guess the transmission is bad, on the otherhand, it could have taken the motor out trying to fight a bad transmission. So I can see why the dealer said $600-800, sounds about right, is it fair, hell no but they aint selling cars now, they need the money.

When you say they are stuck half way, are you saying they work but when you turn them off they stop half way, or are you saying it's all bad and they just happen to stop half way when they died completely? Did it make any unsually noises before it died? Did you check the fuses?

Get a used wiper motor and transmission from a salavage yard in So Cal, it never rains here.
__________________
2004.5 C230K - Pewter/Charcoal - www.Buellwinkle.com



http://www.mylavista.com
Buellwinkle is offline   Reply With Quote
Old 02-18-2009, 06:15 PM   #3 (permalink)
BenzWorld Extremist
 
Eesjunin's Avatar
 
Date registered: Apr 2007
Vehicle: 2002 Mercedes C320
Location: Boston, MA
Posts: 1,021
me too...except they would stop all the way up...but in about a month they have moved down a third...so start/stop location is right smack down the view line
__________________


...pRoject in pRogreSS...

WTB: AMG skirts


Helpful links:
W203 Seat module fix http://www.benzworld.org/forums/w203-c-class/1403233-diy-how-fix-your-power-seat.html

Mechanic search: http://www.cartalk.com/content/mechx/find.html
HID kits: http://www.tspny.com/shop
Eesjunin is offline   Reply With Quote
Old 02-19-2009, 07:47 AM   #4 (permalink)
BenzWorld Member
 
BeavenX5's Avatar
 
Date registered: Jan 2007
Vehicle: 2006 audi S4 Cabriolet
Location: Montreal, Canada
Posts: 98
I had a similar problem with my Volvo. It was the pivot where the wiper arm is attached to the transmission assembly that had some corrosion. Because of the corrosion inside the pivot, the arms had too much resistance and the transmission was not stoping at the right spot. The wipers were also moving slower than usual.
To fix this, I removed both arms, sprayed some cleaner and then some lube inside the pivot (as much as possible) and made the wiper run all this time. It fixed the problem. After this, I lubed this pivot every 6 months. The problem never re-appeared (kept the car 2 years after this).
Your problem might not be the same but it is worth looking into this possibility. Cheap repair
Good luck.
__________________
2004 C240 - Sold October 2009
18X8.5 Brabus Monobloc S Replicas Wheels
Marangoni Mythos 225/40ZR18 Tires
Remus custom muffler for W203
Becker Audio 10 OEM radio from a German C-Class
Mtec HID 4500K Headlamps
CL style front grill
BeavenX5 is offline   Reply With Quote
Old 02-19-2009, 09:48 AM   #5 (permalink)
BenzWorld Extremist
 
Eesjunin's Avatar
 
Date registered: Apr 2007
Vehicle: 2002 Mercedes C320
Location: Boston, MA
Posts: 1,021
it does make some sense...since when it approaches the "new" start/stop position there is a slight jurk and hesitation...hmm will have to dig into that this weekend- weather permitted...Thanks!
Eesjunin is offline   Reply With Quote
Old 02-20-2009, 06:08 AM   #6 (permalink)
BenzWorld Member
 
BeavenX5's Avatar
 
Date registered: Jan 2007
Vehicle: 2006 audi S4 Cabriolet
Location: Montreal, Canada
Posts: 98
I forgot to mention it is important to make a small mark on the pivot AND on the arm to mark the original position of the arm before removing them. If you don't mark it, you may have a tough time reinstalling the arm in the exact same position, specially if they don't come back where they should all the time.
BeavenX5 is offline   Reply With Quote
Old 02-20-2009, 07:15 AM   #7 (permalink)
BenzWorld Junior Member
 
lon801's Avatar
 
Date registered: Jan 2009
Vehicle: 2003 c230 komp.
Location: clearfield utah
Posts: 7
My wipers still work..when i turn them off though they stop halfway on windshield..and i have checked fuses and they are all good..and i havent heard any noise..i tried to check out motor and transmission but i cant get under that black cover that goes all the way across the lower windshield..any suggestions???? thanks
__________________
2003 C230 Kompressor and drivin nothin lessor
lon801 is offline   Reply With Quote
Old 04-07-2009, 09:40 AM   #8 (permalink)
BenzWorld Extremist
 
Eesjunin's Avatar
 
Date registered: Apr 2007
Vehicle: 2002 Mercedes C320
Location: Boston, MA
Posts: 1,021
Update...
they are back in the pocket position...
So almost 2 months?
Eesjunin is offline   Reply With Quote
Old 10-31-2009, 10:54 AM   #9 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2008
Posts: 21
I corrected a windshield problem on a 2000 C230. To start, let me explain the problem. The windshield would go halfway across the windshield and start to slow down. It didn't completely stop but there were brief delays in it going across the windshield. Now we will talk about the solution. Number one...Don't bring it directly to a dealership right away because it may not be a problem with the motor. As listed in other replies, the cost is high to fix a motor and/or windshield. Here is what I did. Get car wax and spread it across the area holding the wiper from moving. This will allow the wiper to move more easily across the windshield. In addition, cover the wiper with the same wax so that the wiper itself is lubricated to move across the glass as well. Make sure the wax is on both the wiper and windshield solid. The work isn't over. Spray the motor holding the arm of the windshield wiper with WD-40 or a lubricant. Do this several times in all of the areas on the bracket. You do not have to remover the cover from the motor and it is best to spray the bracket by lifting the hood. Now start the delay wipers and continue to spray the moving wiper bracket as the wiper itself is moving. It worked for me and saved a lot of money.
rdf63 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Help with windshield wiper, its stuck!! RDM3 W201 190 Class 2 05-10-2009 09:45 PM
My wiper is stuck up Guest (MBNZ) W124 E,CE,D,TD Class 4 01-18-2008 05:24 PM
Windshield Wiper silverstreak W208 CLK Class 1 02-27-2007 05:18 PM
Wiper Stuck hamada128 W201 190 Class 11 02-18-2007 02:27 PM
Windshield Wiper ministerman W201 190 Class 1 12-03-2004 09:49 PM


All times are GMT -7. The time now is 05:48 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.