the P0410 code :( - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-17-2009, 09:06 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 4
the P0410 code :(

Im assuming i need to get my check valve replaced? anyone know a goodsite? much appreciated! 2002 C230 Kompressor!
ivarzzz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-17-2009, 10:08 PM   #2 (permalink)
Lifetime Premium Member
 
Date registered: Dec 2004
Location: Dallas, TX
Posts: 3,522
Lifetime Premium Member
air injection system. You should hear the air injection pump run in the morning. It sounds like a hair dryer that cycles on and off. I had that error for months. When I got round to looking at it, I found a broken vacuum line that goes into the valve which was broken. Reconnected it and the light went out a couple of days later.
__________________
With best regards

Al

Check out the W114, W115 /8 enthusiast forum http://www.stroke8.org

My 280SL restoration
alabbasi is offline   Reply With Quote
Old 02-17-2009, 11:17 PM   #3 (permalink)
BenzWorld Extremist
 
C230 Sport Coup's Avatar
 
Date registered: Feb 2007
Vehicle: 2002 C230 Sport Coup and 2006 ML350
Location: Norcal Coast
Posts: 970
Quote:
Originally Posted by alabbasi View Post
air injection system. You should hear the air injection pump run in the morning. It sounds like a hair dryer that cycles on and off. I had that error for months. When I got round to looking at it, I found a broken vacuum line that goes into the valve which was broken. Reconnected it and the light went out a couple of days later.
I keep getting a 420 error...it's been suggested my car want to get stoned.
I just clear it...comes back every once in a while under WOT.
__________________
2002 C7 Evolution Orion Blue 2.3L C230 Coupe
Auto-Pano-Oyster Leather-Audio 10
AMG Front bar 22mm-17" Wheels- C32 Brakes- H&R 19mm rear sway
ASP Pulley-Supercharger Muffler Deleted- NGK Copper BKR7E
Supersprint Header-Magnaflow Cat- AR20 Resonator- Remus Muffler
MAF Screen Delete- TB Screen delete
TEIN SS Coilovers -
Clear sides- 2005 tails, Blinkers & Grill- Tinted Windows
Bi-Xenons-Clear Fogs- Clear Side/Stealth Bulbs
Renntech Spoiler


C230 Sport Coup is offline   Reply With Quote
Old 02-18-2009, 08:49 AM   #4 (permalink)
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 358
Umm the kompressor does not have an air injection pump. This engine uses the kompressor as the injection pump. Usually when I have this code it is caused by the secondary air injection valve. This is located on the passenger side of the engine just above the kompressor. It should have two large tubes and a small vacuum line attached to it. If you have a hand held vacuum pump, hook up to the valve and see if it holds a vacuum. If it does not replaced the valve and vacuum line going to the solenoid on the front of the engine. Good luck
kyle21nluvnit is offline   Reply With Quote
Old 02-18-2009, 10:07 AM   #5 (permalink)
BenzWorld Extremist
 
Eesjunin's Avatar
 
Date registered: Apr 2007
Vehicle: 2002 Mercedes C320
Location: Boston, MA
Posts: 1,021
0410=Injector Relay
__________________


...pRoject in pRogreSS...

WTB: AMG skirts


Helpful links:
W203 Seat module fix http://www.benzworld.org/forums/w203-c-class/1403233-diy-how-fix-your-power-seat.html

Mechanic search: http://www.cartalk.com/content/mechx/find.html
HID kits: http://www.tspny.com/shop
Eesjunin is offline   Reply With Quote
Old 02-18-2009, 01:01 PM   #6 (permalink)
BenzWorld Member
 
Date registered: Oct 2008
Posts: 57
Ok, here is the run down.

This code (P0410) Secondary air injection, is 99% of the time a bad check valve. The valve is located between the engine block and the firewall. You have to look behind the block to find it. It is connected to a tandem valve, which is just above the check valve and can be seen easily once you remove the top rear engine cover. Look at the vacuum emissions routing sticker under the hood for reference.

Anyway, replace the check valve. And yeah, you can only get it from the dealer.
Part # 002-140-68-60
__________________
2002 C230 Kompressor
Evo Pckg.
solobinoy2k is offline   Reply With Quote
Old 02-20-2009, 03:41 PM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 4
Hey guys thanks for all your help! i ended up getting a new check vavle, 80 bucks canadian! and replaced it myself..im not gunna lie it was a pain specially if you dont have the right tools, but managed to get a 27mm crow socket and it worked out! seems to be running way better now! just one more question..does it take a couple days for the check engine light be turn off??" thanks again everyone!
ivarzzz is offline   Reply With Quote
Old 02-20-2009, 06:23 PM   #8 (permalink)
BenzWorld Elite
 
Date registered: May 2007
Vehicle: 2004 C230 Kompressor Sport Coupe
Location: Olympia, WA
Posts: 1,903
Some codes take 5 successful starts to clear; some take longer. You should pull codes again in case there is another code stored or pending.
zeet is offline   Reply With Quote
Old 04-06-2009, 01:57 PM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Apr 2009
Vehicle: 2002 C230 Kompressor
Location: Wylie, TX
Posts: 2
I am getting the P0410 code and the car seems to have lost power when this occurs on a 2002 C230 Kompressor. Sometimes the problem goes away. Can anyone narrow down possible causes?
Patrix is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Still Throwing P0410 Code NOLA430 W210 E-Class 11 02-24-2009 10:58 PM
CEL and code P0410 Shore R170 SLK Class 19 11-21-2008 12:43 PM
P0410 Code solobinoy2k W203 C-Class 1 10-08-2008 12:42 AM
code p0410 rbrandano W220 S-Class 1 08-31-2007 08:49 PM
Code P0410 and Hesitation agunjal W220 S-Class 0 02-25-2007 08:52 AM


All times are GMT -7. The time now is 10:19 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.