Starting problems - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-23-2009, 09:29 AM
BenzWorld Junior Member
 
Date registered: Dec 2007
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool Starting problems

Hi Everyone!

I have a 2001 c320 it has just left me for the first mine stranded, I tried to start the car after going into the store and it wouldnt start, I came back to the car in the moring and it started right up! I thought it might be the fuel pump however you can hear it prime, it runs fine when it starts. any advice would be great!

Also I have a missfire I thought it could be the ignition coils, I know there is a way to test them for restance with a multimeter but I dont know how??

Thanks
poppell1 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-23-2009, 04:03 PM
BenzWorld Member
 
Date registered: Oct 2008
Location: Baltimore
Posts: 239
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to NAPTOWNBENZ
Hi,
Intermittent no starts are hard to diagnose sometimes without a code or battery check etc. I know alot of people recommend a crank position sensor to fix alot of problems. I would say this might be something to look at. Reason being your car didn't start when the engine was "hot" but it started when it was "cold"
Shawn
Mercedes-Benz of Annapolis
www.getmercedesparts.com
NAPTOWNBENZ is offline  
#3 (permalink) Old 01-23-2009, 05:26 PM
BenzWorld Elite
 
Date registered: May 2007
Vehicle: 2004 C230 Kompressor Sport Coupe
Location: Olympia, WA
Posts: 1,903
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Misfire+occasional non start does say crank sensor, if you have to guess. Is it a random misfire code? Search around, you'll see that's often associated with the CPS. I had a CPS go on a VW and it did exactly that, one minute it was working, then you stop and it won't restart, come back the next day and it starts right up. I know it's a VW not a MB but they both use Bosch ECUs and sensors, very similar behavior.
zeet is offline  
#4 (permalink) Old 01-27-2009, 12:36 PM
BenzWorld Junior Member
 
Date registered: Dec 2007
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Starting problems

HI! Hi everyone, yet another problem I was driving the car today and it stalled in traffic, some of you had said you thought it could be the CPS so I have ordered one, but today I noticed that when it wouldnt start I didnt hear the fuel pump prime, I exausted the battery and had to get a jump this time I heard the fuel pump prime and the car started, when I got home I removed the back seat and checked the connections to the fuel pump, all where fine. CPS or fuel pump or both? I also noticed the pump is behind the drivers seat (wired) and the sending unit is behind the passangers seat (not wired) the dealer says there are two pumps??? but the other is not wired at least not visable?


can anyone help?
poppell1 is offline  
#5 (permalink) Old 01-27-2009, 01:14 PM
BenzWorld Elite
 
Date registered: May 2007
Vehicle: 2004 C230 Kompressor Sport Coupe
Location: Olympia, WA
Posts: 1,903
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You might have multiple problems going on. Since you already have the CPS on the way, and the misfire+occasional non start really says CPS, start there. If you then still have fuel pump problems you know where to go next.
zeet is offline  
#6 (permalink) Old 01-27-2009, 01:46 PM
BenzWorld Junior Member
 
Date registered: Dec 2007
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Do you know the location of the CPS? I thought it is at the rear of the motor behind the MAS is this correct? if not do you know the best way to get to it with out having to tear apart the top end?

Thanks
poppell1 is offline  
#7 (permalink) Old 01-29-2009, 12:32 PM
BenzWorld Junior Member
 
Date registered: Jan 2009
Vehicle: R320 CDI
Location: England
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
As you look at the engine, right hand side,just behind the head near where the bell housing joins the block!
coleman GB is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Starting Problems DirtyJ23 W201 190 Class 10 10-20-2008 02:10 AM
Starting Problems marcmayer W210 E-Class 4 05-15-2008 06:34 PM
Stored 1993 S420 has fuel problems-Gives sudden starting problems-solution needed heartmd W140 S-Class 15 12-09-2007 02:45 PM
Problems starting Terabyte W123 E,CE,D,CD,TD,TE Class 1 10-22-2004 05:23 PM
anyone have starting problems? My car died twice today after starting... cgeorge430 W163 M-Class 10 08-03-2002 11:57 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome