Parking brake problem - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-12-2008, 06:41 AM
BenzWorld Member
 
azatrum's Avatar
 
Date registered: Dec 2003
Vehicle: 2001 C-240
Location: Toronto Canada.
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Parking brake problem

Hi Folks. I am sorry if this topic has been discussed before, i searched through the form but could not find alot of info. Anyways yesterday the parking brake on my car seemed ok when i released it in order to get back home from work. On applying the brake on my driveway, the pedal went down freely without any resistance. I could still hear the clicking sound but it dosent seem to be engaging. The parking brake sign works ok, only the brake dosent work anymore. I will appreciate if anyone could provide any info on what could be the problem and how big it could be. Thanx in advance.
azatrum is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-12-2008, 08:25 AM
BenzWorld Elite
 
2002c230's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C32 AMG
Location: New Mexico, USA
Posts: 1,771
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A couple days ago my girlfriend engaged the emergency brake after parking on my inclined driveway, and in neutral the vehicle was rolling backwords. Are you talking about the parking brake, or the emergency brake? Anyways, I checked it, and it definitely wasn't working. After that I put the emergency brake on, and throttled a little in drive, and the brake was working again. No problems since. You might want to try that, and see if it works.


2002 C32 AMG Sedan [111,000 Miles]
Clear Side Markers | CL Style Grille | Flat Emblem | CF Front Lip Spoiler | CF Rear Diffuser | CF Trunk Spoiler
K&N Air Filters | NGK IX (2 Step) | KV-85 | LET 185MM & ECU | TVT Thermostat | PSK Belt Wrap | CM30
DIY Intercooler Isolation | 26x7x2 FB H/E | Intercooler Reservoir | Battery Relocation | Lorinser Sides
2002c230 is offline  
#3 (permalink) Old 02-12-2008, 11:09 AM
BenzWorld Elite
 
BF_JC230's Avatar
 
Date registered: Oct 2003
Vehicle: 1980 w123 230 "Sport", 2005 w203 230 Sport
Location: Outside of Buffalo,NY
Posts: 2,172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to BF_JC230
Parking brake AND emergency brake...I thought these cars only had a left foot (For left hand drive) foot activated parking brake...MMM...I read that the ratchet mechanism in the kick panel can brake causing the adjuster not to be set and thus no rear shoes to grab the rear drums...

I would start there...In the kick panel,
Jake
BF_JC230 is offline  
#4 (permalink) Old 02-12-2008, 06:34 PM
BenzWorld Member
 
azatrum's Avatar
 
Date registered: Dec 2003
Vehicle: 2001 C-240
Location: Toronto Canada.
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Parking brake problem

Thank you 2002c230 and BF_JC230 for the info. To be honest, i dont even know what an emergency brake is. I am talking about the left foot (For left hand drive) foot activated parking brake. The one that makes clicking sound on applying. Yup i tried a lot of times since then, it definitely is not working anymore. Before, it used to have resistance in it while applying and used to get released with a sound. Now there is no sound and resistance. So if it really is the kick panel, is that an expensive fix? Could it be just the cable? One thing i want to add here is that its extremely cold here in Toronto, could that be the cause of something to break? Thanx in advance.
azatrum is offline  
#5 (permalink) Old 02-13-2008, 05:10 AM
BenzWorld Elite
 
BF_JC230's Avatar
 
Date registered: Oct 2003
Vehicle: 1980 w123 230 "Sport", 2005 w203 230 Sport
Location: Outside of Buffalo,NY
Posts: 2,172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to BF_JC230
Yeah it is has been cold down here in the south towns of Buffalo as well. I read a while ago about someone with the same problem. Turned out it was the ratcheting locker for the parking brake which is connected to the pedal and inside the driver kick panel. I am not sure about fixing - I think it is a replace faulty item...

Good luck!
Jake

Last edited by BF_JC230; 02-13-2008 at 05:17 AM.
BF_JC230 is offline  
#6 (permalink) Old 02-13-2008, 05:16 AM
BenzWorld Elite
 
BF_JC230's Avatar
 
Date registered: Oct 2003
Vehicle: 1980 w123 230 "Sport", 2005 w203 230 Sport
Location: Outside of Buffalo,NY
Posts: 2,172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to BF_JC230
Here are some fast images...
Jake
Attached Thumbnails
Click image for larger version

Name:	w203_Parking_Brake_1.jpg
Views:	2335
Size:	85.0 KB
ID:	162396   Click image for larger version

Name:	w203_Parking_Brake_2.jpg
Views:	692
Size:	86.8 KB
ID:	162397  
BF_JC230 is offline  
#7 (permalink) Old 02-13-2008, 05:20 AM
BenzWorld Elite
 
BF_JC230's Avatar
 
Date registered: Oct 2003
Vehicle: 1980 w123 230 "Sport", 2005 w203 230 Sport
Location: Outside of Buffalo,NY
Posts: 2,172
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to BF_JC230
If that is not it...You may want to check under the rear seat at the actual parking brake split...and adjust it - When was the last time it was adjusted? I think it is a job to do with every service, or once a year...

Jake
Attached Thumbnails
Click image for larger version

Name:	Parking_3.jpg
Views:	1077
Size:	76.1 KB
ID:	162398   Click image for larger version

Name:	Parking_5.jpg
Views:	1443
Size:	99.0 KB
ID:	162399  
BF_JC230 is offline  
#8 (permalink) Old 02-13-2008, 09:34 AM
BenzWorld Extremist
 
Date registered: Jan 2007
Vehicle: 2005 C230K Sport Coupe 6-speed!
Location: South Porcupine, Ontario, Canada
Posts: 1,068
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Seriously, though, there really isn't a such thing as an emergency brake. It is a parking brake. The only reason people called it an emergency brake is the light in the instrument cluster is usually a circle with an exclamation mark (!), which is mostly meant to signal a faulty brake system. So people automatically associated the light as "emergency".
Whosdis is offline  
#9 (permalink) Old 02-13-2008, 09:39 AM
BenzWorld Elite
 
'91 300CE's Avatar
 
Date registered: Jul 2006
Vehicle: 2002 ML320
Location: Portland Area
Posts: 1,951
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Whosdis View Post
Seriously, though, there really isn't a such thing as an emergency brake. It is a parking brake. The only reason people called it an emergency brake is the light in the instrument cluster is usually a circle with an exclamation mark (!), which is mostly meant to signal a faulty brake system. So people automatically associated the light as "emergency".
Handbrakes are considered double duty... since they are mechanical... in case you lose your brake pressure you can gently pull up on these handbrakes and stop the car, hence "emergency brake".

2005 BMW 325Ci - Sport, Premium and Cold Weather Pkgs
2000 C230K -- Desert Silver Metallic -- 113,000 miles -- Sold
2002 ML320 -- Alabaster White
1991 300CE -- Blue Black Metallic -- 129,000 miles -- Sold
1981 300SD -- Classic White -- 190,000 miles -- Sold
1977 240D -- Over 300k miles (Wrecked) -- My 1st car
2006 Porsche Cayenne S - Dad's
2004 Porsche 911 Turbo S

||||||

'91 300CE is offline  
#10 (permalink) Old 02-13-2008, 07:25 PM
BenzWorld Member
 
azatrum's Avatar
 
Date registered: Dec 2003
Vehicle: 2001 C-240
Location: Toronto Canada.
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you BF_JC230 for all the information. I will take the car to the mechanic to have it checked this weekend. I hope its a simple fix.
azatrum is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
A parking brake, a parking brake, my kingdom for a parking brake!!! Capt.wrongway Unimog 10 10-04-2006 12:30 PM
parking brake light problem!!!!!!!!!!!! amgstyle R170 SLK Class 2 09-05-2006 01:12 AM
Parking Brake Problem - '96 w202 c200 ronso W202 C-Class 1 05-24-2006 10:00 AM
Parking Brake Problem URGENT.. Merc600sec W140 S-Class 3 04-07-2006 12:02 AM
Problem Fitting Rear Brake Disc Rotors over Parking Brake Shoes? Guest (MBNZ) W124 E,CE,D,TD Class 7 04-03-2002 08:22 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome