Help, Help, C320 Brake Problem, ESP, ABS, BAS!!!! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-16-2007, 09:56 PM
BenzWorld Newbie
 
Date registered: Dec 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Help, Help, C320 Brake Problem, ESP, ABS, BAS!!!!

I have a 2001 Mercedes C320 and it recently started flashing the following error codes on the dash; ESP, BAS, ABS and then it said Brake Lining Wear Visit Workshop. The computer also retards the engine and the car only goes about 30 miles per hour when these error codes are flashing. This probelm is intermittent and sometimes I can drive 30 to 40 miles before it does it. Other times the error codes flash as soon as I start the car. I had the rear brakes replaced about six months ago and I thought that the front brakes may be causing the problem, therefore I just had the front pads and rotors replaced. The shop also replaced the front brake sensors as well. I then thought it may be the brake switch so I bought one from Walter's Mercedes and just replaced that too. The computer still flashes the ESP, BAS, ABS, Brake Lining Wear Visit Workshop Error Codes. Does anyone know what else the problem could be??? I am planning on taking the car into a local Mecedes Benz repair shop in the next few days, but would like to fix it myself if possible. We have a new baby and buying the formula food and diapers is killing me so I'm trying to save as much money as possible. Ten Thousand Thank You's!!!
no bad days is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-21-2007, 08:40 AM
BenzWorld Newbie
 
Date registered: Dec 2007
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Can anyone help give me some advice in this area??? If not, does anyone know a good Mercedes Benz mechanic in the Upland, Ontario California Area???
no bad days is offline  
#3 (permalink) Old 12-21-2007, 03:38 PM
BenzWorld Junior Member
 
Date registered: Apr 2006
Vehicle: 2002 c320 wagon
Location: Oyster Bay, LI
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Angry Update

After dealing with the draining battery issue, I thought I fixed it with unplugging the potentially defective Power Seat Modules. That led to the next problem of brake lights malfunctioning, abs msg, brake lining msg, visit workshop etc. The other problem were phantom headlights. With the car turned off the headlight would suddenly go on, not both but the left headlight only. The only way I could turn off the headlight was to disconnect the battery.

I brought the car in for service and they discovered I had a defective SAM. After spending $830 and no car for 3 days, I got the car back and it seems fine again.

I am not happy about having to pay for expensive repairs on a 2002 Mercedes with 43000 miles on the odometer. Not a very good experience.
PWGUNNY is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
BAS, ESP, ABS problem.....DIY repair bbearden26 W208 CLK Class 13 06-17-2014 01:26 PM
ABS/BAS-ESP lights on - Brake lights don't work niwred W210 E-Class 12 11-27-2013 04:53 AM
Thrill Kill, got a question about the ABS/ESP/BAS problem LorinserCLK55DTM W208 CLK Class 6 02-07-2006 04:02 PM
ABS/BAS-ESP lights on and no brake lights niwred W210 E-Class 3 11-28-2004 05:48 AM
ESP/BAS & ABS problem chopper W168 A-Class 1 06-14-2004 08:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome