car won't change gears - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 10-31-2006, 05:58 AM
BenzWorld Newbie
 
Date registered: Oct 2006
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
car won't change gears

I have 2002 c240 (automatic) and recently its been having problems changing gears. when driving the rpm will go high and the gears wont change. restarting the car takes care of the problem but i want to know whats wrong with it. it only happens in morning for the past 3 days.
Please help....i will be really appreciated.
dans_benz is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-25-2007, 05:40 AM
BenzWorld Newbie
 
Date registered: Apr 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Red face err...mine too!

my car is doing exactly the same thing, so much it has totally stopped changing gears, even if you tip up or down! is it:

1.gearbox needs oil.
2.Electronic glitch
3.Gearbox is buggered

please oh please dont say three, i dont think i have the bucks to buy a new box!
yebo yes is offline  
#3 (permalink) Old 07-26-2007, 06:09 AM
JAA
BenzWorld Junior Member
 
Date registered: Mar 2006
Vehicle: 2002 C240
Location: Kentucky
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thumbs down Same Thing

I have a 2002 C240 that is doing exactly the same thing! It's got 75,000miles on it.

what the heck is going on?
JAA is offline  
#4 (permalink) Old 07-26-2007, 06:21 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,278
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
OK Guys have a diagnostic readout done first and not just the transmission, if an engine problem the computer could be in safe mode. So starting point is a readout of fault codes and go from there.
eric242340 is offline  
#5 (permalink) Old 07-26-2007, 06:24 AM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,278
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
ps It will be interesting to compare your fault codes
eric242340 is offline  
#6 (permalink) Old 07-31-2007, 11:26 PM
BenzWorld Newbie
 
Date registered: Apr 2006
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Cool here's my diagnosis

p2001 automatic transmission control unit faulty

that's what the readout says, but after reseting it, it works fine, maybe i must sell the merc before i run into more problems.

thanx for helping out.
yebo yes is offline  
#7 (permalink) Old 01-18-2008, 07:19 PM
BenzWorld Member
 
driver450190's Avatar
 
Date registered: Jun 2007
Vehicle: 2002 C240, 1978 450SEL, 1989 190E 2.6L, 1972 Road Runner
Location: Seattle
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey, what did we find out here???
driver450190 is offline  
#8 (permalink) Old 02-18-2010, 06:41 PM
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem with a MB C230 Kompressor 2000, just happened lately. It doesnt change gears. It stay in the same gear. Sometimes it blocks in P or N and dont change. Just after stoping the engine you can change the gears.
agasociados is offline  
#9 (permalink) Old 02-18-2010, 07:47 PM
BenzWorld Elite
 
silarrow's Avatar
 
Date registered: Oct 2009
Vehicle: 02 W203.86 W201-16v Nam.86 W201-16v Euro.93 W201-8v.Silver Arrow-02-SL500.02-Avalanche
Location: Portland-OR
Posts: 2,033
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Folks..check your battery amp due to low voltage capacity will not have enough juice for ECU control your auto trans shifting to any gear but the FIRST gear .You can start your engine, auto daytime running light looks OK but I'm sure there is ..some time it's time to change new Bat..
silarrow is offline  
#10 (permalink) Old 02-18-2010, 10:32 PM
BenzWorld Extremist
 
C230 Sport Coup's Avatar
 
Date registered: Feb 2007
Vehicle: 2002 C230 Sport Coup and 2006 ML350
Location: Norcal Coast
Posts: 971
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Might be tranny fluid in the TCU. Check installuniversity.com for info about leaking orings
causing fluid to wick up the harness to the TCU which is under the floor board on the passenger side.
The good news is it isn't completely dead yet, so you might still have a chance to clean it.

2002 C7 Evolution Orion Blue 2.3L C230 Coupe
Auto-Pano-Oyster Leather-Audio 10
AMG Front bar 22mm-17" Wheels- C32 Brakes- H&R 19mm rear sway
ASP Pulley-Supercharger Muffler Deleted- NGK Copper BKR7E
Supersprint Header-Magnaflow Cat- AR20 Resonator- Remus Muffler
MAF Screen Delete- TB Screen delete
TEIN SS Coilovers -
Clear sides- 2005 tails, Blinkers & Grill- Tinted Windows
Bi-Xenons-Clear Fogs- Clear Side/Stealth Bulbs
Renntech Spoiler


C230 Sport Coup is online now  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W203 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
All Gears move car forward jek9372 W201 190 Class 0 08-08-2006 07:56 AM
Need Help! 1997 s600 transmission doesn't change the gears sportster413805 W140 S-Class 8 06-15-2005 01:55 PM
Dreaming of high gears........now im wishing for any gears!!!! peter G-Class 5 05-14-2002 03:22 AM
what now, gears wont change when i want them to Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 4 03-22-2002 12:16 AM
On a manual tran what is the recommended rmp in which to change gears? VA_SALSA R170 SLK Class 2 10-25-2001 11:45 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome