Transmission doesn't shift gears - 1st gear working only and Reverse - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-27-2012, 10:55 AM
BenzWorld Junior Member
 
Date registered: Oct 2007
Vehicle: 1999 C43 AMG
Location: Boca Raton, FL
Posts: 21
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to mercedesc230
(Thread Starter)
Unhappy Transmission doesn't shift gears - 1st gear working only and Reverse

Hello Benz lovers!
My transmission doesn't shift gears anymore .
A couple days ago, I was making a right at a stop sign and I manual put into 4-3-2-1 (i was an idiot, i don't know what i was thinking - "to get more power" and launch fast, duh! )
A couple seconds later, I think, I noticed that would not shift.
Pull over, stop the car, try again nothing, i tried manual shifting-nothing, disconnect minus at the battery, wait 5 min, same. Would only work in reverse and Drive - in 1st gear.
A friend checked the codes for me:
P0715 - turbine input shaft speed sensor circuit
P0720 - shaft speed sensor circuit
I have a car for more than 5 years and I hate to see it gone.

A local shop specialized in transmissions for German cars said $1700 to fix it with 6 months warranty . I live in South Florida.
Car is a 1997 C230 with 233K miles (5 speed automatic).
Any advice is appreciated

Last edited by mercedesc230; 02-27-2012 at 11:30 AM.
mercedesc230 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-27-2012, 11:59 AM
BenzWorld Elite
 
rudedude's Avatar
 
Date registered: Jul 2005
Vehicle: ML320,C230, F250, Bayliner, Mountain Bike, Fleetwood Motorhome etc...
Location: San Bernardino Ca
Posts: 1,832
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
First you're not an idiot for down shifting your car. If you weren't supposed to do it there would only be a "D" position for drive and not 1234&D...

There seems to be a defect in the 1997-1998 transmissions. Mine did the something similar. It cost almost 3 grand to fix a few years ago. You need to evaluate the car and your attachement to the car and decide if it's worth it to you to fix. Personally if the car is in good condition I would get it fixed. Much better than a car payment. Also when you get it fixed make sure they are going to do all the updates that will fix the flaw and make it much more durable and responsive in the shifts...

True success is being the master of your own time.
rudedude is offline  
#3 (permalink) Old 02-27-2012, 01:58 PM
BenzWorld Junior Member
 
Date registered: Oct 2007
Vehicle: 1999 C43 AMG
Location: Boca Raton, FL
Posts: 21
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to mercedesc230
(Thread Starter)
Quote:
Originally Posted by rudedude View Post
Also when you get it fixed make sure they are going to do all the updates that will fix the flaw and make it much more durable and responsive in the shifts...
I found this thread in the W140 section:http://www.benzworld.org/forums/w140...r-contact.html

There, the op said:
Quote:
conductor plate-$170, 13 pin connector-$9, valve body spring-$3.52, tranny pan gasket/filter-$15. Also added 4qts of Mobil 1 synthetic ATF!


I am wondering if the parts are same for w202.
mercedesc230 is offline  
#4 (permalink) Old 02-27-2012, 05:14 PM
BenzWorld Elite
 
rudedude's Avatar
 
Date registered: Jul 2005
Vehicle: ML320,C230, F250, Bayliner, Mountain Bike, Fleetwood Motorhome etc...
Location: San Bernardino Ca
Posts: 1,832
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Could be the same transmission. My ML320 has the same one

True success is being the master of your own time.
rudedude is offline  
#5 (permalink) Old 03-01-2012, 04:39 PM
BenzWorld Junior Member
 
Date registered: Oct 2007
Vehicle: 1999 C43 AMG
Location: Boca Raton, FL
Posts: 21
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Yahoo to mercedesc230
(Thread Starter)
The parts are the same.

Could anyone tell me what transmission fluid to buy instead of the one at the dealership that cost $20/qt? I need to buy 8L , right ?
mercedesc230 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
No forward or reverse gear.......Engages gears fine........ Help! J4GG4 General Mercedes-Benz 1 05-08-2011 11:16 AM
Reverse gear doesn't shift aqirjazi W202 C36 AMG, C43 AMG 4 10-24-2009 06:16 AM
Reverse gear doesn't shift aqirjazi W202 C-Class 1 10-07-2009 03:43 AM
Transmission-CEL, gears wont shift jchumba W210 E-Class 23 10-27-2008 05:57 PM
Transmission - Reverse only, no FWD gears Benzo5 W126 S,SE,SEC,SEL,SD,SDL Class 2 10-17-2006 01:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome