98 C230 Center Vents not working...HELP! - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-05-2011, 07:29 PM
BenzWorld Junior Member
 
Date registered: Mar 2011
Vehicle: 1998 C230
Location: Troy, NY
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
98 C230 Center Vents not working...HELP!

So in my C230 it sounds like I am having a similar problem as others have had my problem however is little different in that even when the level is at max very little air flows out of the side vents and defrost vent and no air comes out of the center vents and the floor vents.

So I think I'm having a vacuum problem? I found one really good link in this forum but before I start dismantling the dash how can I be sure? Any and all help/advice is welcome.

Oh and do C230s have have vacuum pumps in the trunk too?

Thanks for any help!
DIYGal is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-05-2011, 08:49 PM
BenzWorld Elite
 
bmeister's Avatar
 
Date registered: Oct 2007
Vehicle: 1998 c230 153k
Location: Exit 98, New Jersey, U.S.
Posts: 1,349
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Yes, there is a vac pump in the trunk.

Wondering if your blower motor is working o.k.? speed settings and possible debris clogging air flow. If you have the digital CCU there is a flap/diagnostic test you can do.

It would not suprise me if you have one or more vacuum elements that have dried up. I know some of mine did a while back, not fun. Farmed that one out.

Would inpect for loose vacuum hoses first (at least the ones you can get to)
There is also a vacuum manifold/hose port underneath the center/passenger dash area you may want to inspect for loose hoses there too. B
bmeister is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Center Vents Aren't Working Desparye W123 E,CE,D,CD,TD,TE Class 14 07-20-2010 12:05 PM
center A/C vents not working tommyb2b W140 S-Class 3 01-15-2009 07:58 PM
center a/c vents not working greasy_benz W124 E,CE,D,TD Class 3 09-24-2007 10:11 AM
Center Air Vents not Working ftafever W202 C-Class 1 03-14-2007 01:00 PM
Center vents now working! MBeige W123 E,CE,D,CD,TD,TE Class 9 12-23-2005 01:44 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome