Reset ECU / Turn off ABS light - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-11-2010, 06:55 AM
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1996 C280
Location: Tri-Cities Area, TN
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Reset ECU / Turn off ABS light

I had my codes scanned yesterday by an indie because my ABS light is on. The code was C1101 which is the right front wheel sensor. I got home and cleaned the sensor and replaced, I left the battery unhooked overnight, and this morning as soon as I cranked it up, the ABS light came on immediately (just like it always does). The indie said the code was "hard faulted" (whatever that means).



Anyway, Is their anyway to reset the ECU? I've tried fuse #32 and the battery thing. Will I have to go back and have them turn off the light with their computer?



Thanks

1996 C280
wammer23 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-11-2010, 03:52 PM
BenzWorld Elite
 
bmeister's Avatar
 
Date registered: Oct 2007
Vehicle: 1998 c230 156k Clock spring is getting Crunchy especially in colder weather, jingle jingle
Location: Exit 98, New Jersey, U.S.
Posts: 1,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Ohm test

Quote:
Originally Posted by wammer23 View Post
I had my codes scanned yesterday by an indie because my ABS light is on. The code was C1101 which is the right front wheel sensor. I got home and cleaned the sensor and replaced, I left the battery unhooked overnight, and this morning as soon as I cranked it up, the ABS light came on immediately (just like it always does). The indie said the code was "hard faulted" (whatever that means).



Anyway, Is their anyway to reset the ECU? I've tried fuse #32 and the battery thing. Will I have to go back and have them turn off the light with their computer?



Thanks
Did you take the wire off and do an ohm test? Cleaning may not be the solution here. There are various posts on this issue, it might be overstretched and have little or no continuity. I would check that out before messing with the brain module. B
bmeister is offline  
#3 (permalink) Old 02-11-2010, 05:41 PM
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1996 C280
Location: Tri-Cities Area, TN
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by bmeister View Post
Did you take the wire off and do an ohm test? Cleaning may not be the solution here. There are various posts on this issue, it might be overstretched and have little or no continuity. I would check that out before messing with the brain module. B
I did an OHM test on the cable but I'm not sure about the results. There was continuity at the end (the magnet part) but not at the top (the pins). I ordered a new one today and will report back.

I'm worried that the car won't even recognize the new cable until the ECU is reset. The indie said it was a "hard fault". I guess I'll have to take it back to them and have them reset the light when I make the repair. I hope they'll do it for free since I've already shelled out $98 for the read. Shoulda just bought a Chinese multiplexor.

FWIW I'm also replacing the brake light switch as it was throwing a code as well.

Wish I new how to reset ECU!

1996 C280
wammer23 is offline  
#4 (permalink) Old 02-12-2010, 06:40 PM
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1996 C280
Location: Tri-Cities Area, TN
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
replaced wheel sensor today. I checked the new one an it does have continuity at the top of the cable where the two pins are. This confirms that the old one is bad because it doesn't have continuity.

My fear is realized because the ABS light is still on. I'll have to take it back in to have them turn it off.

It took me 30 minutes to do the whole job. They wanted to charge me $198 for labor (2 hours) and $97 for the part.

I ordered the part from PartsGeek for $62. They shipped super quick. I'll order from them again.

One last request. ANYBODY KNOW HOW TO RESET THE ABS LIGHT?

Thanks

1996 C280
wammer23 is offline  
#5 (permalink) Old 02-14-2010, 03:56 PM
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1996 C280
Location: Tri-Cities Area, TN
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hallelujah!

The ABS light went off for the first time since I've owned the car (1.5 months)!

When I initially replaced the wheel sensor I didn't take it for a drive I just started it up to see if light was still on which it was. After driving the car this morning for the first time since replacing sensor the light went off after about a tenth of a mile.

Turns out the computer doesn't need to be reset. It will turn itself off after being fixed!

Cheers!

1996 C280
wammer23 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
How do you reset ECU in S320 ?? BigBruce W140 S-Class 15 08-28-2008 04:01 PM
ECU reset acarter53 W210 E-Class 1 05-28-2007 08:43 PM
MAF and ECU Reset ehizon W208 CLK Class 2 09-13-2006 10:05 PM
ECU reset jtigr R170 SLK Class 4 06-05-2004 08:10 AM
ECU Reset jcwish R170 SLK Class 0 06-03-2004 06:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome