Heater problem please help!!!! - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-01-2010, 08:48 PM   #1 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1995 c280
Location: Pittsburgh, PA
Posts: 217
Heater problem please help!!!!

like it said in my title i'm having a problem with my heater fan or something the blows the air... when it first started i thought its a small problem after few days it didn't start at all i tried to open the hood and chech if its a fuese problem but all the fuses are right... i closed the hood with a hard push because i was mad i went into the car and the heat was on ...turned it off and tried to turn it back on didnt work again... i opened the door and closed it the heat worked again.... the next day didn't work with the funny way by closing the hood and door... i knew that theres a big problem after driving about 10 minutes the fan worked for about 15min and went off again ... now it worked for 10 min and went off if i turn beams on the red lights on the ( heat bottons) don't know what the real name is haha you can see that the red light is weak turn the beams off the red light is strong again.... Can anyone help me with this situation please ????? I already had alot of problems with this car and spent alot of $$$$$ so please any suggestions ???
__________________
1995 c280 118k Miles
mikhail.abraham is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-02-2010, 09:23 AM   #2 (permalink)
BenzWorld Member
 
Date registered: Jun 2009
Vehicle: 1999 C280 210k miles
Location: Connecticut
Posts: 200
My heater / AC blower worked intermittantly for about a year. Sometimes it was great, other times I had no air /heat for days. I used to bang the cover under the passenger side dash - the jolt would sometimes get the blower to rotate again. I'm guessing you have a similar problem and the jolt from the hood, doors, road, etc. get the blower to work for a few minutes at a time.

The problem can be in the blower motor or the resister pack. These are separate parts.

My problem was the blower motor. Bought replacement on Partsgeek for less than $200. Its an easy installation, search the forum for directions.

Been working great for the past 8 months.
gmascoli is offline   Reply With Quote
Old 02-07-2010, 10:15 AM   #3 (permalink)
BenzWorld Junior Member
 
Date registered: Jan 2010
Posts: 9
I'm having a similar problem that started two summers ago. It stated during the summer when the AC would not blow then later during the fall when I needed heat it wouldn't blow either. It seems to work on and off and I have noticed it may come on if the fan it set to 2 or below for some reason. When I really need it to run defrost it will not work. After reading the forums I am going to remove the fan and see if I can get it to work. I do recall a high winning noise on occasion like a leaf stuck in it before it stopped working.
jslaughter is offline   Reply With Quote
Old 02-07-2010, 12:53 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Jan 2010
Posts: 9
I just just taking a look at the fan motor ...

I had the dealer look at my fan during my B Service. They charged me over $200 just to diagnose this. The dealer stated they had to remove a lot of stuff to check the motor and it needed to be replaced for an additional $450. I passed and said I'll hold until I have some cash.

I have been on these forums today so I decided to take a look under the passenger side dash. Wow this is so easy! I found some leaves stuck in the motor so I removed them and cleaned the plastic cover that was very dirty. Removed the air filter element and found even more leaves.

Turned on my fan to setting five and guess what? Air shooting out my vents! The fan appears to be working perfect.

Why is the MB Dealer not servicing my car for such an easy fix? While I'm thrilled about this forum and my fan working I am also really displeased with the local MB dealer. I'm thinking ... did they really even service my car? I'm thinking the B service is a quick 19.95 oil change and nothing else.
jslaughter is offline   Reply With Quote
Old 02-07-2010, 07:21 PM   #5 (permalink)
BenzWorld Member
 
Date registered: Jun 2009
Vehicle: 1999 C280 210k miles
Location: Connecticut
Posts: 200
Like I said, this need not be a major cost to repair. You got lucky that is was leaves jamming your fan, but you gotta wonder how all that junk is getting in there. You might want to find another parking spot!

Mikhail appears top have another problem based on his description. Dont' know how he's making out with the new blower or resister pack.....
gmascoli is offline   Reply With Quote
Old 03-05-2010, 03:03 PM   #6 (permalink)
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 1995 c280
Location: Pittsburgh, PA
Posts: 217
It was the brushes... i took out the springs and got taller once lol and now its working .....nice trick huh?
mikhail.abraham is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Heater Blower Problem Fixed: R/R Heater Blower tracer342 R170 SLK Class 0 01-28-2010 07:03 AM
heater problem S-BOPOH W215 CL Class 4 08-29-2009 07:57 AM
Heater problem. bielefeld280se W126 S,SE,SEC,SEL,SD,SDL Class 14 02-02-2009 09:55 AM
Heater problem creates another problem Wizz190E W201 190 Class 0 03-19-2008 01:54 PM
Heater Problem Alejo Russo W123 E,CE,D,CD,TD,TE Class 4 06-16-2003 11:38 AM


All times are GMT -7. The time now is 09:53 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.