Door Lock Vacuum Pump Noise - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-20-2009, 06:28 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy Door Lock Vacuum Pump Noise

My '96 C280 door lock vacuum pump started to keep activating. I thought that it was worn out and replaced it, but it is still doing it. I noticed that there is another 'plunger' selenoid type item mounted forward of and connected to the vacuum pump.
Does anyone know what this is?
Could this be the problem?
BTW: how does the vacuum pump work?

Thanks for your suggestions!
explorer77 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-20-2009, 06:56 PM
BenzWorld Junior Member
 
Date registered: Aug 2005
Vehicle: 1992 sl500
Location: Oakland, California
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to gregheff
I am having the same problem and have the same questions. About every 5 seconds or so, the pump unit activates for a couple seconds. Are there sensors that tell the pump unit that all is locked and it can stop? Could a sensor be bad?
gregheff is offline  
#3 (permalink) Old 06-20-2009, 09:03 PM
BenzWorld Elite
 
bmeister's Avatar
 
Date registered: Oct 2007
Vehicle: 1998 c230 156k Clock spring is getting Crunchy especially in colder weather, jingle jingle
Location: Exit 98, New Jersey, U.S.
Posts: 1,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Check your connections

If the pump is still running you need to isolate the offending hose,connector or diaphragm.
If you are referring to the round part thats part of the electric pump that generates the vacuum. Posted some pics. Any look familiar?
The Central locking sys. works in conjunction with the electric modules in the doors. B
Attached Images
     
bmeister is offline  
#4 (permalink) Old 06-20-2009, 11:44 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation I have some answers....

Quote:
Originally Posted by bmeister View Post
If the pump is still running you need to isolate the offending hose,connector or diaphragm.
If you are referring to the round part thats part of the electric pump that generates the vacuum. Posted some pics. Any look familiar?
The Central locking sys. works in conjunction with the electric modules in the doors. B
My vacuum pump looks like #3 photo.
The other part I was referring to was the gas tank lid locking device. It is located forward of the vacuum pump.
I must have a leak in one of the lines to the pump, or the connections themselves. This would cause the pump to keep reactivating to maintain pressure.
Maybe I will spray some soapy water on the thing and look for bubbles.
Any other suggestions?
explorer77 is offline  
#5 (permalink) Old 06-21-2009, 04:13 PM
BenzWorld Elite
 
xvvvz's Avatar
 
Date registered: Sep 2006
Vehicle: '99 2.3L Kompressor
Location: Atlanta, GA
Posts: 1,944
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Since it is a vacuum, is it a good idea to put soapy water over the leak area and then get that sucked into the tubing/system? What about getting a Mityvac and using that to see which hoses can't maintain a vacuum?
xvvvz is offline  
#6 (permalink) Old 06-21-2009, 04:30 PM
BenzWorld Elite
 
LAMF's Avatar
 
Date registered: Jul 2006
Vehicle: 96 C36, 87 Turbo'd 190E 2.3-16, 86 SC'd 190E 2.3-16, Brabus'd C32
Location: MASS
Posts: 1,627
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
pop your trunk and pull back the lining on the passenger side at the top. you will see all the yellow vac lines going to a connection piece. one of the lines is probably popped off. its the most common place for one to pop off


87 190E 2.3-16 Cosworth- Track car-Getrag, short shift, delrin, 95a poly, Euro'd, 2 tone Recaros, custom suspension, EFI w/ Megasquirt, cast iron headers, Garrett turbo...
86 190E 2.3-16 Cossie-Old beater Getrag, slammed on BBS' Mosselman ECU, Eaton M62 SC
03 C32 ///AMG - Daily- designo edition, command, fulll Brabus CF interior, CF lips mirrors spoilers ect, and enough engine mods to destroy 911's
LAMF is offline  
#7 (permalink) Old 06-21-2009, 10:30 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Here is the biggest clue:!!

Quote:
Originally Posted by xvvvz View Post
Since it is a vacuum, is it a good idea to put soapy water over the leak area and then get that sucked into the tubing/system? What about getting a Mityvac and using that to see which hoses can't maintain a vacuum?
The hoses are VERY hard and it would be nearly impossible to remove them from the insert plugs and even more difficult to expand them to push them back on.
I did try spraying soapy water by the vacuum pump and the six line junction and found nothing. I also opened the trunk lock and inspected that connection and it seams good to.

Here is the biggest clue: The vacuum pump only keeps repeating when I am in either forward or reverse and I accelerate. It doesn't do it in park or neutral... Any more suggestions??
explorer77 is offline  
#8 (permalink) Old 06-21-2009, 10:32 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
It doesn't do it in park or neutral.

Quote:
Originally Posted by LAMF View Post
pop your trunk and pull back the lining on the passenger side at the top. you will see all the yellow vac lines going to a connection piece. one of the lines is probably popped off. its the most common place for one to pop off
The connection piece and all of the lines seem fine. I even sprayed soapy water and no bubbles...

Here is the biggest clue: The vacuum pump only keeps repeating when I am in either forward or reverse and I accelerate. It doesn't do it in park or neutral... Any more suggestions??
explorer77 is offline  
#9 (permalink) Old 06-22-2009, 08:47 AM
BenzWorld Elite
 
LAMF's Avatar
 
Date registered: Jul 2006
Vehicle: 96 C36, 87 Turbo'd 190E 2.3-16, 86 SC'd 190E 2.3-16, Brabus'd C32
Location: MASS
Posts: 1,627
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hmm theres a vacuum diagram for the locks on here somewhere. Do any of the doors pin seem weeker that the others(pop up or down less)?


87 190E 2.3-16 Cosworth- Track car-Getrag, short shift, delrin, 95a poly, Euro'd, 2 tone Recaros, custom suspension, EFI w/ Megasquirt, cast iron headers, Garrett turbo...
86 190E 2.3-16 Cossie-Old beater Getrag, slammed on BBS' Mosselman ECU, Eaton M62 SC
03 C32 ///AMG - Daily- designo edition, command, fulll Brabus CF interior, CF lips mirrors spoilers ect, and enough engine mods to destroy 911's
LAMF is offline  
#10 (permalink) Old 06-22-2009, 12:13 PM
BenzWorld Junior Member
 
Date registered: Jun 2009
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Great Suggestion!

Quote:
Originally Posted by LAMF View Post
hmm theres a vacuum diagram for the locks on here somewhere. Do any of the doors pin seem weeker that the others(pop up or down less)?
Great Suggestion!

I held the door lock buttons and tested the strength as I used my remote door lock/unlock. The drivers door was definitely weaker while locking. I would bet that the problem is inside that location!

Now I just have to figure out how to remove the inside of the door to inspect it.
explorer77 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Door lock pump won't kick into vacuum mode. Can it be saved? KingOf_Pain W126 S,SE,SEC,SEL,SD,SDL Class 13 03-24-2009 11:45 AM
Door lock vacuum pump on a 300TE 1991 daimlerbenzluvr W124 E,CE,D,TD Class 6 01-03-2008 11:15 AM
93 300SE Central Lock Vacuum Pump jhholl W140 S-Class 3 06-29-2006 05:16 PM
door lock vacuum pump davesbenz W126 S,SE,SEC,SEL,SD,SDL Class 4 07-27-2005 10:27 AM
Please help to find a used door lock vacuum pump for 1994 C220 tsecolin General Mercedes-Benz 5 12-18-2004 08:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome