replacing camshaft adjuster magnet - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#11 (permalink) Old 02-28-2009, 01:21 AM
J__
BenzWorld Newbie
 
Date registered: Feb 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i need to reseal mine as its leaking like a mofo. how much do i put on there? cover the entire flat mating area with the sealant? or jut 1 continuous circle around the hole in the middle? thnx
J__ is offline  
Sponsored Links
Advertisement
 
#12 (permalink) Old 02-28-2009, 06:04 AM
BenzWorld Elite
 
liquidusculade's Avatar
 
Date registered: May 2008
Vehicle: 2001 CLK55 AMG
Location: South East Georgia
Posts: 1,636
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
just use a circle around the sealing surface, and then do small circles around the bolt holes and it will spread out to form the gasket when you are tightening it. read the directions on the tube... thats how i did mine.

you tighten it down hand tight, let it sit for a while (whatever directions say), tighten it down more after that.

is the leak comming from the seal or the plug? if its comming from the plug you probably need a new magnet
liquidusculade is offline  
#13 (permalink) Old 02-28-2009, 11:24 AM
J__
BenzWorld Newbie
 
Date registered: Feb 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
im not too sure. i have yet to tear it apart.but the whole engine front is convered and the bottom half of the magnet is coverd in oil. my mechanic said it was the cam shaft seal and had to tear the head to replace and not worry about it. just keep it topped up. now its getting anoying so i did some research and found this. the read crank case is leaking too... arg. lol
J__ is offline  
#14 (permalink) Old 02-28-2009, 11:25 AM
J__
BenzWorld Newbie
 
Date registered: Feb 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
if it is the magnet to be replaced. is there an oem alternative? and how much do they normaly go for
J__ is offline  
#15 (permalink) Old 02-28-2009, 11:36 AM
BenzWorld Elite
 
bmeister's Avatar
 
Date registered: Oct 2007
Vehicle: 1998 c230 153k Center vents working again...Finally
Location: Exit 98, New Jersey, U.S.
Posts: 1,332
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
http://www.koperformance.com/online_ordering/make_n_model_search_catalog4.php?make_select=MBZ&y ear_select=1998&model_select=202.023|||0624abc043b 5e800478ecdd9af475918&model_select_text=C230&3flag =Y&group_id=ALL&group_text=All%20Groups&group_log= 1595620&cat_select=472&cat_text=Camshaft%20Magnet& cat_log=1595620 About 50 bucks free ship, many online stores have same item as well get the sealant I used, sensor safe. B
bmeister is offline  
#16 (permalink) Old 02-28-2009, 01:10 PM
BenzWorld Elite
 
oberoi's Avatar
 
Date registered: Mar 2006
Vehicle: 2010 C200cgi W203/SLK230/C180/230E/280SE
Location: Sydney Australia
Posts: 3,131
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
More inf. from the SLK threads - worth a read

http://www.benzworld.org/forums/r170...er-magnet.html

Oberoi
oberoi is offline  
#17 (permalink) Old 02-28-2009, 05:02 PM
BenzWorld Elite
 
liquidusculade's Avatar
 
Date registered: May 2008
Vehicle: 2001 CLK55 AMG
Location: South East Georgia
Posts: 1,636
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
its an easy change out, not alot of work, just three bolts to remove and then replace. on mine i had 3 sensors in the thermostat housing right in front of the magnet and i had to remove one to get the magnet out, but that was easy. if you are going to change it out, anticipate not driving the car for probably at least half a day since the gasket needs time to set.
liquidusculade is offline  
#18 (permalink) Old 05-02-2009, 07:05 PM
BenzWorld Newbie
 
Date registered: May 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
new here



hi. i had the same problem. dealer changed camshaft magnet adjuster after engine light went off. few days ago they had replaced bearings in the right front after i alerted them to it. i bought this car used at 22k miles. i wonder if so much wear is ok for a car with so few miles on it ? the dealer is mb usa dealer and the car was in their fleet. also is it okay to ask them to, as someone suggested here, to replace other magnetic adjusters ? don't the technicians do all this on their own ? i don't understand.
b8cha is offline  
#19 (permalink) Old 02-09-2010, 08:38 AM
BenzWorld Newbie
 
Date registered: Oct 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Unhappy Mercedes C230 Kompressor Leaking Cam Adjuster Magnet into harness

Hello, I have 02' C230 . Same problem. If i am reading all of this right.. i need to replace the magnet. I took off the sensor in front of it/ plugged into it.. and it has oil in it also.. Curious what else might have oil in it. I am checkin all that today. Anyone have part number for the "pigtail" wires.. if theres oil in the connector, does that mean new wiring harness all together??

someone please post all parts needed to fix this damn problem.. thanks.

Derek
derekcarden is offline  
#20 (permalink) Old 09-07-2010, 07:57 AM
BenzWorld Junior Member
 
Date registered: Jun 2010
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I used the Ultra Black on my camshaft adjuster replacement. The CEL went out for the rest of the summer. It came back on with the same code. Could it be that the oil leaking onto the adjuster shouldn't be leaking there, and sealing the adjuster just causes the adjuster to fail ? I'm just reaching for a solution to my issue here, and any input would be appreciated.
Thanks,
fountainpenracing is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Camshaft Adjuster Magnet replaced but p1525 doesn't go away majidmo R170 SLK Class 1 10-08-2008 06:40 PM
Camshaft adjuster leaks masterdog R170 SLK Class 4 08-05-2007 10:23 PM
Camshaft Adjuster Magnet SLTriage R129 SL Class 3 06-28-2007 11:30 AM
Leaking Cam Adjuster Magnet David in Australia R170 SLK Class 4 05-08-2006 11:24 PM
Anyone had to have camshaft adjuster replaced? HopsanGirl R170 SLK Class 7 12-08-2005 01:53 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome