1995 c220 immobiliser problem - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2009, 08:10 AM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
1995 c220 immobiliser problem

Hi folks

Im a new member and i am currently looking at buying a 1995 c220 diesel.

The only thing is that the immobiliser has started to play up on it and its a family member selling it and i know this has only started recently.

The car turns over but doesn't actually kick into life and the red and green lights on the rear view mirror and the drivers door sensor flash intermittently ie.red then green. I have looked this up on the net last night and today but cant get a clear answer as what the problem might be. The family member says that sometimes the car starts first time and sometimes it doesnt meaning the problem is intermittent. He also says that he has dis-connected the battery for 5-10 mins and on some occassions and this has cleared it only for it to come back again.

Some things i have read online say its a fault with the immobiliser which is located under the front passenger footplate and if this is replaced it will cure it but the new immobiliser has then to be programmed to the existing car key fob to work.

Any help/info/ideas on this greatly appreciated.

Thanks in advance
jamesybutler is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-23-2009, 08:58 AM   #2 (permalink)
BenzWorld Elite
 
liquidusculade's Avatar
 
Date registered: May 2008
Vehicle: 2001 CLK55 AMG
Location: South East Georgia
Posts: 1,636
if something is acting up, i always take a closer look at it. get to the immobilizer, check the connections to it. if your good with electronics, take it apart, check the solder joints ect.

if an immobilizer isnt too much money, try replacing it.

i dont really see what else could be causing the immobilizer to act up, maybe someone else can help out.
liquidusculade is offline   Reply With Quote
Old 01-23-2009, 10:48 AM   #3 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
ok thanks i will have a look at it and check the solder points etc just like the k40 relay issues
jamesybutler is offline   Reply With Quote
Old 01-25-2009, 02:33 AM   #4 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
I havent had a chance to get checking the immobiliser control unit solder points but i did get speaking to a local benz specialist yesterday and described the problem to them and they said that in their opinion it could be the a faulty rear view mirror and if that was replaced it should fix it.

They also said that it could be the immobiliser unit itself but they would need to put it onto their computer to see what it said at a cost of £40.00.

As anyone came across the rear view mirror being faulty and causing this problem and if replaced fixing it?
jamesybutler is offline   Reply With Quote
Old 01-26-2009, 02:33 AM   #5 (permalink)
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: 1994 C220 (W202) Classic and 1998 C240 (W202) Elegance
Location: Cape Town - South Africa
Posts: 323
Send a message via MSN to RonCT
Have you tried replacing the batteries in the key fob? Or checking if the red and green lights flash with your spare key?

If you replace the batteries, you may need to re-sync your key fob (although I did not have to)... you point it at the rear view press the button once and turn the ignition to position 2 (within 30 secs).

Do you have a manual for the car? It all explained in there.

Another thing: when the red and green lights flash - I can still start my car. As long as the doors unlock using the remote - it deactivates the immobilizer. It's only when your batteries are sl flat that you have to open the doors using the metal key from the passenger side that you have problems - because then the immobolizer is still activated and the car won't start (it will turn and turn untill your battery dies, but never start).

As far as I know, there's no manual override for the immobilzer which I think sucks, becuase if your remote batteries die - you're stuck. (Happened to me this weekend).

Last edited by RonCT; 01-26-2009 at 02:38 AM.
RonCT is offline   Reply With Quote
Old 01-26-2009, 03:35 AM   #6 (permalink)
BenzWorld Member
 
phoenixdragon's Avatar
 
Date registered: Nov 2008
Location: Somewhere in Suffolk, UK
Posts: 219
Use an MB STAR DAS to diagnose to obviate all the guess work. This is something the first thing they use if you send it to a Merc dealer.

It could be anything flat batteries, faulty fob, unsynchronised fob, faulty siren, faulty immobilier, faulty security module etc and the list goes on.
__________________
'05 W211
'01 R170
'97 W202
'92 W201(gone, due to old age, 11 years of good use)
phoenixdragon is offline   Reply With Quote
Old 01-26-2009, 04:12 AM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
ok cheers
jamesybutler is offline   Reply With Quote
Old 02-26-2009, 05:54 PM   #8 (permalink)
BenzWorld Junior Member
 
Date registered: Feb 2009
Vehicle: 1996 Mercedes Benz c220 ;1998 Toyota Corolla ;2006 Mercedes Benz c230; 2012 Audi A3 TDI
Location: St-Eustache, Quebec
Posts: 31
Send a message via MSN to Mahendra Send a message via Skype™ to Mahendra
Hello , I have a mercedes benz c220 1996. The battery was disconnected for a long while. I had to repair a broken exhaust camshaft. After all is done, the engine turns but does not start. There is fuel in the ramp but no spark. All lead to the infrared key not in sync. Can you please detail me the procedures to resync my key.
THank you very much.
Mahendra is offline   Reply With Quote
Old 03-02-2009, 05:31 AM   #9 (permalink)
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: 1994 C220 (W202) Classic and 1998 C240 (W202) Elegance
Location: Cape Town - South Africa
Posts: 323
Send a message via MSN to RonCT
Point your key at the rear view mirror, press the button twice, put key into ignition and turn to position 2 (within 30 secs) and it should re-sync your key.

This is what I read somewhere recently. I still have to try it out when I get a chance on my unsynced key.
RonCT is offline   Reply With Quote
Old 03-02-2009, 07:38 AM   #10 (permalink)
BenzWorld Member
 
phoenixdragon's Avatar
 
Date registered: Nov 2008
Location: Somewhere in Suffolk, UK
Posts: 219
Quote:
Originally Posted by RonCT View Post
Point your key at the rear view mirror, press the button twice, put key into ignition and turn to position 2 (within 30 secs) and it should re-sync your key.

This is what I read somewhere recently. I still have to try it out when I get a chance on my unsynced key.
Easy, take out the batteries and leave it for a couple of days, weeks or months.
phoenixdragon is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Door Lock Problem 1995 C220 jmiller W202 C-Class 17 02-07-2013 10:03 PM
c220 1995 (w202) Problem mrcoolcurrent W202 C-Class 3 03-17-2008 02:08 AM
1995 C220 head gasket problem ronsmercedes W202 C-Class 1 12-14-2005 11:41 AM
A/C vent problem on 1995 C220 Ed_1965 General Mercedes-Benz 1 07-15-2005 02:39 PM
1995 C220 Noele W202 C-Class 11 10-09-2003 09:26 PM


All times are GMT -7. The time now is 07:25 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.