c220 1996 died n wont start - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-24-2008, 05:30 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2008
Vehicle: c220 elegance
Location: england
Posts: 6
Send a message via Skype™ to twordsmine
Question c220 1996 died n wont start

hello everyone... im new in here so if im askin silly questions dont shoot me yet


ive got n reg 1996 c220 diesel in manual...


parked it fine few nights ago went home went to bed...
got up in the morning- trid to go shoppin- car wouldnt start...


what is strange- the clock on my dashboard reset itself...
tried to jump start it rollin it off the hill... didnt work...
tried to jump leads started- it did but i switched it off n the problems came back...



every time i turn the ignition on after taking the key out the clock resets itself and battery is dying right in front of my eyes when i try to crank it...



whats wrong with it??? i read som info- cranshaft position sensor or K40 relay... these are thw most probable ones





help
cheers-
david
twordsmine is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2008, 08:14 PM   #2 (permalink)
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 27,497
Sounds like an electrical issue that points straight at the battery, if voltage is too low it won't start even from a hill, once you jump it there is enough to keep it running. If I had to guess it would be a shorted cell in the battery. Replace that dog and you'll be good to go.

Take care and enjoy the ride,
Greg
__________________
Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline   Reply With Quote
Old 09-24-2008, 08:56 PM   #3 (permalink)
BenzWorld Member
 
00_230_K's Avatar
 
Date registered: Jul 2008
Vehicle: 2000 c230 kompressor
Location: hamilton ontario
Posts: 373
another possiblity is loose or bad grounds somewhere worth checking out before a battery replacement
__________________
00 C230 Kompressor

Hamilton, Canada
00_230_K is offline   Reply With Quote
Old 09-24-2008, 09:08 PM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2008
Vehicle: c220 elegance
Location: england
Posts: 6
Send a message via Skype™ to twordsmine
thanks for any replies...





1 more thing... i disconnected t battery just 2 reset t ecu... it started once as i said but now every time i lock it n open it n try to run it it doesnt start n rear mirrors lights (t ones from immobiliser) light up... not at t same time tho... they blink 1 after another... when i put t battery on charge from t other car it is charging but as soon as i try to crank it agter taking t leads away t battery dies out after like 10 cranks...




any help to figure this 1 out?




i really dont wanna get rid of it... been a good car... so.... HELP!!!
twordsmine is offline   Reply With Quote
Old 09-25-2008, 10:13 AM   #5 (permalink)
BenzWorld Senior Member
 
doin12volt's Avatar
 
Date registered: Apr 2007
Vehicle: 1995 C220 102k
Location: navarre fl
Posts: 589
Send a message via Yahoo to doin12volt
have your battery cables checked.
__________________
1995 C220 (W202)
Brilliant silver metallic


Viper Remote Start, Keyless and Security system
JVC KDAVX77 with DVD, BLUETOOTH and IPOD
Clarion component speakers
2 MTX 10" subwoofers - Vented
Total 500.1 subwoofer amplifier
17" MB wheels - 2002 E class / Chrome Star centercaps
Clear corner markers
35% Tint all around
LED 3rd brakelight
doin12volt is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
1996 C220 won't start riscfl W202 C-Class 6 06-30-2008 08:20 AM
94 C220 wont start and reverse slips-please help maharodger W202 C-Class 26 09-28-2007 01:17 PM
After wire harness change temp gauge wont work, and now wont start daanmuller W140 S-Class 4 06-14-2007 08:00 AM
battery died.,... Wont Jump Start ???? MeanBenz W208 CLK Class 3 01-13-2007 02:17 PM
Help: 73 280SE 4.5 A/C wont turn on // speedo died WJR4 Vintage Mercedes-Benz 5 11-17-2006 06:33 PM


All times are GMT -7. The time now is 07:23 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.