1996 C220 won't start - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-26-2008, 01:46 PM
BenzWorld Junior Member
 
Date registered: Jul 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
1996 C220 won't start

Guys,

Hopefully you can help as this one is a puzzle.

1996 C220 won't start, attempts to start has the remote keyless red/green lights on the rear view flashing. I can use the remote or the "manual" key to unlock and lock the car. Using the fob will unlock the car with the flashing green light. Locking with fob will flash the red light - so it locks/unlocks just like it should. However, when I get IN the car and try to start it the red/green lights flash. Ideas? I did notice that the fuel door lock (plunger thingy) doesn't work and leaves the fuel door unlocked. I'm wondering if some how this factors into it. I replaced the immobiliser module to no avail - so that doesn't appear to be the problem. Should I replace the ignition perhaps?? Any ideas would be helpful.
riscfl is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-26-2008, 06:31 PM
BenzWorld Senior Member
 
redhope's Avatar
 
Date registered: Apr 2008
Vehicle: 190E-16v & C230
Location: E.S., Maryland
Posts: 508
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Does the ignition accept the key (if it's the infrared one)? Or is your ignition key the standard laser cut key?

Project: 1986 190E 2.3-16v Black
PO: 1998 C230 2.3 Imperial Red
Commuter: 2009 Toyota Corolla Sport
redhope is offline  
#3 (permalink) Old 06-26-2008, 08:18 PM
BenzWorld Elite
 
cjshade's Avatar
 
Date registered: Nov 2007
Vehicle: 96' C220
Location: So Cal USA
Posts: 1,275
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Post Starting problem

Explain what you mean by attemts to start. ex: Engine cranks but does not fire...

I had this same problem early in my C 220 ownership. Turned out I was inadvertantly squeezing the lock button on the key and triggering the immobilizer. After my Wife stopped laughing at me I was able to start the car.

Good Luck!

C as in 220

Last edited by cjshade; 06-26-2008 at 08:21 PM.
cjshade is offline  
#4 (permalink) Old 06-26-2008, 08:21 PM
BenzWorld Senior Member
 
redhope's Avatar
 
Date registered: Apr 2008
Vehicle: 190E-16v & C230
Location: E.S., Maryland
Posts: 508
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yeah I needed a clarification on that myself. If it's a infrared key then it may be the problem. But if it's cut key, and it turns with symptoms then we can go from there. I really shouldn't be thinking about this when I have a headache. lol

Project: 1986 190E 2.3-16v Black
PO: 1998 C230 2.3 Imperial Red
Commuter: 2009 Toyota Corolla Sport
redhope is offline  
#5 (permalink) Old 06-27-2008, 07:53 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: 1994 C220 (W202) Classic and 1998 C240 (W202) Elegance
Location: Cape Town - South Africa
Posts: 323
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via MSN to RonCT
This sounds like an immobilzer problem. I have exactly the same flashing green and red lights, key fob and switch blade style metal key.

Try this: open the door, get in, press the key fob so it locks (with red light). The press again so it opens (green light flashing). insert key immediately and start the car...

If it doesn't work - just keep repeating till the immobilizer is deactivated.
RonCT is offline  
#6 (permalink) Old 06-30-2008, 08:20 AM
BenzWorld Junior Member
 
Date registered: Jul 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by redhope View Post
Does the ignition accept the key (if it's the infrared one)? Or is your ignition key the standard laser cut key?
If by accept you mean insert. Both keys (laser cut and the spare, etc) all fit in the ignition, none will start the car.

The car won't start, meaning it "turns over" but won't actually start the engine. Just like you'd expect if the immobilizer is tripped.

I've unlocked the car with the fob (and the green light blinks). I get out of the car, lock it with the manual key by inserting it into the driver's door. I then unlock it the manual way and get in the car and try to start it with either key and the immobilizer is still going off (red and green blinking lights - no ignition).
riscfl is offline  
#7 (permalink) Old 06-30-2008, 08:20 AM
BenzWorld Junior Member
 
Date registered: Jul 2006
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by RonCT View Post
This sounds like an immobilzer problem. I have exactly the same flashing green and red lights, key fob and switch blade style metal key.

Try this: open the door, get in, press the key fob so it locks (with red light). The press again so it opens (green light flashing). insert key immediately and start the car...

If it doesn't work - just keep repeating till the immobilizer is deactivated.
I've tried this routine to no avail.....
riscfl is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1996 C220 - No heat dj_pi W202 C-Class 3 06-11-2012 08:13 AM
1996 C220 magnum11 W202 C-Class 6 04-19-2008 11:14 PM
"For Sale" C220 (1996) luxboy General Mercedes-Benz 3 07-29-2004 11:17 AM
1996 C220 dub27 W203 C-Class 0 11-07-2002 12:42 PM
1996 C220 Guest (MBNZ) W202 C-Class 1 03-19-2002 04:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome