1996 C220 stall,rough idle. ?MAS? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-24-2008, 11:38 AM Thread Starter
BenzWorld Member
BenzSittinON22s's Avatar
Date registered: Jul 2007
Vehicle: 1996 C220 & 2000 ML430 & 1997 E320
Location: MA
Posts: 145
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1996 C220 stall,rough idle. ?MAS?

i have a 1996 c220 i love the car. the only thing is when i start it in the COLD the cars rpms dont go up and then shuts off. to keep the car on i must hold the accelerator after 10 sec of the foot being on the accelerator the idle just stays extremly low but car still runs.. at a red light or stop the car bucks when giving gas and sometimes will stall(this only happens in the cold anything over 45 degrees it starts fine but RPMs are still extremly low). im thinking its the MAS, can anyone help i would greatly appreciate it.
BenzSittinON22s is offline  
Sponsored Links
post #2 of 2 (permalink) Old 02-24-2008, 02:52 PM
BenzWorld Elite
cjshade's Avatar
Date registered: Nov 2007
Vehicle: 96' C220
Location: So Cal USA
Posts: 1,275
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Post Bad MAF

It is very common on these cars to have the MAF go bad and make the car do all kinds of crazy behavior like you described. On ours it would do something different every time we went to drive it. We thought we had a fuel supply problem, then an electrical problem etc... After chasing around and replacing the Crank Position Sensor we took it to a shop and sure enough it was the MAF showing a code on the shop computer. It did not code on the small OBD II computer that I used however. I later found out this is also common. The part is easy to replace and available online. I've heard of people cleaning them but it did not work for me. I've read on this site that you can find the element only for around $185. I found one online for $285.00 for the whole part. I was told by the shop that they would have to wash the computer of codes after it was installed. I don't know if disconnecting the battery will do as good of a reset job or not.

Good luck,

C as in 220
cjshade is offline  
Sponsored Links

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Engine stall at idle ponch W203 C-Class 19 03-15-2012 09:43 AM
    87 300E rough idle,full pedal=stall? Darkstar7981 W124 E,CE,D,TD Class 3 01-28-2008 11:15 PM
    COld Start & stall after in gear & rough idle at stop rbartholomew W126 S,SE,SEC,SEL,SD,SDL Class 6 10-28-2006 01:30 AM
    low idle stall rousch W123 E,CE,D,CD,TD,TE Class 1 07-11-2004 10:52 AM
    Rough Start and Stall Guest (MBNZ) W124 E,CE,D,TD Class 3 04-10-2001 02:52 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome