BAS / ASR Light Still On - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-21-2005, 03:22 AM
BenzWorld Newbie
 
Date registered: Dec 2005
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
BAS / ASR Light Still On

I have a 1998 C Class Mercedes Benz and the BAS / ASR is on permantly.

I have brand new front ABS sensors, but this has not resolved the issue, i have tried to reset the light but that did not work.

Now i have noticed that if i start the car with my foot on the break pedal, the BAS / ASR light switches off, but as soon as i light my foot off the break pedal, the light is back on again.

Can anyone advice?
jaypabla is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-23-2005, 05:42 AM
BenzWorld Junior Member
 
Date registered: Nov 2003
Vehicle: 1998 C280 Sport
Location: New Jersey
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RE: BAS / ASR Light Still On

Have you tried replacing the brake pedal switch?
kxmills is offline  
#3 (permalink) Old 12-31-2005, 11:05 AM
BenzWorld Junior Member
 
Date registered: Dec 2005
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RE: BAS / ASR Light Still On

Follow this Benzworlkd link. I just triued it, it took me 1/2 hour on my 1999 C280 and it worked, the light(s) arre gone.

http://www.benzworld.org/forums/forums/thread-view.asp?tid=1166641&posts
phidelt0135 is offline  
#4 (permalink) Old 01-02-2006, 12:20 PM
BenzWorld Member
 
benzpimp's Avatar
 
Date registered: Oct 2005
Vehicle: 2009 C300
Location: Tulsa, OK
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
RE: BAS / ASR Light Still On

My BAS/ASR light stays on to. and the solution is just to replace the brake pedal switch.

Thank You
-Justin
benzpimp is offline  
#5 (permalink) Old 07-11-2006, 01:02 PM
BenzWorld Junior Member
 
Date registered: Jun 2006
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The same thing just happened to mine this morning. Going to purchase the switch and do the deed this weekend
LGBenzo is offline  
#6 (permalink) Old 07-28-2006, 12:41 PM
BenzWorld Junior Member
 
Date registered: Jul 2006
Vehicle: Mercdes CL500 2003
Location: England
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Talking bas/asr

Hi

My clk Bas/asr light has been coming on for 4 weeks

I have just replace the brake connection part - which only took 5 mins

havn't seen the light on yet - but it still is early days yet


Thanks for the tip off regarding the seat fuse in the boot - mine seat has finally started to work after 4 months


Ren zo 85

Last edited by ren zo 85; 07-28-2006 at 12:45 PM. Reason: ok
ren zo 85 is offline  
#7 (permalink) Old 07-28-2006, 12:56 PM
BenzWorld Junior Member
 
Date registered: Jul 2006
Vehicle: Mercdes CL500 2003
Location: England
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by ren zo 85
Hi

My clk Bas/asr light has been coming on for 4 weeks

I have just replace the brake connection part - which only took 5 mins

havn't seen the light on yet - but it still is early days yet


Thanks for the tip off regarding the seat fuse in the boot - mine seat has finally started to work after 4 months


Ren zo 85
where can I white dials for CLK 1998 with silver needles
ren zo 85 is offline  
#8 (permalink) Old 07-30-2006, 09:40 AM
BenzWorld Junior Member
 
Date registered: Jul 2006
Vehicle: Mercdes CL500 2003
Location: England
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
cruise control

Dose any one knows why my cruise control only works beteen 40-60mph
if I click it in @ 70mph it stays on for 10 sec then cuts out - but works below 60mph ?


Also My Bas/asr still comes on even though I have change the brake pedal swich

It only comes on mostly in the mornings then goes out when car gets hot later in the day
ren zo 85 is offline  
#9 (permalink) Old 07-31-2006, 05:08 AM
BenzWorld Junior Member
 
Date registered: Aug 2005
Vehicle: 1998 C230 K
Location: SOUTH AFRICA
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi

I had a similar problem. Found that one of the brake light bulbs was not working .
YOGGI is offline  
#10 (permalink) Old 08-01-2006, 04:39 AM
BenzWorld Junior Member
 
Date registered: Jul 2006
Vehicle: Mercdes CL500 2003
Location: England
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
no - they both work fine !
I wonder if there are any sensors anywhere ?
ren zo 85 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W202 C-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome