93 190E 2.6 Rough Running???? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-04-2011, 06:49 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Feb 2011
Vehicle: '93 300D - 144k miles
Location: Upstate, SC
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
93 190E 2.6 Rough Running????

I am looking at purchasing a 93 190# 2.6 w approx 250k miles.

It has been sitting almost a year and now its running rough the owner says... It runs rough at idle and hesitates upon acceleration. Could this be as simple as a gas issue? Maybe degraded vacuum hoses? Could it be an engine issue? What is the chances its something major if no smoke and runs well otherwise.

Also the AC works but doesn't blow, assume it needs a new blower motor?

Car was maintained in past had a tranny rebuild and other items replaced.

Is this too many miles for a gas engine? $1500 maybe get it less...

Whats anyone's opinion?

Thanks for any advice, what to look for, etc...
upst8clay is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-04-2011, 08:26 AM
BenzWorld Member
 
Date registered: May 2010
Vehicle: 1992 190E 2.6
Posts: 95
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think all you r questions are valid and it could be any of the above. What is the maintenance history? Click on my name and the statitics tab and you can see a lot of posts about rpm and vacuum hose repalcement, there is alot of detail there of stuff I did. I also had hesitation. Also the fan I would check fuses first. My blower never stopped but it squeaked a lot and I replaced it.
bachmanw is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    User Tag List

    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    I figured it out running rough problem and idle rough danberg1 W126 S,SE,SEC,SEL,SD,SDL Class 11 07-21-2010 07:20 PM
    2.6 190E Running Rough. What Did I Break? T Love W201 190-Class 2 06-16-2010 06:12 PM
    1990 190e 2.6 Suddenly running rough!!! Waves4Me W201 190-Class 5 03-07-2009 10:02 AM
    running rough dugald R/C107 SL/SLC Class 17 05-10-2007 12:09 PM
    rough running phoenix7 W124 E,CE,D,TD Class 5 12-11-2003 07:44 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome