Replacing Voltage Regulator - 1993 2.3 - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-02-2009, 02:12 PM   #1 (permalink)
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Replacing Voltage Regulator - 1993 2.3

Hey guys....quick question. Do I need to remove & unplug this black cover on the alternator back to replace the voltage regulator? Or is the voltage regulator not in my line of sight from above where I'm standing?

Here is a pic of what I'm looking at when I'm looking from above. Any help is appreciated. I'm looking to complete this task within the next couple of hours when the engine cools.

__________________
Mike

1988 BMW 325is
1996 Mercedes E320
Bimmerista is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-02-2009, 05:33 PM   #2 (permalink)
BenzWorld Member
 
jsbarks's Avatar
 
Date registered: Mar 2008
Vehicle: 84 190D
Location: Ontario
Posts: 398
Mercedes Voltage Regulator Install

jack the car up of you need room and crawl under!

Last edited by jsbarks; 06-02-2009 at 05:37 PM.
jsbarks is offline   Reply With Quote
Old 06-03-2009, 05:42 PM   #3 (permalink)
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 518
How did you make out on replacing the voltage regulator on your 93?
Ignatz is offline   Reply With Quote
Old 06-04-2009, 12:17 PM   #4 (permalink)
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
I didn't. I decided to put it off for another day.
Bimmerista is offline   Reply With Quote
Old 06-04-2009, 03:33 PM   #5 (permalink)
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 518
Thanks for getting back. I knew you you change the regulator in the older alternators, but did'nt know if it could be done on a 93, with that black plastic cover. I'm at 200,800 and probably due for a regulator.
Ignatz is offline   Reply With Quote
Old 06-10-2009, 04:08 PM   #6 (permalink)
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 518
I got nervous with my mileage so I replaced my regulator. I dropped the alternator to make the job easier. The black cover has to come off to get to the regulator. Just take your time removing the cover so you don't break the tabs. I put a new belt on while everything was apart. My 200,000 mile regulator had one contact (brush) that was definetly short. I also dis-connected the battery before I started. Gota keep this junk runnin!
Ignatz is offline   Reply With Quote
Old 06-13-2009, 08:06 PM   #7 (permalink)
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Ended up taking my car to a reputable shop since I didn't have much time to perform this task due to work & whatnot.

The shop replaced the alternator & voltage regulator. All is fine for about 3 days, then this afternoon, while I was driving on the freeway going about 65MPH with the A/C on (it was about 100F in Dallas today) the ABS light faintly comes on. As soon as I turn it off, the light goes off. I could only endure the heat for about a minute, so I turn on the A/C again and within several seconds, the ABS light comes on again.

I park, do my errands, and come back out to a dead car. I have to get it jumped before I'm on the road again. Any idea what this problem may be??
Bimmerista is offline   Reply With Quote
Old 06-14-2009, 05:17 PM   #8 (permalink)
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 518
Your going to have to run it by that shop so they can check out the alternator. Does'nt sound like its charging. I mounted a small digital voltage guage in my ash tray years back. Mines charging identical to the old regulator.
Ignatz is offline   Reply With Quote
Old 06-16-2009, 06:43 PM   #9 (permalink)
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
"Charging System Failure"

Took it to 2 shops, they tested the battery and alternator....both told me the same thing. They didn't exactly know what the problem was and I was not prepared to leave it at the shop to get it fixed. Has anyone else had a similar problem occur?? What does "Charging System Failure" mean?? I already have a new alternator and relatively new battery. Both tested fine.
Bimmerista is offline   Reply With Quote
Old 06-16-2009, 08:08 PM   #10 (permalink)
BenzWorld Member
 
jsbarks's Avatar
 
Date registered: Mar 2008
Vehicle: 84 190D
Location: Ontario
Posts: 398
what symptoms was yoiur car having again to make you think a charging issue?
jsbarks is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
What next changed voltage regulator no voltage Wayne4756 W124 E,CE,D,TD Class 5 05-14-2009 08:35 AM
Does replacing Voltage Regulator increase Alternator life? rph74 W126 S,SE,SEC,SEL,SD,SDL Class 3 03-27-2007 05:34 PM
Replacing voltage regulator/brushes my260e W124 E,CE,D,TD Class 5 01-01-2007 05:39 PM
Replacing Voltage Regulator Sergio W124 E,CE,D,TD Class 3 11-24-2005 01:39 PM
Help!! Replacing Voltage Regulator/Alternator Removal. Sergio W124 E,CE,D,TD Class 1 11-22-2005 05:54 PM


All times are GMT -7. The time now is 06:57 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.