Replacing Voltage Regulator - 1993 2.3 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-02-2009, 03:12 PM
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Replacing Voltage Regulator - 1993 2.3

Hey guys....quick question. Do I need to remove & unplug this black cover on the alternator back to replace the voltage regulator? Or is the voltage regulator not in my line of sight from above where I'm standing?

Here is a pic of what I'm looking at when I'm looking from above. Any help is appreciated. I'm looking to complete this task within the next couple of hours when the engine cools.


Mike

1988 BMW 325is
1996 Mercedes E320
Bimmerista is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-02-2009, 06:33 PM
BenzWorld Member
 
jsbarks's Avatar
 
Date registered: Mar 2008
Vehicle: 84 190D
Location: Ontario
Posts: 398
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mercedes Voltage Regulator Install

jack the car up of you need room and crawl under!

Last edited by jsbarks; 06-02-2009 at 06:37 PM.
jsbarks is offline  
#3 (permalink) Old 06-03-2009, 06:42 PM
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
How did you make out on replacing the voltage regulator on your 93?
Ignatz is offline  
#4 (permalink) Old 06-04-2009, 01:17 PM
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I didn't. I decided to put it off for another day.

Mike

1988 BMW 325is
1996 Mercedes E320
Bimmerista is offline  
#5 (permalink) Old 06-04-2009, 04:33 PM
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks for getting back. I knew you you change the regulator in the older alternators, but did'nt know if it could be done on a 93, with that black plastic cover. I'm at 200,800 and probably due for a regulator.
Ignatz is offline  
#6 (permalink) Old 06-10-2009, 05:08 PM
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I got nervous with my mileage so I replaced my regulator. I dropped the alternator to make the job easier. The black cover has to come off to get to the regulator. Just take your time removing the cover so you don't break the tabs. I put a new belt on while everything was apart. My 200,000 mile regulator had one contact (brush) that was definetly short. I also dis-connected the battery before I started. Gota keep this junk runnin!
Ignatz is offline  
#7 (permalink) Old 06-13-2009, 09:06 PM
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Ended up taking my car to a reputable shop since I didn't have much time to perform this task due to work & whatnot.

The shop replaced the alternator & voltage regulator. All is fine for about 3 days, then this afternoon, while I was driving on the freeway going about 65MPH with the A/C on (it was about 100F in Dallas today) the ABS light faintly comes on. As soon as I turn it off, the light goes off. I could only endure the heat for about a minute, so I turn on the A/C again and within several seconds, the ABS light comes on again.

I park, do my errands, and come back out to a dead car. I have to get it jumped before I'm on the road again. Any idea what this problem may be??

Mike

1988 BMW 325is
1996 Mercedes E320
Bimmerista is offline  
#8 (permalink) Old 06-14-2009, 06:17 PM
BenzWorld Senior Member
 
Date registered: Nov 2002
Vehicle: 1993 190e-2.3
Location: Birdsboro, PA
Posts: 519
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Your going to have to run it by that shop so they can check out the alternator. Does'nt sound like its charging. I mounted a small digital voltage guage in my ash tray years back. Mines charging identical to the old regulator.
Ignatz is offline  
#9 (permalink) Old 06-16-2009, 07:43 PM
BenzWorld Member
 
Bimmerista's Avatar
 
Date registered: Mar 2007
Vehicle: 1996 E320
Location: North Texas
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
"Charging System Failure"

Took it to 2 shops, they tested the battery and alternator....both told me the same thing. They didn't exactly know what the problem was and I was not prepared to leave it at the shop to get it fixed. Has anyone else had a similar problem occur?? What does "Charging System Failure" mean?? I already have a new alternator and relatively new battery. Both tested fine.

Mike

1988 BMW 325is
1996 Mercedes E320
Bimmerista is offline  
#10 (permalink) Old 06-16-2009, 09:08 PM
BenzWorld Member
 
jsbarks's Avatar
 
Date registered: Mar 2008
Vehicle: 84 190D
Location: Ontario
Posts: 398
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
what symptoms was yoiur car having again to make you think a charging issue?
jsbarks is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W201 190 Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
What next changed voltage regulator no voltage Wayne4756 W124 E,CE,D,TD Class 5 05-14-2009 09:35 AM
Does replacing Voltage Regulator increase Alternator life? rph74 W126 S,SE,SEC,SEL,SD,SDL Class 3 03-27-2007 06:34 PM
Replacing voltage regulator/brushes my260e W124 E,CE,D,TD Class 5 01-01-2007 06:39 PM
Replacing Voltage Regulator Sergio W124 E,CE,D,TD Class 3 11-24-2005 02:39 PM
Help!! Replacing Voltage Regulator/Alternator Removal. Sergio W124 E,CE,D,TD Class 1 11-22-2005 06:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome